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Backing up Chief Architect Content

The information in this article applies to:

QUESTION
I want to create a backup of my program and all of its content. What is the most
e cient way to do this?

ANSWER
Backing up data simply means creating a copy of your les and saving them in a safe
location so that they can be retrieved in the event of a problem. It's important to
routinely back up your important data - including Chief Architect/Home Designer
drawings and user content - because in the event of a hard drive crash or other
computer malfunction, it's possible you might lose your work, or access to it, unless
you have copies saved somewhere else.

Additionally, it's helpful to have this same content backed up so that it can be
transferred to another computer for use with the Chief Architect software.
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For information about restoring backed up Chief Architect/Home Designer
data or migrating it to a new computer, see KB-00091: Restoring Chief
Architect Content (https://www.chiefarchitect.com/support/article/KB-
00091/restoring-chief-architect-content.html)

For safety's sake, it is best to use a strategy that utilizes a backup location somewhere
other than your local computer. Options include:

Burning files onto a DVD;
Copying files to a removable storage device such as a USB flash drive or external
drive;
Copying files to a server or other location on your network;
Copying files to an online storage site or have your backup service do it for you.

There are a number of di erent Chief Architect/Home Designer les that you may want
to back up. You can back up some or all of them, depending on your needs:

Plan and Layout Files
The Program Installer
Core, Bonus, and Manufacturer Catalogs
The User Catalog
Toolbars, Hotkeys, Templates, and other user data

Regardless of where you choose to save your backed up les, it is helpful to know how
to copy and paste les in your operating system's le system. There are several ways,
and all are easy.

When copying les associated with Chief Architect or Home Designer, it is important to
begin by saving your work and closing out of the software.

To copy and paste les
1. Open the File Explorer in Windows or Finder in macOS, navigate to a file you would

like to copy to the system Clipboard, and select it.

2. If you would like to select multiple files, hold down the Ctrl key on your keyboard if
you're using Windows, or the Command key if you're using a Mac, then click on
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additional files to add them to your selection.

3. Copy the selected file or files to the Clipboard:

On Windows, click the Copy button in the Home ribbon, right-click and select
Copy from the contextual menu, or press Ctrl + C.

On macOS, select Edit> Copy from the menu bar, right-click (Control-click) and
select Copy from the contextual menu, or press Command + C.

On a Mac, hold down the Control key while clicking to initiate a right-
click command. More information about right-click commands on
Apple input devices can be found in the following Apple resource:
Right-click on Mac (https://support.apple.com/guide/mac-help/right-
click-mh35853/mac#).

4. Once they are copied to the Clipboard, navigate to the location where you would
like to paste a copy of the selected file(s).

5. Paste the selected file or files:

On Windows, click the Paste button in the Home ribbon, right-click and select
Paste from the contextual menu, or press Ctrl + V.

On macOS, select Edit> Paste Item from the menu bar, right-click (Control-click)
and select Paste Item from the contextual menu, or press Command + V.

To back up Plan and Layout les
Plan and layout les often reference a variety of other les such as images and PDFs.
When backing up plans and layouts, it is important that these referenced les be
included. A great way to do this is to use the Backup Entire Plan/Layout tool in the
program so that all associated les, including those that have been imported, are
backed up to a single folder.

https://support.apple.com/guide/mac-help/right-click-mh35853/mac#


It's important to be aware that if the Backup Entire Plan/Layout tool is used in a layout
le, the layout le, as well as all the plans associated with the layout will be backed up.

However, if this tool is used while in a plan le, the layout le will not be included.

1. Select Open Plan  or Open Layout* , and proceed to open the file that you

want to backup.

*Layout files are only available in Home Designer Pro, Chief Architect Interiors, and
Chief Architect Premier.

2. From the menu, navigate to File> Backup Entire Plan/Layout  and in the dialog

that displays:

Leave the radio button set to Backup Plan Files and All Referenced Files.

Be sure to check the Send Backup Files to Zip Archive box to create a
compressed/zipped folder (Recommended).

Click OK.

3. Browse your chosen backup location, then click Save.

Note: If the Send Backup Files to Zip Archive box was not checked in the step
above, you will need to create a new, empty file folder on the Desktop for the
plan and referenced files to be backed up to:

On a Windows operating system, right-click in an empty area and choose
"New> Folder".



On a macOS system, right-click in an empty area and choose "New Folder".

4. If backed up from a plan, a copy of the plan file, including the associated files such
as images, textures, PDF's, and backdrops will now be backed up.

If backed up from a layout, a copy of the layout, all plan files sent to the layout, and
the associated files such as images, textures, PDF's, and backdrops will now be
backed up.

To back up the Program Installer
The program installer allows you to install the Chief Architect/Home Designer program
onto a supported Windows or macOS system. This Installer le can be downloaded
from the Digital Locker (https://accounts.chiefarchitect.com/digital-locker/) area of your
Online Chief Architect Account (https://accounts.chiefarchitect.com/). Installers for the
most recent program versions are available online; however, for archival purposes
many people opt to keep their own copies of installers for the program versions that
they have licenses for.

1. In the Digital Locker, click the DOWNLOAD link on the right for the program version
you want to back up.

2. On the next page, select the Windows or Mac option, then click the DOWNLOAD
button.

https://accounts.chiefarchitect.com/digital-locker/
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3. This will download a .msi (Microsoft Installer Database) file on Windows or a .dmg
(Apple Disk Image) file on macOS.

On Windows, the icon for a .msi file will look similar to the image below: 

On macOS, the icon for a .dmg file will look similar to the image below:

Note: The name of the file will vary depending on what version of the
program installer you have, but in general, the file name will begin with the
product title, followed by a version number, and ending with the .msi file
extension on Windows, and .dmg on a Mac.



4. If you are presented with the option to Save or Run the file, choose Save, and
specify a location you'd like to download and save the installer to.

If the download starts automatically, the installer will likely be located in the
Downloads folder on your system when it's finished downloading. 

5. Once downloaded, make a copy of the installer file in your chosen backup location
using the Copy and Paste commands, as described above.

To back up Core, Bonus, and Manufacturer Catalogs
By default, Core, Bonus, and Manufacturer catalogs are saved in the ProgramData
folder on Windows or the Application Support folder on macOS. These are hidden le
locations and may require you to use the "Run" utility on Windows or the "Go to
Folder"  function in macOS to access.

Close out of Chief Architect or Home Designer prior to completing the following steps.

1. Browse to the file location where your library content is stored:

On Windows, press the Windows Key  and the letter R on your keyboard at
the same time to open the Run dialog. Type %programdata%  and then click
OK to open the Program Data folder.

On macOS, open Finder, select Go > Go to Folder, type: /Library/Application
Support  and click Go to open the Application Support folder.



In Chief Architect X10, Home Designer Pro 2019, and newer program
versions, the ability to move these libraries was implemented. If you
have moved your libraries to a custom location, then you will want to
instead reference this location to backup these les. You can con rm
the location of your "System Library Database Folder" on the Folders
panel of the program's Preferences dialog.

2. Open the folder with the same name as the program and version you're using.

For example, "Chief Architect Premier X15" or "Home Designer Pro 2024".

3. On your keyboard, hold the Ctrl key if you're using Windows, or Command if you're
using a Mac, and click to group select the following folders:

Bonus Libraries
Core Libraries
Manufacturer Data
Manufacturer Libraries
Referenced Files

Do NOT copy or backup the Program_Data folder or the
dont_change.dat le. They contain unique, encrypted registration
information and if you try to use a copied and pasted version of either,
your license registration will no longer be recognized by our registration
server.

4. When the folders are selected as a group, make a copy of them in your chosen



backup location using the Copy and Paste commands, as described above.

To back up the User Catalog
The User Catalog stores custom items that you may have added to the Chief
Architect/Home Designer Library Browser. To back up this content, use the Export
Library function.

1. Launch the version of the program that you're using and create a New Plan .

2. Select View> Library Browser  to open the Library Browser if it's not already

open.

3. Right-click the User Catalog folder and select Export Library from the contextual
menu.

You can also export just individual items or secondary folders by right-clicking on
those items.

On a Mac, hold down the Control key while clicking to initiate a right-
click command. More information about right-click commands on Apple
input devices can be found in the following Apple resource: Right-click
on Mac (https://support.apple.com/guide/mac-help/right-click-
mh35853/mac#).

https://support.apple.com/guide/mac-help/right-click-mh35853/mac#


4. In the Export Library Data dialog:

Specify your chosen backup location as the place where you would like to save
your backed up User Catalog.

Type a short, descriptive name for the library being exported.

Ensure that the Library File with Textures/Images (*.calibz) option is selected.

Click Save.

Note: This export process may take some time, depending on the size of
the library. If you have an extensive User Catalog and it's taking a
considerable amount of time to export, it may be necessary to consolidate
the catalog or separate it into smaller folders to export

To back up Toolbars, Hotkeys, Templates, and other user data
Toolbars, hotkeys, template les, and other user-speci c data is saved in the Chief
Architect/Home Designer Data folder. The Chief Architect/Home Designer Data folder
is located in your Documents directory by default, and its name will begin with the full
name and version of your Chief Architect/Home Designer program followed by the
word Data - for example, "Chief Architect Premier X15 Data" or "Home Designer Pro
2024 Data".

The default le path for this folder on Windows may be one of the following, but may
also vary depending on your product and version:

C:\Users\ [ YOUR USERNAME ] \Documents\Chief Architect Premier X15 Data

C:\Users\ [ YOUR USERNAME ] \Documents\Home Designer Pro 2024 Data

And on macOS:

/Users/ [ YOUR USERNAME ] /Documents/Chief Architect Premier X15 Data



/Users/ [ YOUR USERNAME ] /Documents/Home Designer Pro 2024 Data

If you have moved your Chief Architect/Home Designer Data folder to a
custom le location, refer to the location you have moved it to instead.
You can con rm the location of your Data folder in the Preferences dialog.
On the Folders panel, take note of the le path next to the "My Data
Folder" or "Data Folder for Current User" heading.

You can backup the entire Chief Architect/Home Designer Data folder if you wish, or
only the sub-folders and les that are of importance to you. Each of these are
described in further detail below:

Archives - contains automatically archived plan and layout files.
Backdrops - contains custom backdrop images. These are also exported when the
User Catalog is backed up, as described above.
Database Libraries - User Catalog file location. This is also exported when the User
Catalog is backed up, as described above.
Hotkeys - contains an .XML file that links commands/tools in Chief Architect to a
sequence of keyboard keys/presses.
Images - contains custom images. These are also exported when the User Catalog is
backed up, as described above.
lex - contains customized dictionaries.
Patterns - contains custom .PAT files. These are also exported when the User
Catalog is backed up using the method mentioned above.  
Scripts - contains custom scripts in the Ruby programming language that may be
referenced by some plans created in Chief Architect Premier.
Templates - contains plan and layout template files.
Textures - contains image files that were used for customizing or creating materials.
These are also exported when the User Catalog is backed up, as described above.
Toolbars - contains files relating to the toolbars in the program.
mmaster.mat - The Master Materials List file.
sheetSizes.sheet - contains user-created units of measurement.
_MigrateBackup - If you migrated legacy settings into the current version, additional
folders with names appended with _MigrateBackup may also be present.
Migrate_Settings_Log.txt - If you migrated legacy settings into the current version,
this log file will detail what was migrated. 
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If the Chief Architect Premier Data folder is renamed, moved or deleted,
the program will automatically replace it using default information from
the program's installation folder. When this occurs, customized user
settings and custom user library content will not be available.

Do NOT backup, copy, or modify any of this content while Chief Architect is
running.

Moving Library Content to the Cloud or Other Custom Location (/support/article/KB-
03090/moving-library-content-to-the-cloud-or-other-custom-location.html)

Organizing your Plan and Layout Files (/support/article/KB-00562/organizing-your-
plan-and-layout-files.html)

Restoring Chief Architect Content (/support/article/KB-00091/restoring-chief-
architect-content.html)

Using Chief Architect on Multiple Computers (/support/article/KB-00956/using-chief-
architect-on-multiple-computers.html)

Using the Backup Entire Plan/Layout Tool to Send Files to Another User
(/support/article/KB-00987/using-the-backup-entire-plan-layout-tool-to-send-files-to-
another-user.html)

Related Articles

/support/article/KB-03090/moving-library-content-to-the-cloud-or-other-custom-location.html
/support/article/KB-00562/organizing-your-plan-and-layout-files.html
/support/article/KB-00091/restoring-chief-architect-content.html
/support/article/KB-00956/using-chief-architect-on-multiple-computers.html
/support/article/KB-00987/using-the-backup-entire-plan-layout-tool-to-send-files-to-another-user.html
https://chieftalk.chiefarchitect.com/
/blog/
https://www.facebook.com/ChiefArchitect
https://www.youtube.com/user/ChiefArchitectInc
https://www.instagram.com/chiefarchitect/




(https://www.houzz.com/pro/chiefarchitect/)


(https://www.pinterest.com/chiefarchitect/)
208-292-3400 (tel:+1-208-292-3400)  © 2000–2023 Chief Architect, Inc.  Terms of Use (/company/terms.html)

Privacy Policy (/company/privacy.html)

https://www.houzz.com/pro/chiefarchitect/
https://www.pinterest.com/chiefarchitect/
tel:+1-208-292-3400
/company/terms.html
/company/privacy.html

	Architectural Home Design Software
	Backing up Chief Architect Content
	QUESTION
	ANSWER
	To copy and paste files
	To back up Plan and Layout files
	To back up the Program Installer
	To back up Core, Bonus, and Manufacturer Catalogs
	To back up the User Catalog
	To back up Toolbars, Hotkeys, Templates, and other user data



