Converting Plan Files to .dwg or .dxf Format

Reference Number: KB-00013
Last Modified: July 16, 2015

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors


I have a Chief Architect plan file that I need to open in AutoCAD. How do I convert it to .dwg or .dxf?


Converting a Chief Architect plan file into either a two- or three-dimensional AutoCAD-compatible .dwg or .dxf file can be done easily using the export function.

To export a 3D .dwg or .dxf

Any perspective or orthographic camera view can be exported as a 3D model, including AutoCAD compatible .dwg or .dxf files.

  1. Enter a 3D view by selecting 3D> Create Perspective View> Perspective Full Overview .

  2. Select File> Export> Export 3D Model (DWG,DXF) .

  3. In the Export 3D Drawing dialog, select the Compatible Version and the Scaling Unit, then press Export.

  4. Set the location and file name of the model in the Save 3D Drawing File dialog, and press Save.

To export to a 2D .dwg or .dxf

Plan view, elevation views, and CAD Details can be exported as to-scale .dwg or .dxf files.

  1. Select File> Export> Export Current View (DWG,DXF)  from the menu.

  2. In the Export Drawing dialog:

  • From the Compatible Version drop-down list, select which version of AutoCAD you want the file to be compatible with. 

  • Select the Layer Set you'd like to export. 

  • Click the Export button. 

  • For additional information about the options in the Export Drawing File dialog, click the Help button in the bottom right corner of the dialog box. 

  • A dialog will appear prompting for a save location:

    • Specify a File Name and choose the location where you'd like to save this file to.

      Note: This field is called Save As if you are running the software natively on a Mac.

    • Click Save to save the file.