Browse
Categories

Message: Attempt to access missing P-List 2300

Reference Number: KB-00028 Last Updated: 10-11-2013 02:26 PM

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors or Chief Architect Lite


QUESTION


When I take any 3D view of my plan or rebuild walls, floors and ceilings, I get this error message:

"Error 2300: Attempt to Access Missing P-List 2300."

After the error appears, the plan seems to generate normally in the 3D view. What is causing this error?


ANSWER

This error may occur for either of two reasons:

  • A wall segment that is one pixel in length is located somewhere on  the plan.  Typically, it will be in the same location as another wall,  making it difficult to find.

  • You have a 3D object in your plan that is not installed in your Library Browser. The error generally appears when opening and modifying plans created in an older version of Chief.

 

To prevent error message 2300 from appearing, the wall segment or 3D object needs to be removed from the plan. Because error 2300 often happens when a plan is nearly complete, it is critical that you implement the following troubleshooting steps with a copy of you plan - not the original.


To resolve error 2300

  1. Open the plan in which error 2300 is occurring and select File > Save As  from the menu.  In the Save As dialog:

    • Click the Save in drop-down arrow at the top of the dialog and select Desktop as the location of the new copy.

    • In the File name field at the bottom of the dialog, erase the old name and name this copy "Trash".

    • Click the Save button to close the dialog and create a copy of the plan.


  2. Look at the upper left corner of the Chief Architect window, in the Tabs under the main toolbars, and confirm that the plan file that is now active is called "Trash".  



    • If you do not see this name in the upper left corner, do not proceed to the following steps. Instead, repeat this sequence beginning with Step 1.


  3. To find the problem wall segment or object, begin deleting sections of the plan until the error message stops appearing.

    • Delete portions of the plan in a logical progression, such as floor by floor, from left to right or top to bottom.

    • Try deleting by halves - first the left half and then, if the error persists, delete the top half of the remaining drawing, and so on.

    • Use the Edit Area tools to quickly delete all objects in a particular area. Select Edit> Edit Area from the menu to access these tools.

    • You may want to use the Delete Objects dialog to delete objects by category rather than location. Select Edit> Delete Objects  from the menu to access this dialog.

    • Sometimes it is helpful to close the "Trash" plan without saving your work and then reopen it and start your search again.


  4. When you discover where the problem object is found, close the "Trash" plan but DO NOT save the changes you made. At some time in the future, you may need to continue to troubleshoot this problem and returning to a copy of the drawing in which a majority of the walls have been deleted will hinder the troubleshooting process.


  5. Open original plan and delete the wall segment or 3D object that you found in the "Trash" copy of the drawing.


If you are unable to find the problem object feel free to send the plan to the Online Support Center for troubleshooting assistance.