Browse
Categories

Creating and Using a Plan Style Template

Reference Number: KB-00463 Last Updated: 10-28-2013 12:49 PM

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors or Chief Architect Lite

QUESTION

I have a number of different architectural design styles that I often use and would rather not have to set up my default settings every time I begin a new plan that will use one of these styles.  How can I do this work once and save it for future use?

ANSWER

In Chief Architect, any time you open a new, blank plan, its initial default settings are copied from a template.  You can create your own custom template plans to reflect the architectural styles, annotation sets, and materials that you use most often.

A template plan is essentially a blank plan with default settings customized to meet a particular set of design needs.  You may find it helpful to create more than one template, each set up to draw a particular architectural style.  It is a good idea to save all your templates in a particular location, such as a folder in My Documents or in the Chief Architect Templates directory.

 

Helpful Hint: Before you begin setting up your style defaults, it's important that you also set up your structural defaults, particularly framing, foundation, roof and wall defaults.   Although not discussed in this article, other settings to consider when creating a template plan are print settings set in the Page Setup dialog, as well as custom layers and layer sets.

To Creating a Style Template 

  1. Begin by selecting File> New Plan  from the menu to open a new, blank plan using the default profile.plan template.

If you are already familiar with this process, you may want to jump ahead to just the sections that apply to your needs using the links below.


To set up Floor Defaults

When a template plan is created, only one floor is present, so only the default settings for Floor 1 can be specified.  The Floor 2 defaults are set up when you build a second floor.

  1. Select Edit> Default Settings  from the menu to open the Default Settings dialog.



    • Select Floor and click the Edit button.
  2. On the Structural panel of the Floor 1 Defaults dialog, specify the default Ceiling (B) height for Floor 1.

    Note: The default Floor Height for Floor 1 is set at 0" and cannot be changed.
  3. On the Moldings panel:
    • The Profile template will have one molding already set up for Base Molding.  If you want to add moldings, Click on Add New...
    • In the Select Library Objects dialog, browse to find a molding profile that meets your needs and click OK.


    • Specify the Height and the Distance Above Floor for each molding profile.
  4. When you are satisfied with your selections, click OK.

To set up Wall Defaults

  1. In the Default Settings dialog:
    • Click the  beside Walls.
    • Select Exterior/Interior Wall and click the Edit button.
  2. In the Wall Defaults dialog, specify the desired wall types that you would like to use whenever the Exterior Wall and Interior Wall tools are used.

  3. Click the Define button if you would like to create or modify a custom wall type in the Wall Type Definitions dialog.


    • In addition to specifying structural aspects of a wall, such as its framing and ­sheathing, you can specify siding material such as lap siding, ­shingles or ­stucco and interior materials including paneling, finished ­tongue and groove, and ­sheetrock.

        Helpful Hint: To learn more about creating custom wall types, see additional information articles below.
  4. Repeat steps 2 and 3 to define the defaults for upper and lower Pony Walls.

  5. You can also specify Railing, Deck Railing and Fencing Defaults. 

    • The Railing, Deck Railing and Fencing Defaults dialogs are similar to the Railing, Newels/Balusters, Layer and Materials tabs of their corresponding specification dialogs.  A variety of attributes can be specified here, including railing construction, ­newel and baluster size, style and spacing, and materials.

To set up Door and Window Defaults

  1. In the Default Settings dialog:

    • Click the  beside Door.
    • Select Interior Door and click the Edit button.
  2. In the Interior Door Defaults dialog, specify the type of door you want to place whenever the Hinged Door  tool is used to place a door in an interior wall.

    • The Interior Door Defaults dialog is nearly identical to the Door Specification dialog, and allows you to establish a wide variety of attributes for doors, including style, size, hardware, construction, casing, and materials.
    • When you are satisfied with your selections, click OK.
  3. In the Default Settings dialog, select the Exterior Door subheading, click OK, and repeat step 2 to define the type of door you want to place whenever a Hinged Door  is placed in an exterior wall.

  4. In the Default Settings dialog, select Window and click OK.

  5. In the Window Defaults dialog, specify the type of window that you would like to place using the Window  tool.

    • As with door defaults, the Window Defaults dialog allows you to control a range of window attributes, including size, shape, construction, casing, treatments, and materials.
    • These settings also affect the component windows in Bay, Box and Bow Windows and in Automatic Dormers.
    • When you are satisfied with your selections, click OK.

To set up Cabinet Defaults

  1. In the Default Settings dialog:

    • Click the  beside Cabinets.

    • Select Base Cabinet and click the Edit button.


  2. In the Base Cabinet Defaults dialog, specify the attributes of the base cabinet that you would like to create whenever the Base Cabinet  tool is used.

    • As with window and door defaults, the Base Cabinet Defaults dialog is similar to its corresponding specification dialog, the Base Cabinet Specification dialog.

    • An extensive range of attributes can be specified, including dimensions, curvature, door and drawer styles, face items, hardware, moldings and materials.

    • When you are satisfied with your selections, click OK.

  3. Repeat steps 1 and 2 to establish default settings for Full Height Cabinets, Wall Cabinets, as well as Shelves and Partitions.

To set up defaults for moldings

Trim and moldings can be added to your template plan in a variety of ways. 

    • Base, crown and ­chair rail can be applied to the walls of a floor in the Floor Defaults dialog.

    • Molding can be placed on cabinets in their corresponding Cabinet Defaults dialog.

    • Casing can be selected for doors and windows in their respective defaults dialogs.

  Helpful Hint: If you do not see the style of molding that you need for your architectural style, you can create your own custom molding profiles, add them to the library, and apply them wherever you like in any plan - including template plans.  See the additional information articles below.

To set up Material Defaults

In some regards, setting up the default materials for the various objects in your plan can be the most time-consuming aspect of creating a template plan, but some time-saving features are available to help you select default materials efficiently.

Often, certain materials are used repeatedly throughout a plan.  Wood of a particular type and finish, for example, may be used for molding, window and door casing and cabinetry.  When you select this material as a default for one item, and it becomes available in the Plan Materials dialog.  Instead of clicking the Library Material button in a given defaults dialog, and then browsing the Materials library to find the desired selection, you can find it quickly and easily in the alphabetized Plan Materials list.

The material defaults are specified on the Materials panel of the Defaults Settings dialogs for objects such as doors, windows, cabinets, railings and fencing.

The default materials for walls are specified in the Wall Type Definitions dialog.

The floor materials for categories of rooms, such as kitchens and baths, can be specified in the Room Material Defaults dialogs.

 

    • In the Default Settings dialog, click the  beside Rooms, select Normal Room or the room type you would like to edit, and click the Edit button.
    • Click on the Edit button next to Floor Finish then browse the Library for the material you would like to use.
    •  

Some objects, such as stairs, do not have defaults dialogs. You can specify the default materials for their components in the Material Defaults dialog.

  • In the Default Settings dialog, click the  beside Materials, select the specific item you want to edit, and click the Edit button. Then browse the Library for the desired material.



To set up Layer Sets

Layer Sets are used to control the layer settings for different views in a plan or layout file. All views associated with a plan file - including views sent to layout - make use of layer sets stored in that .plan file.

A layer set consists of a complete list of the layers in the current plan or layout along with the display settings for each layer as set for a particular type of view or purpose. These display settings can be modified, and can be different for each layer set.

Any changes made to a layer set in one view affects all other views using the same layer set. If this is not desired, you can create a unique layer set for a particular view.

To learn more about Layer Sets, please see our online tutorial training videos on the Layer Set feature.

  Helpful Hint: If you have already set up Layer Sets, in another file, you can choose to Export these, and them Import them in to your plan style template.

To set up Annotation Sets

An Annotation Set is a collection of Saved Defaults for many of the tools used to annotate plan and layout files: manually-drawn Dimensions, Text, Callouts, Markers, Arrows, the Current CAD Layer, and the Active Layer Set. Multiple Annotation Sets can be saved in any plan or layout, each for a specific purpose, and you can quickly switch from set to set as you work on these various tasks.

Annotation Sets can be set up for different drawing tasks with specific annotation requirements.

For example, you could create a set for site plans with large dimensions, text, callouts, markers, and arrows; a dimension format using feet, yards, or meters instead of inches or millimeters; and custom layers for dimensions and text.

A number of Annotation Sets are included in the template plans installed with Chief Architect. You can use these sets as they are or customize them, and you can also create additional new sets in both plans and layouts.

Many of the objects included in Annotation Sets can be assigned a Text Style.

  Helpful Hint: To set up Annotation Sets, you should review Article Number 1167 entitled "How to set up my own Annotation Set and import it in to an existing file" and the online tutorial training videos on the Annotation Sets feature.

To set up Text Styles

In Chief Architect, a Text Style is a saved set of attributes that can be assigned to any object that displays text, such as Text, Callouts, Markers, Dimensions, Schedules, CAD objects, and architectural object labels.

This makes it easy to ensure that various objects display text with a consistent appearance.

You can create your own or edit existing Text Styles to suit your needs.

  Helpful Hint: To learn more about Text Styles, please see our online tutorial training videos on the Text Style feature.

 

Saving and using a style template

 

To save a template

  1. Select File> Templates> Save Plan as Template .

  2. Give the new template a short, descriptive name. Be sure to delete the asterisk (*).This automatically saves the template to the Chief Architect Templates folder.

  3. To use this template to create a new plan, select File> Templates> New Plan from Template .

  4. Select the template from the list and click OK.

To use this template whenever you open a New Plan File

To use the plan as your template whenever you open a New Plan  file, specify it as your template in the Preferences dialog.



  1. Select Edit> Preferences from the menu to open the Preferences dialog.

  2. On the New Plans panel of the dialog, click the Browse... button to the right of the Plan Template text field.

  3. In the Select a Plan Template File dialog, browse to the location of your new template file and click Open to specify this file as your plan template.

  4. Click OK to close the Preferences dialog and apply your change.