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General Framing Guidelines

The information in this article applies to:

QUESTION
What is the best way to approach framing in Chief Architect?

Architectural Home Design
Software

/


ANSWER
In this tutorial, we will describe recommended framing practices in Chief Architect.

Speci,cally, we will discuss:

Setting up Framing Defaults 

Generating Automatic Framing 

Manually building and editing framing  

Changing Framing Defaults in an existing plan

Before you begin drawing your plan, it's recommended that you set up your framing

defaults to re0ect the way you want the structure to be built. Changing these defaults

after the structure is complete may cause problems, requiring you to re-do work and

lower your productivity.

To setup framing defaults

1. Select Edit> Default Settings , highlight the Framing category, then click Edit.

2. In the Framing Defaults dialog, visit each panel and specify the spacing, framing

member size, framing member type, and other information.  

Note: While all framing default settings are important to your structure, the

floor framing will be the most time-consuming to change after your plan is

complete.   



3. When you have setup your framing defaults to your satisfaction, click OK.

4. Framing layers associated with Wall Types can also be modified to your liking.

Navigate to Build> Wall> Define Wall Types , and in the Wall Type Definitions

dialog that opens:



Choose the Wall Type you'd like to modify using the drop-down menu located in

the top left corner.

Wall layers that are to be framed will typically be listed under the Main Layers

category. Select the desired wall layer to make modifications, or select the Insert

Above or Insert Below buttons to add a new wall layer above or below the

selected layer.

Specify your desired framing Material as well as an appropriate Thickness value

for your framing layers.

Check Framing to produce framing for the selected layer when wall framing is

generated. Select the appropriate framing Type from the drop-down menu, the

Spacing, as well as the Width.

In X12 and prior versions, these properties are part of the framing material that is

chosen for the wall layer.



Set your Top and Bottom Plate Count and Width, as well as the Max Plate

Length.

These options are not available in X13 and prior versions.

Check Horizontal Framing to produce framing that runs horizontally instead of

vertically, sometimes referred to as girts. When Horizontal Framing is checked,

specify the Bottom Run Elevation, which is measured from the center of the

lowest horizontal framing member relative to zero, the default top height of the

subflooring on Floor 1. Also, specify the Max Girt Length, which is available in

X14 and newer versions.

The ability to create Horizontal Framing did not exist in X12 and prior versions.

Once the framing wall layers are setup to your liking for each of your Wall Types,

click OK.

Note: Floor and ceiling heights, which determine wall heights, are set in the Floor

Defaults dialog for each floor in your plan. Before drawing on each new floor, be

sure to specify these values, as well.

When you are con,dent that your plan is in its ,nal state, it's a good time to generate

framing. You can build framing at any time, however, if changes are made to the plan,

manual framing will not update to re0ect the changes.

To generate automatic framing

1. Select Build> Framing> Build Framing  from the menu.  

In X14 and newer versions, select Build> Framing> Build All Framing  to build

roof, wall, platform, and deck framing with a single click.

2. In the Build Framing dialog, click the Framing Defaults button to open your

Framing Defaults and visit each panel to verify that the default information is

correct. Once you have verified that the information is correct, click OK.



In X15 and prior versions, only a single Build Framing dialog existed in which

framing settings along with Build Framing boxes existed. Visit each panel of this

dialog and verify that the information is correct. 

Some important framing information to be aware:

Floor framing for a particular floor in your plan is accessed on the floor below.

Floor 1 floor framing, for example, is built on Floor 0 (foundation level), with their

settings located on the FOUNDATION panel.

In order to create the floor framing for Floor 1, a Floor 0 must be present. If a

Floor 0 has not been built, the Build Floor Framing checkbox on the Foundation

panel will not be available.

Ceiling framing for a particular floor in your plan is accessed on that floor.

Starting in X14, the ability to create Roof Overframing is available under the

ROOF panel.

Note: In X14 and prior, although properties relating to trusses can be

specified on the Trusses dialog panel, trusses cannot be built automatically.

Navigate to Build> Framing> Roof Truss or Floor/Ceiling Truss, then click and

drag in your plan to draw out trusses.

3. In the Build Framing dialog, check the appropriate Build box for each type of

framing that you would like to generate, then click OK.



It's common to use a combination of both automatic and manual framing in a single

Chief Architect plan.

To build or edit framing manually

With the exception of posts, framing objects are drawn by clicking and dragging in a

straight line, similar to other line-based objects. The manual framing tools, which can

be accessed by navigating to Build> Framing from the menu, are organized into

categories: general framing, roof framing, and 0oor/ceiling framing. The category that a

drawing tool belongs to determines where it can be used:

Roof framing objects can only be drawn within the area of one or more roof planes.

Floor and ceiling framing objects can only be drawn within one or more floor or

ceiling platforms.

General Framing  objects and Posts  can be drawn anywhere in a model.

General Framing  objects can also be drawn in CAD Details.



Wall Bridging  can only be drawn in a Wall Detail.

Manually drawn 0oor, ceiling, and roof framing is unaDected when automatic framing

is rebuilt and remains along with the newly produced automatic framing. In contrast,

manually drawn wall framing is deleted when automatic framing is rebuilt. You can,

however, prevent this from happening by checking the Retain Wall Framing option

located in the Wall Speci,cation dialog.

1. Once framing is automatically generated or manually created, it can be edited

further.  

 

2. Use Wall Detail views to edit wall framing components. Wall Details can be accessed

from the Project Browser or by right-clicking on a wall and selecting the Open Wall

Detail  edit button.

If you do not see the Project Browser, select View> Project Browser to turn on

its display.

Note: Wall Details are a special type of elevation view in which only the studs,

plates, girts, headers, and bridging used to frame an individual wall display.

A Wall Detail view for each framed wall in your plan is automatically created by

the program when its wall framing is built.



3. Floor and roof trusses can be edited by selecting and opening their specification

dialog. The chord and webbing thicknesses can be set, as well as horizontal span

and some additional options like Kingpost and Energy Heel.

Additional information on each of the options in this dialog can be found by clicking

the Help button at the bottom.



4. Trusses can also be modified in the Truss Detail. A Truss Detail is a special CAD

Detail window in which a diagram of each truss configuration present in the plan is

drawn.

The trusses in a Truss Detail are linked to the actual trusses in the plan. If you

modify a truss in a Truss Detail, it will be modified in the model as well. To modify

the information in a Truss Detail without affecting the model, use CAD> CAD Detail

From View  to create a line-drawn copy first.

Note: The Truss Detail is typically for display of trusses only. Editing the

members that make up the trusses in the Truss Detail is possible and

recommended only if absolutely necessary.

To open a plan’s Truss Detail, select CAD> CAD Detail Management  from the

menu, select the Truss Detail, then click Open.



To change framing defaults in an existing plan

1. Before making changes that will affect floor, ceiling and/or roof plane heights, it is

recommended that you first delete your framing - including wall framing.  

Click On Edit> Delete Objects  to open the Delete Objects dialog box. 

Click the radio button beside All Floors.



Check the boxes in the Framing category that you want to remove, or select the

Framing heading to check all of the boxes in this category. 

Click Delete to close the dialog and delete the specified framing objects in your

plan.

2. If you are raising or lowering your floor and/or ceiling heights and you do not have

Auto Rebuild Roofs turned on, you may need to raise or lower your roof manually.

To raise the roof planes enough to accommodate your changes, hold down the

Shift key, select the roof planes you'd like to modify, then click the

Transform/Replicate Object  edit button. 



To learn more about group selecting objects, such as roof planes,

please see the appropriate resource in the Related Articles section

below. 

In the Transform/Replicate Object dialog that displays, check the box beside

Move, select the Relative To Itself radio button, then specify the

desired distance to raise or lower the roof planes along the Z Delta.  





(https://chieftalk.chiefarchitect.com/)

A positive number here will raise the roof planes while a negative number will

lower the roof planes.

3. Make the needed changes to your plan's structure and framing defaults.   

Begin on the lowest floor and work upwards towards the attic.

Remember that changes made to the Framing and Floor Defaults will not affect

any rooms that are not using the default values. For example, rooms with sunken

floors should be examined individually and their heights adjusted as needed. 

Return To Top

Controlling Door and Window Framing (/support/article/KB-00985/controlling-door-

and-window-framing.html)

Creating Roof Trusses (/support/article/KB-00981/creating-roof-trusses.html)

Deleting Objects From a Plan or Layout (/support/article/KB-00196/deleting-objects-

from-a-plan-or-layout.html)

Displaying Framing in a Cross Section/Elevation View (/support/article/KB-

00017/displaying-framing-in-a-cross-section-elevation-view.html)

Group Selecting Objects (/support/article/KB-00623/group-selecting-objects.html)

Manually Editing Wall Framing (/support/article/KB-00571/manually-editing-wall-

framing.html)

Raising or Lowering a Roof Plane (/support/article/KB-00634/raising-or-lowering-a-

roof-plane.html)

Troubleshooting Wall Framing Issues (/support/article/KB-00335/troubleshooting-

wall-framing-issues.html)

Understanding Saved Plan Views (/support/article/KB-03185/understanding-saved-

plan-views.html)

Related Articles

/support/article/KB-00985/controlling-door-and-window-framing.html
/support/article/KB-00981/creating-roof-trusses.html
/support/article/KB-00196/deleting-objects-from-a-plan-or-layout.html
/support/article/KB-00017/displaying-framing-in-a-cross-section-elevation-view.html
/support/article/KB-00623/group-selecting-objects.html
/support/article/KB-00571/manually-editing-wall-framing.html
/support/article/KB-00634/raising-or-lowering-a-roof-plane.html
/support/article/KB-00335/troubleshooting-wall-framing-issues.html
/support/article/KB-03185/understanding-saved-plan-views.html
https://chieftalk.chiefarchitect.com/


 (/blog/)


(https://www.facebook.com/ChiefArchitect)


(https://www.youtube.com/user/ChiefArchitectInc)


(https://www.instagram.com/chiefarchitect/)


(https://www.houzz.com/pro/chiefarchitect/)


(https://www.pinterest.com/chiefarchitect/)
208-292-3400 (tel:+1-208-292-3400)  © 2000–2024 Chief Architect, Inc.  Terms of Use (/company/terms.html)

Privacy Policy (/company/privacy.html)

/blog/
https://www.facebook.com/ChiefArchitect
https://www.youtube.com/user/ChiefArchitectInc
https://www.instagram.com/chiefarchitect/
https://www.houzz.com/pro/chiefarchitect/
https://www.pinterest.com/chiefarchitect/
tel:+1-208-292-3400
/company/terms.html
/company/privacy.html

	Architectural Home Design Software
	General Framing Guidelines
	QUESTION
	ANSWER
	To setup framing defaults
	To generate automatic framing
	To build or edit framing manually
	To change framing defaults in an existing plan



