Browse
Categories

Creating Stairs in Sloping Terrain

Reference Number: KB-00547 Last Updated: 09-09-2014 08:00 AM

The information in this article applies to:

Chief Architect Premier or Chief Architect Lite

QUESTION

My plan calls for a set of stairs that cuts into sloping terrain to join two sidewalks, but when I draw stairs in my plan, they do not follow the terrain or join to my sidewalks.  What should I do?





ANSWER

You can create stairs that follow your terrain by drawing the stairs in an area defined by Retaining Walls and snapping the stairs to landings at each end.

terrain stairs

To create stair landings

The first step to creating stairs that follow the terrain in a plan is to create the landings that the stairs will attach to. We can define the heights of these landings to control the staircase's height, as well.

  1. Open the plan in which you want to create stairs in sloping terrain.



    • In this example, the terrain has a single ­slope between two flat areas.


  2. Select Tools> Layer Settings> Display Options  from the menu and turn off the display of Terrain, Primary Contours layer.  While not strictly necessary, this will make drawing in the sloped area of the terrain easier. Click OK to close the dialog.


  3. Select Build> Stairs> Landing then click and drag a rectangular landing.




    • While you can begin with either landing, you may find it easier to begin with the one closest to the height of your building pad.


  4. Edit the size and shape as needed using the edit handles.

    • In this example, the landing is 6 feet wide by 10 inches deep.


  5. Select the newly created landing and then click Open Object .


  6. On the General panel of the Stair Landing Specification dialog, which opens next, specify the Height and Thickness of the landing, check the box beside No Rail on Selected Edge, then click OK.

     

    • When a building is present in a plan, the Height value of a ­stair landing is measured relative to the Default Floor Height for Floor 1, which is defined as 0". 

    • Bear in mind that this 0" value is not the same as 0" in the terrain if you have a building drawn in your plan.  The program will automatically drop the terrain relative to the height of Floor 1, depending on the type of foundation that you build.

    • In this example, there is no building in the plan so the landing height is measured relative to 0" in the terrain.


  7. Double-click on each edge of the landing and make sure that No Rail on Selected Edge is checked for each edge.


  8. With the stair landing still selected, click the Copy/Paste  edit button, then click and drag the Move edit handle, releasing the mouse button to place a copy at the desired location.



    • If you need to position the copy with greater precision, you can use the Transform/Replicate Object  edit tool.


  9. When the copied stair landing is in place, select it and click the Open Object  edit button.  On the General tab of the Stair Landing Specification dialog, specify the Height of this new landing, then click OK.

     


  10. To check the heights of your landings relative to the terrain, select 3D> Create Orthographic View> Backclipped Cross Section from the menu, then click and drag a camera arrow parallel to the slope of your terrain and within the length of the landing.


     
  11. If the landing and terrain are not near one another, return to floor plan view and make any necessary adjustments to the landing heights.

    Depending on the requirements of your drawing, you may need to make changes to your slope, instead.

 

 

To draw stairs between landings

  1. In floor plan view, select Edit> Snap Settings from the menu and make sure that Object Snaps  are enabled - particularly, Midpoint  snaps.


  2. Select Build> Stairs> Straight Stairs  from the menu, then move your cursor to the landing with the lower Height value.  Position it near the midpoint of the edge closest to the other landing.


  3. When your cursor is over the midpoint, a triangular red Midpoint  snap indicator will display.  Click and drag to the midpoint of the other landing's midpoint, then release the mouse button.  A staircase will be created and will be attached to the two landings.




  4. Select the stairs and click the Open Object  edit button.


  5. On the Style panel of the Staircase Specification dialog:



    • Uncheck all of the boxes in the Stringer section.

    • Check the box beside Riser Surface at Top Landing.

    • Click OK to close the dialog and apply your changes.


  6. Select 3D> Create Perspective View> Full Overview  to see the results so far.



    Notice that the terrain can be seen in parts of the staircase area.

 

To create a well around the stairs

To make sure that the terrain does not spill into the staircase area, we can use retaining walls to cut the terrain around this area.

  1. Return to floor plan view and select Terrain> Walls and Curbs> Straight Retaining Wall  from the menu.


  2. Click and drag to draw three retaining walls around three sides of the stairs, leaving the base of the stairs open.



    • Do not worry about positioning them precisely right now.  Instead, you can draw them larger than the staircase and reposition them in a moment.


  3. Select each ­retaining wall and use their edit handles to move them so that they bump up against the stairs.




    • The wall at the top of the stairs should be positioned under the landing.


  4. Select CAD> Dimension from the menu and make sure Display Temporary Dimensions  is enabled.


  5. Select one of the side retaining walls, then click on the temporary dimension indicating its distance from the opposite retaining wall.

    In the Move Object Using Dimension in-line text box, reduce this distance by 1" and then press the Enter key on your keyboard.





  6. Select the retaining wall on the other side of the stairs and repeat step 5 so that both retaining walls are partially located beneath the edges of the stairs.
     

    Once this step has been completed, try not to edit the stairs or the side retaining walls in any way. If you do, the program may snap the stairs to the surface of one of the walls and you will have to delete the walls and repeat this process.



  7. Select 3D> Create Perspective View> Full Overview  to see the results.




  8. You can use the Material Eyedropper  to apply the ­concrete material of the retaining walls to the treads and risers of the stairs.  Or, use the Material Painter  to apply new materials to these surfaces.