Browse
Categories

Creating a Polyline Solid that Contains an Arc

Reference Number: KB-00565 Last Updated: 07-09-2014 11:30 AM

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors or Chief Architect Lite


QUESTION

I would like to create a ­polyline solid that includes an arc with a precise radius; however, when I create a rectangular polyline solid using the Polyline Solid tool, I must use the Break Line tool to reshape the rectangle into an arc. This is very imprecise. How can I specify a precise value for the radius?





ANSWER

The Polyline Solid tool is a fast way to create a rectangular polyline solid; however, if you wish to create a polyline solid with precise dimensions that is not rectangular in shape, use the CAD drawing tools to create a closed polyline with the desired shape and then convert it to a polyline solid using the Convert Polyline tool. 

Polyline solids can be created in either floor plan view or in Cross Section/Elevation views.  Which view you use will depend on the desired orientation of the arc in your polyline solid.



To precisely define an arc

  1. Begin by opening the Chief Architect plan in which you would like to create a polyline solid with an arc or select File> New Plan  from the menu to open a new plan.


  2. If you would like the curve of the arc to be oriented vertically, select 3D> Create Orthographic View . Otherwise, remain in floor plan view and proceed to step 3.

    In Chief Architect X2 ad prior, use 3D> Create Vector View> Cross Section/Elevation.


  3. Select CAD> Arc> Draw Arc  from the menu, then click and drag an arc of the approximate size needed.  There is no need to worry about precision at this time.


  4. Click on the arc to select it, then click the Open Object  edit button.


  5. On the Arc panel of the Arc Specification dialog, specify the desired attributes of the arc.  The following describes how the arc in this example was created:


     
    • The start and end points of the arc were set when it was drawn, with the wall edges used as references.  In this case, the Start Y and End Y values should be the same;  if they are not, lock either the Start or the End of the arc at the upper left corner of the dialog and change the value that is available for editing on the right side.  

    • With either the Start or the End still locked, specify the desired Arc Radius of the arc on the left side of the dialog, then press the Tab key on your keyboard to update the information in the dialog without closing it.  In this example a radius of 120" (10') is used.

    • Specify the desired Chord Length, then press the Tab key.  In this example, the arc will be placed over a 144" (12')  wide wall opening.

    • Click OK to close the dialog and apply your changes.   



To create a closed polyline that includes the arc

Once the arc is defined and locked, we add CAD lines to create a closed polyline.  Taking advantage of some CAD editing options will help us do this effectively.

 
  1. Click Edit> Snap Settings and make sure that Object Snaps  and Endpoint snap settings are toggled on.  This will allow us to precisely snap new lines to the ends of our arc. 


  2. Select CAD> Lines> Draw Line from the menu, then click and drag a line beginning at one end of the arc.  Notice the square-shaped Endpoint snap indicator that displays where the line meets the arc. 




  3. Continue drawing and defining lines until you have created a closed polyline with the needed size and shape. 




  4. Using the Select Objects tool, click on the polyline near one of its edges to select it and then click the Convert Polyline edit button to open the Convert Polyline dialog. 


  5. Click on the radio button beside Polyline Solid and then click the OK button to close the dialog. 




    Note:  If the Polyline Solid option is not enabled, a break in the polyline may have been created when the arc was edited. To reconnect the arc to the other segments, click on it; drag it away from the rest of the rectangle; and then drag it back so that it reconnects with the rectangle.


  6. When the Convert Polyline dialog closes, the Polyline Solid Specification dialog will open. This is where attributes of your polyline solid, including thickness and materials, can be specified. Click the OK button to close the dialog and return to either floor plan or Cross Section/Elevation view.  




  7. The two-dimensional polyline that you drew is now a three-dimensional object with the selected material and a precisely defined shape.  

    • In many cases, you will want to draw your polyline solid in place; in this example, however, the polyline solid was drawn in an empty space above the cross section to improve image clarity.  

    • It can now be selected and moved into place using the Move edit handle. 

    • Hold down the Ctrl key on your keyboard to move an object such as the polyline solid through obstructions such as the ceiling as it is moved into place. 




  8. When the polyline solid is in position, return to floor plan view either by closing the Cross Section/Elevation view or by clicking the Window menu and selecting the Floor Plan view from the bottom of the menu to toggle to it. 




  9. Click on the polyline solid to select it, click the Center Object  tool in the Edit toolbar at the bottom of your screen, then click the wall to position it in the center of the wall.


     

  10. In floor plan view, select 3D> Create Perspective View> Full Camera and create a 3D view to see the results.  

    In Chief Architect X1 and prior, use 3D> Create Render View> Render Full Camera.