Manually Editing Wall Framing


Reference Number: KB-00571
Last Modified: July 16, 2015

The information in this article applies to:

Chief Architect Premier


QUESTION

I have generated wall framing in my plan and would like to make some changes to it. How is this accomplished?


ANSWER

You can select and edit most wall framing in any 2D or 3D view.



In order to generate wall framing, you must first be using a wall type with a framing material as the Main Layer.


To verify the wall type definition
  1. Select Build> Wall> Define Wall Types .


  2. In the Wall Type Definitions dialog, verify the Main Layer material is set to a Framing material.  If it is not, adjust the wall accordingly.



    A wall type's thickest structural layer is typically set as the Main Layer.


  3. Click OK to close the dialog.



To create wall framing

  1. Select Build> Framing> Build Framing .


  2. In the Build Framing dialog, select the Wall panel.


  3. Check Automatically Build Wall Framing so that wall framing will be regenerated whenever changes are made to the model.




  4. Make any other desired changes on this panel, then click OK to generate Wall Framing.

 

To edit wall framing in floor plan view

  1. Select Tools> Layer Settings> Display Options .


  2. Scroll down to the Framing, Wall layer, place a checkmark in the Disp colum, then click OK to display this in the currently active layer set in the 2D floor plan view.




  3. In floor plan view, click the Select Objects  tool, then click on a wall stud to select it.



    If the wall is selected instead at first, click the Select Next Object  edit button or press the Tab key on your keyboard as many times as needed until the stud is selected.  



  4. Once selected, a wall stud can be edited either using its edit handles, edit toolbar buttons, or by opening the Framing Specification dialog.


Other framing members, such as headers, trimmers and cripples can be edited in 3D views or a Wall Detail.

To edit wall framing in a 3D view

  1. Select 3D> Create Orthographic View> Orthographic Framing Overview .


  2. Using the Select Objects  tool, click on a wall framing member to select it, and make any desired changes.




  3. Close the view when you have finished making the desired changes.

A Framing Overview of an entire plan may be overwhelming when all you need to modify is an element in an individual wall, in which case, a Wall Detail would be a better option.


To edit wall framing in a Wall Detail view 

  1. Return to your 2D floor plan view, if you have not already.


  2. Use the Select Objects tool, then click on a wall to select it.  


  3. With the wall selected, click the Open Wall Detail  edit button.

      

    The Open Wall Detail tool will not be available unless you have previously generated wall framing using the Build Framing dialog.

    Wall Details can also be accessed from the Project Browser. 



  4. A Wall Detail elevation view of the wall framing for that wall - and that wall only - will generate.

  • In this Wall Detail view, you can select and edit individual framing members such as studs, headers, trimmers and cripples using the edit handles, edit toolbar buttons and specification dialogs.

  • New framing members can be added by selecting an existing framing member and using the Copy/Paste function in the Edit menu.


  • Once you are finished modifying the framing members, select File> Close from the menu to close the Wall Detail view.  


  • The framing changes you made in elevation view will now be visible in floor plan plan view.


  • Select File> Save  from the menu to save them.