Browse
Categories

Creating a Post and Beam Structure

Reference Number: KB-00598 Last Updated: 09-09-2014 12:42 PM

The information in this article applies to:

Chief Architect Premier or Chief Architect Lite


QUESTION

I would like to design a ­post and beam structure in Chief Architect.  How can I do this?



ANSWER

There are a wide variety of post and beam construction styles, and a variety of methods that you can model this type of structure in Chief Architect, as well.  In this example, a simple structure composed of posts, beams, and trusses is created.

 



To create the perimeter

  1. Select Edit> Default Settings from the menu, select Framing and click on the Edit button to display the Framing Defaults dialog.

    • On the Beams panel, under the Size/Position heading, make sure that the Under Joists radio button is selected and specify the desired Depth and Thickness.  In this example, 5 1/2" is used for both. 

    • On the Posts panel, specify the desired Dimension.  In this example, 5 1/2" is used.

    • On the TRUSSES panel, specify the desired Member Depths.  In this example, the Top ChordBottom Chord, and Webbing are all specified as 5-1/2"

    • Click OK after making these changes.


  2. Next, select Build> Framing> Post  from the menu, then click in the drawing area to place a ­post.

    If the "Framing, Posts" layer is not enabled in your currently active layerset, a message dialog will display asking if you want to turn the layer on.  Select Yes.


  3. Click on the post to select it, then click the Transform/Replicate Object  edit tool.  In the Transform/Replicate Object dialog:   

    • Check the box beside Copy and specify the number of copies you would like to make. In this example, 4 copies are created.

    • Check the box beside Move and specify the interval at which you would like the copied posts to be created. In this example, a Move interval of 120" along the X Delta is used.  

    • Click OK to close the dialog and create the copies at the specified interval. In this example, a total of five posts spaced 10 feet apart are produced.




  4. Next, using the Select Objects  tool, click and drag a rectangular marquee around all five posts to group-select them.

  5. With the five posts selected, click the Transform/Replicate Object  edit button again. In the Transform/Replicate Object dialog: 



    • Check the box beside Copy and specify 1 copy. 

    • Check the box beside Move and specify the interval to move the copied posts.  In this example, the posts are moved 24 feet down on-screen, or -24' on the Y Delta then hit your tab key on your key board.  You will see it converted to -288". 

    • Click OK to close the dialog and create the copies at the specified interval.  




  6. Select Edit> Preferences from the menu, and on the BEHAVIORS panel, move the radio button to Concentric and set the Jump value, which is the distance you want between the outside of the posts and the edge of the structure's ­concrete slab, then click OK. In this example, 6" is used.




  7. Next, select CAD> Boxes> Rectangular Polyline from the menu, then click and drag a polyline that snaps to the outside of the array of posts.




  8. Concentrically resize the polyline so it represents the size of the ­slab you need by clicking on the polyline to select it, then Zoom  in on a corner of the polyline.  Since you've already set Concentric as the active Edit Behavior in preferences, slowly drag the corner outward until it snaps to one Jump increment, then release the mouse button.




  9. Select Edit> Edit Behaviors> Default to return to the Default edit behavior.



  10. Using the Room Divider  tool, draw walls that snap to the polyline as they are drawn. is used.  When the area is completely surrounded by the room divider, it will convert them in to full width invisible walls.




  11. Using the Select Objects  tool, click inside of the room's floor area to select the Room, the click on the Open Object  edit tool to display the Room Specification dialog. 

    • In the General panel, select the desired Room Type of Slab so there is no additional flooring on top of the slab foundation.


  12. Next, navigate to Build> Floor> Build Foundation  from the menu.  In the Build Foundation dialog, move the radio button under Foundation Type to Monolithic Slab and click OK.


  13. Finally, select 3D> Create Perspective Overview> Perspective Framing Overview  from the menu to see the results so far.




       

To add the roof trusses

  1. Close the Framing Overview and return to the Floor Plan view.

     
  2. From the currently active foundation level, go Up One Floor  to Floor 1, then specify the two side walls as Full Gable Walls by Shift + selecting the two walls and then click on the Change to Gable Wall(s) tool   in the edit menu at the bottom of your screen.


  3. Select Build> Roof> Build Roof  from the menu.  In the Build Roof dialog:  

    • On the ROOF panel, check Trusses (no Birdsmouth).

    • Specify the desired Pitch, Overhang, materials and other settings.

    • Check the box next to Build Roof Planes and click OK to close the dialog and build a roof over the structure.  


  4. Select Build> Framing> Roof Truss  from the menu, then click and drag a line perpendicular to the roof ­ridge from one exterior wall to the opposite wall to draw a roof ­truss at that location.  




  5. To move the joist over the top of the first two posts on the left side of the building, select the truss and then click on the Center Object tool  and then place your mouse over the top of one of the first posts until you see the vertical centerline indicator and click.




  6. With the truss still selected, click the Transform/Replicate Object  edit button.  In the Transform/Replicate Object dialog:

    • Specify the number of copies that you want across the building, in this example 4 copies. and the distance, in the example 120" in the direction (the X Delta or right on your screen) to copy them across the building. 

    • Click OK to close the dialog and create the copies at the specified interval.  


  7. Create a Perspective Framing Overview to see the results.  Select File> Close View    when you are finished to return to floor plan view.





To add the beams

  1. Zoom in on the two posts located at top left corner of the structure.


  2. Select Build> Framing> Floor/Ceiling Beam , then click and drag to draw a beam between these two posts.  Drag the posts endpoint to just short of the 2nd post.




    • By default, beams will snap along their centerlines as they are drawn, and you can snap them to the posts midpoints.


  3. Go to the Window drop down menu and select Fill the Window Building Only  .


  4. Select the beam, then click and drag the end edit handle to the right.  Cross over the top of all the posts and snap to the right side midpoint of the last post on the right.


  5. To size the beam correctly, double click on it to open the  Beam Specification dialog.  Change the Depth:  and Width: fields to the desired size.


  6. To copy the beam to the line of posts on the opposite side of the building, select the beam click on the Copy/Paste tool  in the edit tool bar at the bottom of the screen.  Then click on the Reflect About Object  tool in the tool bar at the bottom of the screen and hover over the roof ridge line until you see the horizontal center line indicator and click.  You should now have beams over each line of posts.


  7. Create a Perspective Framing Overview  to see the results.