Creating a Post and Beam Structure


Reference Number: KB-00598
Last Modified: July 16, 2015

The information in this article applies to:

Chief Architect Premier


QUESTION

I would like to design a post and beam structure in Chief Architect. How can I do this?




ANSWER

There are a wide variety of post and beam construction styles, and a variety of methods that you can model this type of structure in Chief Architect, as well. In this example, a simple structure composed of posts, beams, and trusses is created.

To create the perimeter

  1. Select Edit> Default Settings from the menu.


  2. Select Framing from the list and click the Edit button.

    • Switch to the Beams panel and under Floor/Ceiling Beams click the Edit Floor Beam Defaults button.

    • Under the General panel of the Floor Beam Defaults dialog, set the depth and width of the beam. In this example 5 ½ inches(") will be used for both.

    • Click OK to close the Floor Beam Defaults then set the Placement to Under Joists.

    • On the Posts panel of the Framing Defaults Click the Edit Post Defaults button and set both Width 1 and Width 2 to match the beam width of 5 ½".

    • Click OK to close the Post Defaults and switch to the Trusses panel of the Framing Defaults.

    • Under the Member Depth heading, set the Top and Bottom chords and the Webbing to 5 ½".

    • Click OK to Make these changes and Done to close the Default Settings dialog.


  3. Next, select Build> Framing> Post from the menu, and click in the drawing area to place a post.

    If you do not have the layer Framing, Posts turn on you may see the message: "The layer "Framing, Posts" is not displayed. Do you want to turn on the display of this layer in the current view?". Click Yes if you see this message.

  4. Click on the post to select it, then click the Transform/Replicate Object  edit tool. In the Transform/Replicate Object dialog:



    • Check the box beside Copy and specify the number of copies you would like to make. In this example, 4 copies are created.

    • Check the box beside Move and specify the interval at which you would like the copied posts to be created. In this example, a Move interval of 120" along the X Delta is used.

    • Click OK to close the dialog and create the copies at the specified interval. In this example, a total of five posts spaced 10 feet apart are produced.


  5. Next, using the Select Objects  tool, click and drag a rectangular marquee around all five posts to group-select them.




  6. With the five posts selected, click the Transform/Replicate Object  edit button again. In the Transform/Replicate Object dialog:



    • Check the box beside Copy and specify 1 copy.

    • Check the box beside Move and specify the interval to move the copied posts. In this example, the posts are moved 24 feet down on-screen, or -24' on the Y Delta then press your Tab key on your key board. You will see it converted to -288".

    • Click OK to close the dialog and create the copies at the specified interval.




  7. Open your program Preferences , and on the Behaviors panel, move the radio button to Concentric and set the Jump value, which is the distance you want between the outside of the posts and the edge of the structure's concrete slab, then click OK. In this example, 6" is used.

    On a Windows PC, Preferences can be found by selecting Edit> Preferences from the menu and on a Mac selecting Chief Architect> Preferences from the menu.





  8. Next, select CAD> Boxes> Rectangular Polyline from the menu, then click and drag a polyline that snaps to the outside of the array of posts.




  9. Concentrically resize the polyline so it represents the size of the slab you need by clicking on the polyline to select it, then Zoom in on a corner of the polyline. Since you've already set Concentric as the active Edit Behavior in preferences, slowly drag the corner outward until it snaps to one Jump increment of 6", then release the mouse button.




  10. Select Edit> Edit Behaviors> Default to return to the Default edit behavior.


  11. Select Build> Wall> Room Divider from the menu, then using the Room Divider tool, draw walls over the polyline that you created in the previous steps. When the Room Dividers completely surround the area they will automatically convert to full width, invisible, walls.




  12. Using the Select Objects  tool, click inside of the room's floor area to select the Room, the click on the Open Object  edit tool to display the Room Specification dialog.

    • In the General panel, change the Room Type to Slab so there is no additional flooring on top of the slab foundation.


  13. Next, navigate to Build> Floor> Build Foundation from the menu. In the Build Foundation dialog, move the radio button under Foundation Type to Monolithic Slab and click OK.


  14. Finally, select 3D> Create Perspective Overview> Perspective Framing Overview from the menu to see the results so far.




To add the roof trusses

  1. Select File> Close View from the menu to close the Perspective Framing Overview and return to the Floor Plan view.


  2. From the currently active foundation level, go Up One Floor to Floor 1, then specify the two side walls as Full Gable Walls by group selecting the two walls and then clicking on the Change to Gable Wall(s) edit tool on the edit toolbar.


  3. Select Build> Roof> Build Roof from the menu. In the Build Roof dialog:

    • On the Roof panel, check Trusses (no Birdsmouth).

    • Specify the desired Pitch, Overhang, Materials and other settings.

    • Check the box next to Build Roof Planes and click OK to close the dialog and build a roof over the structure.


  4. Select Build> Framing> Roof Truss  from the menu, then click and drag a line perpendicular to the roof ridge from one exterior wall to the opposite wall to draw a roof truss at that location.

    If the Framing, Roof Trusses layer is not being displayed then you may receive the following message: "The layer "Framing, Roof Trusses" is not displayed. Do you want to turn on the display of this layer in the current view?". Click Yes to this message to turn on the display of Roof Trusses in this view.





  5. To move the joist over the top of the first two posts on the left side of the building, select the truss and then click on the Center Object tool. Place your mouse over the top of one of the first posts until you see the vertical centerline indicator and click.




  6. With the truss still selected, click the Transform/Replicate Object edit button. In the Transform/Replicate Object dialog:

    • Specify the number of copies that you want across the building, in this example 4 copies. and the distance, in the example 120" in the direction (the X Delta or right on your screen) to copy them across the building.

    • Click OK to close the dialog and create the copies at the specified interval.


  7. Create a Perspective Framing Overview to see the results. Select File> Close View from the menu when you are finished to return to floor plan view.




To add the beams

  1. Zoom in on the two posts located at the top, left, corner of the structure.


  2. Select Build> Framing> Floor/Ceiling Beam , then click and drag to draw a beam between these two posts. Drag the beams end point to fall just short of the 2nd post.

    If the Framing, Ceiling Beams layer is not turn on for display in this view then you may receive the following message: "The layer "Framing, Ceiling Beams" is not displayed. Do you want to turn on the display of this layer in the current view?". Click Yes to this message to turn on the display of the Ceiling Beams in this view.




    • By default, beams will snap along their centerlines as they are drawn, and you can snap them to the posts midpoints.


  3. Go to the Window drop down menu and select Fill the Window Building Only .


  4. Select the beam, then click and drag the end edit handle to the right. Cross over the top of all the posts and snap to the right side midpoint of the last post on the right.


  5. To copy the beam to the line of posts on the opposite side of the building, select the beam click on the Copy/Paste edit button on the edit toolbar at the bottom of the screen. Then click on the Reflect About Object tool in the tool bar at the bottom of the screen and hover over the roof ridge line until you see the horizontal center line indicator, then click. You should now have beams over each line of posts.


  6. Create a Perspective Framing Overview to see the results.