Browse
Categories

Importing Terrain Elevation Data from a dxf or dwg File

Reference Number: KB-00719 Last Updated: 12-12-2013 12:11 PM

The information in this article applies to:

Chief Architect Premier or Chief Architect Lite


QUESTION

I have a ­.dwg file containing terrain data that I received from my engineer and want to import this data into Chief Architect. What steps are involved in doing this?


ANSWER

Importing terrain information from a CAD drawing file is a straight-forward task in Chief Architect but requires a knowledge of what layers were used when the drawing was created and which layers contain the data that you need.

 

Terrain drawings typically contain several types of data, specifically boundary data, elevation data and CAD data.  These different types of data must each be imported separately, which means that you will need to import your drawing several times. There is no single CAD standard, and which layers the different data is on is determined by the drafts person that created the drawing. 

 

This article describes how to do the following:

  • Determining which layers contain the terrain information.
  • Importing the boundary data.
  • Converting the boundary to a terrain perimeter.
  • Importing elevation data.
  • Importing other CAD information from the drawing.
  • Building the terrain.



To determine which layers contain terrain information

If you do not know which layers in your .dxf or .dwg file contain the needed elevation and plot data, you can import the drawing into an empty plan file to find out, following the steps below.

  1. Select File> New Plan  from the menu to create a new temporary plan.  


  2. Start the Import Drawing Assistant by selecting File> Import> Drawing (DWG, DXF)  from the menu.   

    • On the Welcome page, click Next.  

    • On the Select File page, click the Browse button to open the Import Drawing Assistant dialog and select the desired .dxf or .dwg file saved on your computer. When the needed file is selected, click the Open button to return to the Import Drawing Assistant.  Do not make changes to the other options on this dialog page at this time, and click Next.  

    • On the Select Layers page, make sure there is a checkmark beside the name of each layer in the Layer column, then click Next.  

       


    • On the Layer Mapping page, select Chief layers by name. Leave the Import all layer attributes radio button selected, then click Next.  

       


    • On the Drawing Unit page, select the unit of measurement that was used to create the drawing from the drop-down list. If you are uncertain of which unit to select, contact the person that created the drawing.  

       

    • Click Next and then click Finish to close the Import Drawing Assistant.  


  3. You should now see the drawing in the plan area. If you do not, select Window> Fill Window  from the menu to center it in the drawing area.

    If you do not see the drawing after clicking Fill Window, see the Tips for Importing CAD Drawings section at the end of this article.  


  4. The next step is to determine whether there is any unneeded data in the drawing.  

    • Examine the drawing to see if you find any information that you do not wish to import.   

    • If you find a line or other object that you do not want to import, click on it to select it, then click the Open Object  edit button.  

    • On the Line Style panel of the object's specification dialog, click the Define button to the right of the Layer name.  

       

    • In the Layer Display Options dialog, turn off the display of this layer in by clicking on the checkmark  in the Disp column to remove it, then click OK.  

       

    • Continue examining the drawing, repeating this process for any unnecessary objects that you find, until you are satisfied that only terrain data is displaying in the drawing area.  


  5. If you plan to import the lot perimeter, click on the polyline representing the perimeter to select it, then select the Open Object  edit button and go to the Line Style panel of the object's specification dialog.

    Make a note of the Layer that the lot perimeter is on, then click OK.  


  6. Next, determine which layer or layers the contour lines are on. To do this, select Tools> Display Settings> Display Options  from the menu to open the Layer Display Options dialog. The layers in this dialog can be sorted by any of the columns, which will help us here.   

    • Scroll to the top of the list, then click the heading of the Used column.   

    • The layers will now be sorted so that those found at the top of the list display a red  symbol in the Used column.  Since this plan is blank except for the imported drawing, these Used layers are those imported from the drawing file.  

       

    • Make a note of the layer names that are both Used and set to display in 2D .  These are the layers that have the data you need when the drawing is imported into your plan.  

    • Click OK to close the Layer Display Options dialog.  


  7. Close this temporary plan without saving it, as there is no need to save it once you have made a note of the layers the terrain data is on.



To import the lot boundary and create a terrain perimeter

If  you would like to import the lot perimeter data for a ­plot plan and use  it as your Terrain Perimeter, follow the steps below. 

  1. Select File> Open Plan  from the menu and open the plan in which you would like to import the lot perimeter.


  2. Start the Import Drawing Assistant by selecting File> Import> Drawing (DWG, DXF)  from the menu.

    • On the Welcome page, click Next.   

    • On the Select File page, click the Browse button to open the Import Drawing File dialog and select the desired .dxf or .dwg file saved on your computer.  

    • Also on the Select File page, place a check mark next to Polylines, then click Next.   

    • On the Select Layers page, uncheck all unwanted layers.  

      In Chief Architect X1, you need to uncheck all layers except the layer containing the boundary.  

    • Select  the layer with the lot perimeter polyline that you wish to serve as  your Terrain Perimeter, then select Terrain Perimeter from the Convert to drop-down list.  

    • Select the layer or layers that contain elevation data and select Elevation Data from the Convert to drop-down list.  

    • When the correct layers are selected and defined as needed, click Next.  



      To quickly uncheck all layers, Click the Clear All button and then you can easily select only the layer you are interested in.

    • On the Layer Mapping page,  select a layer mapping option.  Any option will work in this instance;  however, you can map the lot perimeter directly to the Chief Architect  Terrain Perimeter layer by checking the box beside Go to the advanced layer mapping page..., then clicking Next.  

    • On the Advanced Layer Mapping page, click on the DWG/DXF Layer name.  Then click the Chief Layer drop-down list, select Terrain Perimeter from the list and click Next.  



    • On the Drawing Unit page,  select the unit of measurement. You should have determined the correct  unit earlier when you first imported the data into a test plan.  

    • Click Next and then click Finish to close the Import Drawing Assistant.  


  3. You should now see the drawing in the plan area. If you do not, select Window> Fill Window  from the menu to center it in the drawing area.

    If you do not see the drawing after clicking Fill Window, see the Tips for Importing CAD Drawings section at the end of this article.


  4. Click on the newly imported lot perimeter to select it, then click the Open Object  edit button.
       

  5. In the Terrain Specification dialog, make any changes that you would like to your new terrain perimeter and click OK to close the dialog.



To import contour data

While  not strictly necessary, it is a good idea to import your  contour  data only after the Terrain Perimeter has been imported and  established.

  1. Start the Import Drawing Assistant by selecting File> Import> Drawing (DWG, DXF) from the menu.  


  2. On the Welcome page, click Next.   


  3. On the Select File page, click the Browse button to open the Import Drawing File dialog and select the desired .dxf or .dwg file saved on your computer, then click Next.

     

    Also on the Select File page, place a check mark beside Polylines, then click Next.  


  4. On the Select Layers page, select only the layer or layers containing contours as determined in the first part of this article.  




  5. On the Drawing Unit page, select the unit of measurement.  


  6. Click Next and Finish.  You should now see the terrain data lines in your plan.



    If you do not see the contour lines, see the Tips for Importing CAD Drawings section at the end of this article.



To import other CAD information

If you want to import any other data, such as text or the location of water lines, follow these steps.

  1. Start the Import Drawing Assistant by selecting File> Import> Drawing (DWG, DXF) from the menu.  


  2. On the Welcome page, click Next.  


  3. On the Select File dialog page, click the Browse button to open the Import Drawing File dialog and select the desired .dxf or .dwg file saved on your computer, then click Next.  


  4. On the Select Layers page, select layers NOT containing perimeter or elevation data by unchecking the layers that were already imported, then click Next.  


  5. On the Drawing Unit page, select the unit of measurement, then click Next, and finally, Finish. You should now see the additional data in your plan.

    If you do not see this data, see the Tips for Importing CAD Drawings section at the end of this article.



To build the terrain

With the terrain perimeter and elevation data in place, you can now build your terrain.

  1. From the menu, select Terrain> Build Terrain .

    If asked about linear interpolation, click Yes. You should now have the terrain data imported into your plan.  


  2. Select 3D> Create Perspective View> Full Overview  to see your terrain.  




Tips for Importing CAD Drawings


While Chief Architect is able to import .dxf and .dwg files, these  are not Chief Architect native file formats.  As a result, there are a  couple of  requirements for successful importing.

 

  • Drawings imported into Chief Architect be created in Model Space in AutoCAD.  If a drawing was created in Paper Space, it will not be recognized by Chief.

 

  • Chief Architect does not recognize and will not import any layers that are frozen in AutoCAD.  You can see if any layers in your drawing file are frozen on the Select Layers page of the Import Drawing Assistant.

 

  • Chief  Architect is able to import layers that have been turned off in  AutoCAD; however, the 2D display of these layers will be turned off in  Chief, as well, so you will not see them when the drawing is   first    imported.

    You can check for imported layers that are turned   off in  the Layer Display Options dialog. Sort by Used  layers, then look for any imported layers that are used but not set to display.