Browse
Categories

Creating and Using Layout Templates

Reference Number: KB-00737 Last Updated: 10-08-2014 10:35 AM

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors or Chief Architect Lite


QUESTION

I would like to create and use a ­layout template in Chief Architect.


ANSWER

A template file has all of your preferred default settings, layer display options and other file-specific information saved and waiting for you.

A layout template can also feature a border with your company information, logo, text macros and other details. When you identify a file as a template, Chief Architect refers to that file for this information any time you open a new layout file.

Creating a layout template is easy and can save you a lot of time when creating a new layout file.  A sample layout template is attached to this article as well.


To create a layout template

  1. Start by selecting File> New Layout  from the menu to create a new, blank layout.  


  2. Next, set the paper size, drawing sheet size, and the specify the printer for this layout.  

    • To do this, select File> Print> Drawing Sheet Setup  from the menu. 

    • In X5 and prior select File> Print> Page Setup.


  3. In the Drawing Sheet Setup dialog:  



         
    • Select the Drawing Sheet size you will be using.  

      In most cases, the Printer Paper and Drawing Sheet sizes as well as the page orientation should be the same. 

      In X5 and prior products you need to set the printer paper and the Printer on this dialog as well.

    • Make sure the Drawing Scale is set at a 1 to 1 scale.  

      Example: 1 in = 1 in 

      It is important not to change this, as the drawing scale is set when you send individual views to the layout.


      For more information about drawing scale as well as line weight scaling, click the Help button at the bottom of this dialog.

    • Click OK to apply your settings to this layout file and close the Drawing Sheet Setup dialog.  


To create a layout border

  1. First, go to page 0 of the layout sheet.  



    Page 0 is the Default Page Template, Items placed on this page show on every page of the layout that is assigned to follow this Page Template. It is possible to set up more than one page template. Please refer to the software's Reference Manual for more information on creating additional Page Templates.



  2. Using CAD drawing tools, create the borders and title blocks that you want to be on each page of the layout.  


  3. Using Text or Rich Text , add your company name, project information and any other notations that you want to display on every page of the layout.  


  4. To insert your company's logo or other image, select File> Import> Picture  from the menu.  

    Chief Architect can import the following file types: .bmp, .jpg, .png, .gif, and .tif.


  5. Macros are special commands that insert dynamic information into a text object.  

    They can be inserted in Text by selecting the Insert> option, and in the Rich Text Specification dialog using the Insert Macro  tool.  

    Text Macros are available in both plan and layout files but are particularly useful in layouts, allowing you to automatically insert useful information such as the page number, date and time, and file name.  



  • Use a Text Macro to show the page number for each page of the layout. 

  • Make sure to leave enough room in the text box to allow for 2 or 3 numbers depending on how many pages you expect to use.

  • Use one of the Date or Time macros to insert the date or time in the layout sheet to automatically let you know when you printed this layout.

  • Add the file name for this layout sheet using one of the File Info text macros.

  • Inserting this next to the binding edge will allow you to determine which file it is or even where this set of plans is located on your computer, should you need to reprint them in the future. 

Now we are ready to save this file and use it as a layout template.


To save and use this file as a template

  1. Select File> Templates> Save Plan as Template .  


  2. Give the new layout template a logical name.  

    Be sure to delete the asterisk (*).  


  3. Click the Save button, and the program automatically saves the template to the Templates directory on your computer.  


  4. To use this template to create a new layout, select File> Templates> New Layout from Template .


To use this layout whenever you open a New Layout File

To use the layout as your template whenever you open a New Layout  file, specify it as your template in the Preferences dialog.

  1. Select Edit> Preferences  from the menu.  


  2. In the Preferences dialog: 


     

    • On the New Plans panel of the dialog, click the Browse button to the right of the Layout Template text field.  

    • In the Select a Layout Template File dialog, browse to the location of your new layout template file and click Open to specify this file as your layout template.  

    • Click OK to close the Preferences dialog and apply your change.


Attachments
Profile1.layout 0.1 Mb Download File