Browse
Categories

Creating Your Own Plan Database

Reference Number: KB-00740 Last Updated: 07-29-2014 02:23 PM

The information in this article applies to:

Chief Architect Premier

QUESTION

How can I use the Plan Database tool in Chief Architect to quickly find plans that I have created?


ANSWER

A Plan Database is a special list that stores information such as the type of construction, number of rooms, and price of each plan in the database.  Once a database is created, you can use the Find Plan Wizard to search for plans that meet the construction, size and price criteria that you specify.

Creating a Plan Database that is useful to both you and your clients involves several steps:

  • Creating a plan database file. 

  • Adding plans to the database. 

  • Assigning a price to each plan. 

  • Creating styles to organize the database. 

  • Creating thumbnail images for the plans in your database. 

  • Copying your plan database for viewing by clients in the Chief Architect Client Viewer.




    To create a plan database

    1. Select Tools> Plan Database> Create Plan Database  from the menu to open the Create Plan Database dialog.  


    2. Click the Browse button to specify the database file's name and the location where this database will be saved.  

       


    3. Next, specify the folder that will contain the plans in your database by clicking the Browse button next to the Plan Search Path field.  

       


    4. Check the box beside Include Subfolders if you want your plan database to include plans located in subfolders of the Plan Search Path folder.


    5. If you want to distribute your plan database to clients or colleagues, check the box beside Use Relative Paths. This allows the plan database to be copied to other computers along with the plans.  



    To save plans in the database folder 

    If you want to make your plan database available to clients using the Client Viewer, it is very important to export the plan files to the plan database folder using the Backup Entire Plan function rather than simply saving or copying the files there. 

    1. Launch Chief Architect and open a plan that you want to include in the plan database. 


    2. Select File> Backup Entire Plan  from the menu. 


    3. In the Backup Entire Plan dialog, select Backup All Files (Including Textures, Backdrops and Images) and click OK.  




       

    To add or delete plans from the plan database 

    1. Select Tools> Plans Database> Edit Plan Database  from the menu. 


    2. In the Select Plan Database dialog, browse to the plan database you want to edit and open it.  

        

    3. In the Edit Plan Database dialog:  

      • Click the Add Plan button to add a new plan to the database. 

      • Click the Remove button to remove the selected plan from the database.

      • Click the Select File button to change the link of the selected plan to a new location. 

      • Click the Open Plan button to open the selected plan in Chief Architect. 



    To add pricing information to each plan

    1. Select Tools> Plans Database> Edit Plan Database  from the menu. 


    2. In the Select Plan Database dialog, browse to the plan database you want to edit and open it.  

        

    3. In the Edit Plan Database dialog, click on a plan to select it and then: 

      • Specify a Price for the model. This could be the price to purchase the plan, an estimate of the construction costs or any other price information you might want to convey. 

      • Enter a Description of the plan.  You may want to indicate what is purchased for the price indicated above. 

      • The Area, number of BedroomsBaths and Floors are added automatically based on the Living Area, number of floors, and Room Type specifications saved in the plan file.  Each of these values can be adjusted as needed in the plan database. 



    To organize plans by style

    1. From the menu, select Tools> Plans Database> Edit Plan Database 


    2. In the Select Plan Database dialog, browse to the plan database you want to edit and open it.  

        

    3. For each plan in the database, select the plan and type in a style or choose a style you have alread entered.

      

    To display thumbnail images

    1. Select Edit> Preferences  from the menu to open the Preferences dialog.  

       


    2. At the upper right corner of the General panel under Thumbnail Images: 

      • Place a check mark next to Enable. 

      • Select Large or Small images.  Selecting Large typically results in better quality images. 



    To create a custom thumbnail image

    1. Open the plan you wish to create a custom thumbnail image for. 


    2. Create the view that you want to use for the plan thumbnail, which can be a floor plan, Perspective, or Orthographic  view. 

      Hint: For a consistent presentation, consider using the same view for every plan thumbnail in your database. For example, you might always use a Render Full Overview or a front elevation.


    3. When the desired thumbnail view is active, select File> Save Plan Thumbnail  from the menu. 


    4. The next time you open the plan by selecting File> Open Plan  from the menu or use the Find Plan Wizard  to search the plan, this plan thumbnail will display as a preview image. 


      

    To save your plan database onto a disc for use with the Chief Architect Viewer

    A plan database and the associated plan files can be burned onto CDs or DVDs and then given to clients along with a copy of the Chief Architect Viewer.

    1. Save the plan database file in the same folder as the plan files that are included in it. 


    2. Be sure that the plan files were saved to this folder using Backup Entire Plan , as described above. 


    3. Copy the contents of this plan database folder onto a CD/DVD, following the instructions for your CD/DVD burner. 



    To search for plans using your plan database and the Viewer

    1. Insert the CD/DVD containing the plan database into your CD/DVD drive. 


    2. Launch the Client Viewer and select Tools> Plans Database> Search for Plans  from the menu.  

       


    3. On the Welcome page of the Find Plan Wizard, browse to the CD/DVD drive on your computer and open the plans database. 


    4. You can open and view plans in the Client Viewer directly from the CD/DVD.  If you want to add notes using the Text tools, you must first save the plan to a location on the computer's hard drive, such as My Documents.