Browse
Categories

How to use Layer Sets

Reference Number: KB-00765 Last Updated: 11-10-2014 02:56 PM

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors or Chief Architect Lite


QUESTION

What are Layer Sets and how can I use them to improve my productivity?


ANSWER

In Chief Architect, nearly all objects in the program are placed on layers, which can be thought of as transparency sheets laid over your drawing area. At any time, you can open the Layer Display Options dialog and turn layers on or off - or change their appearance - to make it easier to work in your plan or to prepare views to be sent to layout or printed.

Working with layers is advantageous because they allow you to design a single 3D model that includes everything needed for your working drawings while avoiding the frustration of having to deal with all of those objects at once.

A Layer Set can be thought of as a stack of transparency sheets gathered together for a particular purpose that can be quickly applied to your drawing. Rather than turning on and off layers one by one, layer sets allow you to quickly switch between one collection of layer attributes and another. 

If you are editing your electrical plan, for example, your job will be easier if unrelated objects such as roof planes and ceiling framing are not in the way. You could select Tools> Display Options from the menu to open the Layer Display Options dialog and then browse the dozens of layers in the list, turning off each unneeded layer; or, you could simply click the Active Layer Set Control drop-down and choose Electrical Set.

 

Chief Architect template plan files include a number of Layer Sets created for a variety of purposes, including:

  • Display settings for different types of views

  • Display settings for specific drawing tasks

  • Settings for the Reference Display and Aerial View



You can customize these Layer Sets to suit your needs as well as create your own.

Layer Sets are an extremely important consideration when sending views to layout.

 

To create a custom layer set

  1. Open the plan in which you would like to create a new layer set. For the purposes of this article, a floor framing layer set will be created.



    Alternatively, you can select File> New Plan to create a new, blank plan.


  2. Select Tools> Layer Settings> Layer Set Management  from the menu. In the Layer Set Management dialog, scroll through the list of the various Layer Sets that are already available.

    In previous versions click Tools> Display Settings> Layer Set Management



    • Notice that there are two sets that relate to framing: the "3D Framing Set" and the "Framing Set".

    • The "3D Framing Set" is the default set for Orthographic and Perspective Framing Overviews.

    • The "Framing Set" is a generic set for examining framing objects that has all framing layers turns on and most other layers turned off. It will make a good starting point for creating a Layer Set specifically for floor framing.


  3. Click on the "Framing Set" to select it, then click the Copy button. In the New Layer Set Name dialog, type a short, descriptive name such as "Framing Set - Floors", and click OK.



    • Layer Sets must have unique names. If you try to give the new Layer Set a name that already belongs to a Layer Set in the current plan, the program will ask you to choose a new name.


  4. In the Layer Display Options dialog, which opens next, notice that the name of your new Layer Set displays in the Available Layer Sets drop-down.

    • This means it is currently selected for editing and any changes that you make to the layer settings below will affect this particular Layer Set.


  5. Make any needed changes to the new Layer Set. In this example:




    • All of the "Framing" layers are turned off except for the layers that pertain to Floor Framing

    • The "Walls, Main Layer Only" layer is turned on.

    • All non-framing layers are assigned a medium grey color with a line weight of 18, while the "Framing" layers are black with a line weight of 35.


  6. When you are finished customizing the new Layer Set, click OK to return to the Layer Set Management dialog.

    • Notice that your new Layer Set is included in the list but is not selected as the Active Layer Set.

    • You can select it from the Active Layer Set drop-down list, which will put it in use when the dialog is closed; however, for the purposes of this example, we will click OK to close the dialog without making any changes.


To use a custom layer set

Now that we have created a custom Floor Framing Layer Set, we can use it to control the display of views in this plan file. In this example, we will create a view of the floor framing and foundation walls.

  1. Go to the view where you would like to use your Layer Set. In this example, we will go to Floor 0 in floor plan view to display the floor framing for Floor 1.


  2. Notice the name of the currently active Layer Set displaying in the Active Layer Set Control drop-down on your toolbar. In this example, the Default Set is active.


  3. Click the Active Layer Set Control drop-down arrow and choose your custom Layer Set from the list.




  4. When you select your new Layer Set, it will instantly be applied to the current view.




    In version X3 Premier and newer, you can also create a Floor Framing Annotation Set to go along with your Floor Framing Layer Set, and add dimensions, text, callouts, markers and other annotation set up specifically for your floor framing views. More information can be found in the Setting up Custom Annotation Sets linked in the Related Articles section.


To export and import custom layer sets

Once you have created custom Layer Sets like "Framing Set - Flooring" in one of your plans, you can transfer them into other plan files by exporting and then importing them.

  1. In the plan file where you created your custom Layer Sets, select File> Export> Layer Sets  from the menu.

    • In the Save Layer Set File dialog, type a short, descriptive Name and choose an easy-to-find location on your hard drive, then click OK.


  2. Open a plan file in which you would like to use your custom Layer Sets.


  3. Select File> Import> Layer Sets  from the menu.

    • In the Open Layer Set File dialog, browse to the location where you saved your file in step 1, above, select it, and click the Open button.


  4. In the Import Layer Sets dialog which opens next, browse through the list of Layer Sets and select the set or sets that you would like to import into the current plan.



    • To import multiple sets, hold down the Ctrl key, on Windows, or the Command key on Mac, while you click on different names.

    • Click OK to close the dialog and import the selected Layer Sets.


  5. If the current file already has a Layer Set with a particular name, the program will ask you if you want to replace the existing Layer Set.

    • Click Yes to replace the existing Layer Set with the new one you are importing.

    • Click No to get rid of the existing Layer Set and import the new one to replace it.


MORE INFORMATION

In most cases, you will want any changes that you make to a given Layer Set to affect only that individual set. Occasionally, though, you may find it helpful to apply a particular change to all Layer Sets.

 

To modify all layer sets

  1. Select Tools> Layer Settings> Display Options  from the menu.


  2. Click the Layer Sets drop-down arrow and select a Layer Set from the list.


  3. Check the box beside Modify All Layer Sets.


  4. Make any changes that you want to any layer or layers.


  5. Uncheck the box beside Modify All Layer Sets.


  6. Click OK to close the dialog and apply your changes to all Layer Sets in the current plan or layout.