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Understanding Layer Sets

The information in this article applies to:

QUESTION
What are layer sets and how are they used in Chief Architect?

ANSWER
In Chief Architect, nearly all objects in the program are placed onto layers that have
di erent attributes, of which can be modi ed. Working with layers is advantageous
because they allow you to design a single le that includes everything needed for your
working drawings, while avoiding the frustration of having to constantly change layer
properties when switching between views.

Layer sets can be thought of as a stack of transparency sheets gathered together for a
particular purpose that can be quickly applied to your drawing. Rather than turning on
and o  layers one by one, layer sets allow you to quickly switch between one collection
of layer attributes and another. Additionally, layer sets are connected to saved plan
views, which allow you to change a variety of options in the program with a single click.
If you're editing your electrical plan, for example, your job will be easier if unrelated
objects such as roof planes and ceiling framing are not in the way. You could access
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your Layer Display Options and browse the dozens of layers in the list, turning o  each
unneeded layer for the view you're in; or, you could simply switch to the Electrical
Saved Plan View which could be associated with an Electrical Layer Set that has all of
your preferred display settings already setup to your liking.

Chief Architect template plan les include a number of saved plan views and layer sets
created for a variety of purposes, including:

Display settings for different types of views.
Display settings for specific drawing tasks.
Settings for the Reference Display.

You can learn more about layer sets in the sections below:

Managing and linking layer sets to saved plan views
Linking layer sets to other types of views
Using saved plan views to switch layer sets
Using the Active Layer Display Options to switch layer sets
Exporting and importing layer sets
Modifying all layer sets in a file

Understanding how saved plan views function and how they are
associated with layer sets, as well other defaults, is fundamental in
establishing a productive work ow. Please view our resources on saved
plan views (https://www.chiefarchitect.com/search/?
default_tab=all&q=saved+plan+views&page=1) to learn more.

Managing and linking layer sets to saved plan views
1. Open the plan in which you would like to manage layer sets, or open a New Plan 

 , and then navigate to Tools> Layer Settings> Layer Set Management .

Here, you can scroll through the list of the various layer sets that are setup in the
plan and make modifications.

https://www.chiefarchitect.com/search/?default_tab=all&q=saved+plan+views&page=1


To customize layer properties for an existing layer set, select the name of the
layer set to highlight it, then click Define to open the Layer Display Options
dialog.

Layer settings such as line style, line color, line weight, text style, whether or not a
layer is locked, and if a layer is displayed for the layer set can be specified here.



Click the New button to open the New Layer Set dialog and create a new layer
set. Layer sets must have unique names. If you try to give the new layer set a
name that already belongs to a layer set in the current plan, the program will ask
you to choose a new name.

Once a name is specified and you click OK, the Layer Display Options dialog will
open for the newly created layer set allowing you to specify your desired layer
settings.

Click the Copy button to open the New Layer Set dialog and create a new layer



set based on a copy of the currently selected layer set.

Again, once a name is specified and you click OK, the Layer Display Options
dialog will open for the newly created layer set allowing you to specify your
desired layer settings.

Click the Rename button to rename a layer set and the Delete button to delete
layer sets.

The layer set specified as the Active Layer Set For Current View cannot be
deleted.

It's highly recommended that you don't delete any layer sets that are
being referenced or used by a layout le.

Also, any changes made to a layer set in one view a ects all other
views that use the same layer set.

Click the Import button to import layer settings from a .layers file or the Export
button to export the layer settings in the current plan in a .layers file.

More information on importing and exporting layer sets can be found further
down in this article or by accessing the Help button at the bottom of the dialog.

The Active Layer Set for Current View option displays the layer set that is used
in the plan view that was active when this dialog was opened.

2. When you're finished customizing layer sets, click OK to confirm the changes and
close the dialog.

3. Layer sets should be linked directly to a saved plan view unless you have created a
layer set for the purposes of using it with a 3D Camera view, Cross Section/Elevation
view, CAD Detail, Wall Detail, Truss Detail, or the Reference Display. A layer set can
be linked to a saved plan view by navigating to Tools> Active View> Edit Active
View  to link it to the currently active plan view, or by accessing the Project

Browser , right-clicking on the desired plan view, and choosing Edit View.



New saved plan views can be created by navigating to Tools> Active
View> Save Active View As or by right-clicking on the Plan Views folder in
the Project Browser and selecting "New Saved Plan View."

On a Mac, hold down the Control key while clicking to initiate a right-
click command. More information about right-click commands on Apple
input devices can be found in the following Apple resource: Right-click
on Mac (https://support.apple.com/guide/mac-help/right-click-
mh35853/mac).

4. On the SELECTED DEFAULTS panel of the Plan View Specification that displays,

select the the Layer Set drop-down to designate which layer set you'd like to link to
the plan view. In most cases, you will want to have a different layer set associated
with each plan view.

https://support.apple.com/guide/mac-help/right-click-mh35853/mac


5. Click OK to close the dialog. Now, the layer set and the saved plan view will be
linked. 

Linking layer sets to other types of views
When a view other than a saved plan view is created, you may notice that it is also
linked to a layer set. For example, when a Cross Section/Elevation view is created, the
Section View Layer Set is used for that view by default; when a Framing Overview is
created, the 3D Framing Layer Set is used by default. These can be managed and setup
to your liking by accessing the Default Settings.

1. Navigate to Edit> Default Settings ,  click on Layer Sets, and then click Edit.

2. In the Layer Set Defaults dialog, notice the layer sets that are setup for each
particular type of view.



3. Make any desired changes, then click OK.

We don't recommend using the same layer set between a saved plan
view and a di erent type of view. For example, don't link the "Working
Layer Set," which is connected to the "Working Plan View," to any other
type of view listed in this section.

4. Staying within the Default Settings dialog, expand the Camera Tools category,
select each camera tool, either all at once, or one-by-one, then click Edit.

5. On the SELECTED DEFAULTS panel of the Camera Defaults dialog that displays,

specify your desired Layer Set to be used.



6. Once all desired changes are made, click OK and Done to close the dialogs.

Using saved plan views to switch layer sets
Saved plan views are linked to default/annotation sets as well as layer sets, and allow
you to switch between them simultaneously with a single click. When a plan view is
changed to a di erent plan view, the layer set may change if it's speci ed to do so
within that plan views speci cation dialog.

1. Open a plan view that you want to switch the layer set for.

2. On your toolbar, look for the Saved Plan View Control drop-down, click on it once,
and then select a different saved plan view from the list. You can also switch
between saved plan views by accessing the Project Browser  side window.

When you switch between saved plan views, the layer set should also change if it's
setup to do so.

For demonstration purposes, you can see that the image below shows that the layer
set now matches the saved plan view.

Note: If changing the plan view does not also change the active layer set, the
plan view may not be setup to change or it's not linked correctly to the view.



Please refer to the first section in this article or view the resources on saved
plan views (https://www.chiefarchitect.com/search/?
default_tab=all&q=saved+plan+views&page=1) to learn more.

Using the Active Layer Display Options to switch layer sets
The Active Layer Display Options is a side window that is typically docked beside the
Project Browser and Library Browser. This side window allows you to see and make
layer-related changes on the y for the view that's active. The layer set can also be
changed here if it's displayed.

1. Open a view that you want to switch the layer set for.

2. If the Active Layer Display Options is not displayed, navigate to View> Active Layer
Display Options  to turn on the display of this side window.

3. Click the Settings button at the bottom of this side window and enable the Layer
Set Control option to be displayed if it's not already.

4. With the Layer Set Control now displayed, the layer set can be changed for the
active view.

https://www.chiefarchitect.com/search/?default_tab=all&q=saved+plan+views&page=1


If you use the Active Layer Display Options to switch between layer sets
without switching plan views, you should be in the "Working Plan View"
or you should have the intention of switching back to the layer set you
want associated with the currently active plan view.

Exporting and importing layer sets
Once you have created custom layer sets like in one of your plans, you can transfer
them into other plan les by exporting and then importing them.

1. In the plan file where you created or customized layer sets, select File> Export>
Export Layer Sets  from the menu or navigate to Tools> Layer Settings> Layer

Set Management , and click on the Export button.

All layers in the file will be exported to a .layers file no matter which method is
chosen.

2. In the Export Layer Set File dialog, type a short, descriptive Name and choose an
easy-to-find location on your computer such as the Desktop or Documents, then
click OK.

3. Open a plan file in which you would like to use your custom layer sets, select File>
Import> Import Layers Sets  from the menu or navigate to Tools> Layer

Settings> Layer Set Management , and click on the Import button.

4. In the Import Layer Set File dialog, browse to the location where you saved your
file in step 2 above, select it, and click the Open button.

5. In the Import Layer Sets dialog which opens next, browse through the list of layer
sets and select the layer set(s) that you would like to import into the current plan.



Choose whether you want to Replace existing layer sets that have the same
name or to Create a new copy.

If you're importing layer sets that have the same name as existing layer sets
already present in the file, and you choose the Create a new copy option, the
new, imported layer sets will have a number appended onto the name.

Click OK to close the dialog and import the selected layer sets.

Modifying all layer sets in a le
In most cases, you will want changes that you make to a given layer set to a ect only
that individual set. Occasionally, though, you may nd it helpful to apply a particular
change to all layer sets in a plan.

1. Select Tools> Layer Settings> Display Options  from the menu.

2. Click the Layer Sets drop-down arrow and select a layer set from the list.
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3. Check the box beside Modify All Layer Sets.

4. Make any changes that you want to any layer(s) that you would like reflected in all
layer sets.

5. Uncheck the box beside Modify All Layer Sets once your desired changes have
been made.

6. Click OK to close the dialog and apply your changes to all layer sets in the current
plan or layout.

Return To Top

Customizing Toolbars (/support/article/KB-00811/customizing-toolbars.html)
Message: This new layout box references the "Layout Set 1" layer set saved in your

plan. (/support/article/KB-00939/message-this-new-layout-box-references-the-layout-
set-1-layer-set-saved-in-your-plan.html)

Setting up a Custom Default/Annotation Set (/support/article/KB-01167/setting-up-a-
custom-default-annotation-set.html)
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