Browse
Categories

Adding Detail to a Cross Section View

Reference Number: KB-00766 Last Updated: 11-10-2014 02:56 PM

The information in this article applies to:

Chief Architect Premier


QUESTION

How can create a detail drawing from a ­cross section view?




ANSWER


Chief Architect provides several ways to create detail drawings of your plan.

  • The Auto Detail tool is available in cross section views and quickly adds basic ­concrete, wall ­insulation and siding patterns to the view with a single click.

  • The CAD Blocks library includes a selection of blocked detail drawings and components that can be placed in CAD Detail views and used as they are or unblocked and edited to meet your needs.

  • Using the CAD drawing tools, you can create your own detail drawings from scratch.


These tools and resources can be used singly or you may choose to use a combination. For example, you could begin by Auto Detailing a cross section view. Next, you might send the view to a CAD Detail and add a detail drawing from the CAD Blocks library. The detail drawing can then be unblocked and edited and the CAD drawing tools used to add further information that can be superimposed on the cross section.

This article provides an overview of how to use the CAD tools to create a new ­foundation detail drawing, but the same tools and techniques are also helpful when editing existing drawings. Topics discussed include:

  • Placing and editing components from the library

  • Drawing components manually

  • Accurately positioning components

  • Placing details in a cross section view

  • Adding drawings to the library


To place and edit components from the library

  1. Open a plan in which you would like to create a detail drawing and select CAD> CAD Detail Management from the menu.

     

    • In the CAD Detail Management dialog, click the New button.

    • In the Create New CAD Detail dialog, type a descriptive New Detail Name, then click OK to close the dialog and open a new CAD Detail window.

    • You can send a cross section view to a CAD Detail and then draw detail information directly over it, but in this example we will draw the detail in a blank window.


  2. Select Library> Library Browser from the menu to open the Library Browser.

    • Locate the CAD Blocks library category and click the + beside it to expand its contents.

    • Browse to CAD Blocks> Detail Components> Footings and Slabs, where a selection of ­footing and ­slab components is available.

    • Click on a component to select it. In this example, the Concrete Footing is used.

    • When you move your cursor into the drawing area, it displays the CAD Block icon. Click once to place the selected CAD block in your CAD Detail window.




  3. In order for this item to be added to the library, it was made into a CAD block. To edit it as a CAD object, click on the footing to select it, then click the Explode CAD Block edit button.


  4. Click on the footing to select it again and click the Open Object edit button. On the Fill Style panel of the Polyline Specification dialog:




    • Select Concrete from the Fill Pattern drop-down list.

    • Specify the desired Spacing, Angle, Line Weight and Fill/Pattern Color.

    • On the Line Style tab, select a Line Color, Style and Weight.

    • Click OK to close the dialog and apply your changes.



To draw components manually

Depending on your requirements for a particular detail drawing, you may find that you use all of the CAD Tool families: Lines, Arcs, Splines, Boxes and Circles. In this example, we will focus on closed polylines; however, the nearly all of the concepts apply to open polylines, as well.

Two of the Box Tools; Rectangular Polyline and Box, seem very similar at a glance but are actually quite different from one another:

 

Rectangular Polylines are composed of lines, just as their name implies, so each of their edges can be edited in the same way that lines can: they can be broken, trimmed, curved, deleted and so on.

 

Boxes are always closed shapes with four 90 degree corners. Their corners can be filleted or chamfered but their edges cannot be extensively edited. Boxes are useful when the item being drawn needs to remain a closed shape with right angles. For this reason, framing cross boxes and insulation are created using Boxes.

  1. Select CAD> Boxes> Rectangular Polyline from the menu, then click and drag a vertical rectangle to form the foundation stem wall.

    • Don't worry about the exact size or location as you draw it: instead, use Temporary Dimensions to resize it precisely once it is drawn.

    • In this example, a stem wall 8" wide and 24" high is used.

    • To place the stem wall precisely, see To accurately position components, below.


  2. With the rectangular polyline still selected, click the Open Object edit button. On the Fill Style panel of the Polyline Specification dialog:

    • Select Concrete from the Fill Pattern drop-down list.

    • Specify the desired Spacing, Angle, Line Weight and Fill/Pattern Color.

    • On the Line Style panel, select a Line Color, Style and Weight.

    • Also on the Line Style panel, choose Back Group or Front Group to 'layer' objects in front of one another. For example, the ground polyline, which displays 'behind' the other foundation objects, has Back Group checked.

    • Click OK to close the dialog and apply your changes.


  3. In this example:

    • The CAD> Circles> Circle tool is used to create rebar in the footing and stem wall concrete.

    • The CAD> Boxes> Cross Box tool is used to create framing members.

    • The CAD> Boxes> Insulation tool is used to create sections of insulation in the floor and wall.

    • The CAD> Lines> Line tool is used to represent the grade line.

    • Polylines are edited using Break Line , Change Line/Arc and other edit tools to create irregular shapes of the ground and drainage areas.

    • The Leader Line tool is used to create annotations. (In Version 10 and prior, the Text with Arrow tool can be used.)


To accurately position components

In Chief Architect, there are a number of ways to position objects precisely. When preparing a detail drawing, three of the most useful tools are the CAD Stops Move specification, the Point to Point Move and Transform/Replicate Object edit tools.

CAD Stops Move is an option found on the Line Style tab of the specification dialogs of Text and closed CAD objects such as circles, polylines and boxes.

  • Check this box to enable this behavior for the selected object, and it will bump against other open and closed CAD objects when it is being moved, preventing them from overlapping.

  • A quick way to align text objects is to draw a line and then move the text so that it stops against the line, which can later be deleted.

To learn how to use the Point to Point Move edit tool, see the Point to Point Move article listed in the Related Articles section.


Objects can be copied at regular intervals using the Transform/Replicate Object dialog using the steps below.

  1. Click on an object such as a 2x12 ­joist to select it, then click the Transform/Replicate Object edit button.


  2. In the Transform/Replicate Object dialog:



    • Check the box beside Copy and specify the number of copies you want to make.

    • Check the box beside Move and specify the increments that you want the copies to be placed on the appropriate Delta, or axis.

    • Click OK to close the dialog and create the specified copies.

    • In this example, two copies are placed at 16" intervals, or 16" on-center, along the X Delta.


  3. The Transform/Replicate Object edit button is also available when objects are group selected. In this example, a 2x12 and a section of insulation could be Shift+selected, then replicated at 16" intervals as needed to quickly detail an entire ­floor platform, if needed.




To place a detail drawing in a cross section view

  1. Open the cross section view that you would like to add detailing to, or select 3D> Create Orthographic View> Backclipped Cross Section from the menu to create such a view.

    In Chief Architect X1 and prior, use 3D> Create Vector View> Backclipped Cross Section.


  2. Select CAD> CAD Detail from View from the menu to convert the view into a CAD drawing in its own CAD Detail window.


  3. Click the Window drop-down menu and select your CAD Detail window to toggle back to it.


  4. With the Select CAD Object tool active, hold down the Shift key on your keyboard and click and drag a rectangular selection marquee around your entire detail drawing. When you release the mouse button, the entire drawing is selected as a group.


  5. Click the Make CAD Block edit button to block the drawing into a single object.


  6. With the blocked drawing selected, click the Copy/Paste edit button.


  7. Select Window> Previous Window to return to your cross section view CAD Detail.


  8. Select Edit> Paste from the menu, then click once in the drawing area to place a copy of the blocked detail drawing.


  9. You can now use the Point to Point Move edit tool to place the detail over the cross section at the appropriate location.

     

To add a drawing to the library

You can add a finished detail drawing or any portion of the drawing to the library by first blocking the objects in question using the Make CAD Block edit tool. Examples of items you might want to add are a group of stacked lap siding components, a custom connector or ­anchor bolt that you have drawn, or footing and stem wall with rebar.

  1. Click on the detail drawing or component block to select it, then click the Add to Library edit button to add the drawing to your Library Browser, where you can then rename it and move it into the appropriate folder in your user My Library folder that you have created for it.

    In Chief Architect X2, the Add to Library edit tool would place the Item in the Import category, where it then needed to be renamed and moved into the appropriate User Libraries folder.


  2. This CAD block is now available for use in any plan.