Browse
Categories

Creating an In-ground Swimming Pool

Reference Number: KB-00773 Last Updated: 11-27-2013 02:31 PM

The information in this article applies to:

Chief Architect Premier or Chief Architect Lite


QUESTION

I would like to create a ground-level swimming pool with rounded edges and a sloped bottom with different depths.  How do I do this?




ANSWER

Using the Terrain Feature Tools, Polyline Solids and 3D Molding Polylines, you can create a custom ground level swimming pool.


To create a hole for the pool

  1. Select Terrain> Create Terrain Perimeter  from the menu to create terrain in which the pool can be designed.   You can skip this step if you have a terrain perimeter already drawn.

    Feature regions follow the contours of your terrain. If you place a feature region on a ­slope, it will follow the slope rather than form a flat area. If your terrain is sloped, use Elevation Lines or a Flat Region to create a level area to place your pool in.


  2. Select Terrain> Feature> Rectangular Feature  from the menu, then click and drag to draw a rectangular feature polyline contained inside the Terrain Perimeter. 

    • In this example, a 30' X 20' rectangular polyline is used.



      This polyline will form the hole for the swimming pool.


  3. To create an L-shape, use the Select Objects  tool to select the terrain feature, then click on the Break Line edit tool and click on the edge of the feature to place a break.


  4. Now click on the edge of the polyline that you would like to bump out to select it, click on the right edge to place a 90 degree break at the point where the short part of the "L-shape" will begin, and drag out this edge.




  5. Select the Feature Polyline and click the Open Object  edit button to display the Terrain Feature Specification dialog and on the General panel:

    • Change the Height to the desired depth of the pool's deepest point.  In this example, -96" is used. 

    • Click OK to close the dialog and apply your changes.


  6. Next, select 3D> Create Perspective View> Perspective Full Overview  so that you can see the results thus far.



    Once you have verified the 3D Camera view, select File> Close to return to floor plan.



To slope the bottom of the pool

  1. Select 3D> Create Orthographic View> Backclipped Cross Section , then click and drag a camera arrow that runs perpendicular to the slope that you wish to create.




  2. In the backclipped cross section view, select CAD> Boxes> Rectangular Polyline  from the menu, then click and drag to draw a rectangle along the bottom part of the pool. 

    This rectangle will form the shallow end of the pool, as well as the slope to the deep end.  


  3. Click on the top edge of the polyline to select it, then click on the temporary dimension that displays between it and the bottom edge to specify the height above the deep end that you would like the shallow end to be.



    In this example 48" is used.


  4. With the rectangle still selected, click the Break Line  edit button and click along the top edge of the rectangle to place a break at that location.


  5. Next, drag the top left corner down to create a slope, as demonstrated below.




  6. With the rectangular polyline still selected, click the Convert Polyline  edit button to display the Convert Polyline dialog.



    Move the radio button to Polyline Solid, then click OK.


  7. On the General panel of the ­Polyline Solid Specification dialog, which comes up next, change the Thickness to 12". 

                    

    Click OK to close the dialog and finish converting the polyline into a polyline solid which will form a sloped bottom for the pool.


  8. Select File> Close view  to close the cross section/elevation view and return to floor plan view.


  9. In floor plan view, select the newly-created polyline solid and use the edit handles to adjust its width to match the width of the sloped part of the L. 

                                     


  10. If you like, repeat these steps to create a sloped section for the other part of the L.



To created a rounded ledge around the pool

  1. Select Edit> Edit Behaviors and click on Concentric , which allows you to resize objects so that the distance moved by each edge is the same.

    Note: You will notice once you have selected this option that the Concentric icon will stay next to your mouse cursor until you return to the Default edit behavior.


  2. Next, using the Select Objects  tool, click on the pool feature region to select it and click the Copy/Paste In Place  edit button.



    • Place the mouse pointer over one of the diamond shaped corner handles. 

    • Click and drag the handle slowly away from the pool. You will see that it snaps at 1 inch increments.

    • Release the mouse button so that a new region is created 3 inches out from the original.


  3. With the newly created feature region still selected, click the Convert to Plain Polyline  edit button so that it is no longer a terrain feature.


  4. Next, with the new plain polyline selected, click the Convert Polyline  edit button, select the Molding Polyline radio button and click OK.


  5. In the Molding Polyline Specification dialog:

    • On the Moldings panel, click the Add New button.

    • In the Select Library Object dialog, browse to Architectural> Molding> Chair Rails.



    • In this example, CA-13 is used.

    • Click OK to return to the Molding Polyline Specification dialog.


  6. Back on the Moldings panel, set the Height, Width and Vertical Offset values.



    • In this example, 3", 6", and -2", respectively, are used.

    • Make sure that the box beside Extrude Inside Polyline is selected.

    • Click OK to close the dialog and create a rounded ledge around the edge of the pool.


  7. Finally, take a Perspective Full Overview  to see the results so far.



    Once you have verified the 3D Camera view, select File> Close to return to floor plan.

Now that we are finished using Concentric resizing, select Edit> Edit Behaviors> Default  to return to the default editing behavior.




To create a molding profile for the pool

  1. From the menu, select CAD> CAD Detail Management , click on the New button to display the Create New CAD Detail dialog. 

    Give the detail a name of "Pool Molding" and click OK to open a new, blank CAD detail window.


  2. Using the CAD drawing tools, create the profile of the curve that you would like to use where the pool walls meet the bottom.



    Draw this profile the actual size of the rounded corners you want at the bottom of the pool. This will save you the step of resizing it later. For more information about how to create a custom molding profile visit the "Creating a custom molding profile" article listed in the Related Articles section.



  3. Once created, use the Add to Library edit tool to add this molding profile to the Library Browser in your User Catalog.


  4. Finally, select File> Close to close the CAD Detail window and return to floor plan view.



To create curved edges at the bottom of the pool

  1. Select the Pool Molding profile that was saved to Library in the previous section, then select Build> Trim> 3D Molding Line  from the menu, then click and drag to draw a molding line along the left side of the pool starting at the top and going to the bottom.


  2. Select the newly created 3D molding line and click the Open Object  edit button. 

    If you have trouble selecting the 3D Molding Line, you can use the Next edit tool or Tab key on your keyboard to select the next object until the 3D Molding Line is selected.

    You can also try locking the Default CAD Layer and the Terrain Features layers in the Layer Display Options dialog.


  3. In the Selected Line panel of the 3D Molding Polyline Specification dialog:



    • In the Lock section, click the radio button beside Length/Angle, then change the either the Start or End Z: value to -48".

  4. On the Moldings panel, remove the checkmark next to Extrude Inside Polyline. If necessary you can choose a different height and width on this panel as well. Click OK to close the dialog and apply your changes.


  5. With the Molding Polyline still selected in floor plan view, use the Break Line edit tool to place two breaks along the molding line.



    These breaks, shown above with the diamond edit handles, will allow you to edit the polyline so it follows the slope of the pool bottom.


  6. Next, select 3D> Create Orthographic View> Backclipped Cross Section , then click and drag a camera arrow to create a view through the left side of the pool.


  7. In the cross section view, click on the 3D molding polyline to select it.



    • You can also use the Break Line edit tool while in the Cross Section/Elevation view to place additional breaks, if needed.


  8. Return to floor plan view and repeat these steps, drawing 3D Molding Lines for each side of the pool, one at a time.

    • In order to make sure the molding lines connect to each other, be sure to set the ending point of the old line and starting point of the new line at the same height. 

    • For example, if you proceed clockwise around the pool and draw the second molding line along the top of the pool, you will need to set the Z value in step 1 to be -48".

  9. Now, take a Perspective Full Overview  to see the results so far.




To add water to the pool

  1. Select the pool terrain feature created in the first section of this article.

    • If you locked the Terrain Features layer earlier, you will need to unlock this layer now.

    • If you initially select an object other the terrain feature, click the Select Next Object  button or press the Tab key on your keyboard.


  2. With the Terrain Feature selected, click on Copy/Paste in Place edit button.


  3. With the pasted terrain feature still selected, click on the Convert to Plain Polyline  edit button.


  4. With the now plain polyline selected, click the Convert Polyline  edit button.

    • In the Convert Polyline dialog, choose Polyline Solid.




  5. In the Polyline Solid Specification dialog:

    • On the General panel, set the Height to -6" and the Thickness to 1".



    • On the Materials panel, click on the words Polyline Solid, then click the Library Material button.



    • In the Select Library Objects dialog, browse to Materials> Landscaping> Water and choose a water material. In this example, Water1 is used.

    • Click OK to close the dialog and apply your changes.


  6. Finally, take another 3D Perspective Full Overview  to see the results so far.



    You can now close the view, or use the Window> Tile Vertically  feature to tile the floor plan and camera views, and adjust the materials of the other elements in the design, such as the terrain feature and molding polylines.



To accessorize the pool area

A patio area around your pool can be designed using one or more terrain features with different heights and materials.  Avoid drawing a terrain feature over the pool feature, as it will cover it up.  Suitable patio materials can be found in the ­Concrete & Stone, ­Masonry, and Tile in the Library Browser.



Furniture, games and other accessories can be found in the Library Browser .


To learn how to create a water material with a bump map applied for ray trace views, that can be seen through, visit the "Using Bump Maps to Make Realistic Water Effects" article in the Related Articles section.