Browse
Categories

Using Layer Set Defaults

Reference Number: KB-00799 Last Updated: 07-30-2014 10:19 AM

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors or Chief Architect Lite


QUESTION

What is the purpose of the Layer Set Defaults dialog and how can I use the options in this dialog to my advantage?


ANSWER

In Chief Architect, nearly all objects in the program are placed on layers, which can be thought of as transparency sheets laid over your drawing area.  At any time, you can open the Layer Display Options dialog and turn layers on or off - or change their appearance - to make it easier to work in your plan or to prepare views to be sent to layout or printed.

Working with layers is advantageous because they allow you to design a single 3D model that includes everything needed for your working drawings while avoiding the frustration of having to deal with all of those objects at once.

The Layer Set Defaults dialog controls which layer set is used when a particular type of view is created. For example, when a Cross Section/Elevation view is created, the Section View Set is used for that view; when a Framing Overview is created, the 3D Framing Set is used.

In most cases, you can customize the settings in each of these layer sets to suit your needs without ever changing your defaults.  You can do this in the Layer Display Options dialog, which can be accessed in a number of ways: 

  
  • Select Tools> Display Settings> Layer Set Management  from the menu to open the Layer Set Management dialog. Click the name of the layer set that you would like to modify and click the Define button to open the Layer Display Options dialog.

  • Select Tools> Display Settings> Display Options  to open the Layer Display Options dialog. Select the layer set that you would like to customize, make any desired changes, and click OK to close the dialog, apply your changes, and return to the active view.

  • Select Edit> Default Settings  from the menu, click on Layer Sets, then click the Edit button to open the Layer Set Defaults dialog. Click the Define button to the right of the layer set that you would like to customize.

    There are times, though, when it can be very helpful to create custom layer sets for use in particular views.

    • For example, when you are working on framing cross sections, you can save time by creating a Framing Cross Section Set.


    To create a Framing Cross Section Set

    1. Select Tools> Layer Settings> Layer Set Management  from the menu.




    2. Click on the 3D Framing Set to select it, then click the Copy button. Give the new layer set a short, descriptive name such as "Framing Cross Section Set" and click OK.




    3. The Layer Display Options dialog opens next, displaying the attributes of your new custom layer set.




      • Use the Name Filter to filter the list by keyword or Scroll down the list of layer names, select Ceiling Surfaces and click in the Disp column to turn on this layer's display.

      • Other layers that you may want to display include Floor Surfaces and Walls, Foundation.

      • You can also customize the line style, color and size (or weight) for each layer.

      • Click OK to close the dialog and add your new layer set to the list of available layers. Click OK once more to close the Layer Set Management dialog.


    4. If you will be creating multiple framing cross sections and would like to use your new layer set whenever you create a new cross section view, select Edit> Default Settings  from the menu, click on Layer Sets and click the Edit button.




    5. In the Layer Set Defaults dialog, select your new "Framing Cross Section Set" from the Cross Sections drop-down list and click OK.




      The next time you create a Cross Section/Elevation, Backclipped Cross Section, or Wall Elevation view your custom layer set will be used in that view.


    6. When you are finished working on a particular aspect of your plan, such as framing, return to the Layer Set Defaults dialog and select the original layer set for that view type.


    Other examples of custom layer sets that you may find useful as Layer Set Defaults, at least temporarily:

    • 3D Terrain Set - Turn off the display of all layers that are only visible in interior views, such as Cabinets, Fixtures, Interior and Furnishings, Interior. Can be useful as the Default Camera Set when you are doing extensive work on your terrain.

    • Roof ­Overhang Footprint - Turn on the display of Roof Planes to include eaves as part of the plan footprint. Can be useful as the Default Plan Footprint Set when roof overhang area must be included for setbacks.

    • 3D Roof Speed Set - Turn off the display of all layers except Roof Planes, Roof Openings, Doors, Windows and all Walls, layers. Can be useful as the Default Camera when you are doing extensive roof editing.

    • Custom Reference Display sets - Create custom layer sets for use as the Reference Display.  For example, create a Plumbing Reference Set to display the location of Floor 1 plumbing on the Foundation floor.


      Once you have created a custom layer set in one of your plans, you can transfer it into other plan files by exporting and then importing. 

        To export and import custom layer sets

        1. In the plan file where you created your custom layer set select File> Export> Layer Sets from the menu.


        2. In the Save Layer Set File dialog type a short, descriptive name and choose to save the file to an easy to find location on your hard drive then click OK.




        3. Open a plan file in which you would like to use your custom layer sets and select File> Import> Layer Sets from the menu.


        4. In the Import Layer Set File dialog browse to the location where you saved your file in step 1 above. Select the saved file and then click the Open button.


        5. In the Import Layer Sets dialog which opens next, browse through the list of layer sets and select the set or sets that you would like to import into the current plan.


          • To import multiple sets hold down the Ctrl key while you click on different names.




        6. Click OK to close the dialog and import the selected layer sets.

          • If the current file already has a layer set with a particular name the program will ask you if you want to replace the existing layer set.

          • Click Yes to replace the existing layer set with the new one you are importing.

          • Click No to keep the existing layer set and not import the new one.


        In most cases you will want any changes that you make to a given layer set to affect only that individual set. Occasionally, you may find it helpful to apply a particular change to all layer sets.

        To modify all layer sets

        1. Select Tools> Layer Settings> Display Options from the menu.


        2. Click the Available Layer Sets drop down menu and select a layer set from the list.


        3. Check the box beside Modify All Layer Sets located at the top of the dialog.




        4. Make any changes that you want to any layer or layers that you would like reflected in all layer sets.


        5. Uncheck the box beside Modify All Layer Sets to turn off the feature.


        6. Click OK to close the dialog and apply your changes to all layer sets in the current plan or layout. 

        Layer Set Defaults are plan-specific, so you may find it useful to save often-used custom layer sets and layer set defaults as part of your template plan.