Browse
Categories

Creating a Path Light

Reference Number: KB-00808 Last Updated: 06-05-2015 11:28 AM

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors


QUESTION

I would like to learn how to create a ­symbol with a light fixture integrated into it. How can I do this?  


ANSWER

You can use the solid Primitive tools to create a wide variety of custom objects, including custom light fixtures such as path lights. In this article, we will use the Cylinder, Sphere and 3D Molding Lines in combination to create a path light.

We will first create the different components of this object, and then assemble them together to form the path lights shown in the above image. 


To create the glass enclosure

  1.  Select File> New Plan  from the menu to open a new blank plan. 


  2. Select Build> Primitive> Cylinder  from the menu, then click and drag to draw a cylinder. 


  3. Once created, click the Select Objects  button, then click on the cylinder to select it and click the Open Object  edit button.


  4. On the Cylinder panel:



    • Set the Radius.
      In this example, 2 1/2".

    • Set the Height.
      In this example, 5", 

    • Set the Z position.
      In this example, since we want the light to be directly below the wrought iron cap above, we will set the Z value to 5" below its original location, or 15 7/8".

    • Go to the Materials panel to choose an appropriate material for this portion of the light, then click OK to apply the changes.


To hollow out the interior of a cylinder

  1. With the 5" cylinder still selected, click the Copy/Paste Hold Position  edit tool to create an identical copy of this cylinder at the same location.


  2. Next, select Edit> Edit Behaviors> Concentric .

    You will notice the mouse cursor updates to indicate that the Concentric edit behavior is active.


  3. Return to the menu and select Edit> Snap Settings> Grid Snaps  to temporarily toggle off this setting.


  4. After making these setting changes, use the circle edit handle to resize the copied cylinder so that it is slightly smaller than the original cylinder, as demonstrated in the image below.




  5. Return to Edit> Edit Behaviors> Default , and Edit> Snap Settings> Grid Snaps  to re-enable these features before continuing.


  6. Now that you have two cylinders created, one resized slightly smaller than the other, use the Select Objects  tool to select the larger cylinder, click on the Solid Subtraction  edit tool, then click on the smaller interior cylinder.


  7. Select 3D> Create Perspective View> Full Overview  and rotate the view to see the results so far.



    Select File> Close to close the 3D view and return to your 2D floor plan view.


To create the cylindrical top

  1. Select Build> Primitive> Cylinder  from the menu once more, then click and drag to draw a new cylinder.


  2. Once created, click the Select Objects  button, then click on the cylinder to select it and click the Open Object  edit button.


  3. On the Cylinder panel of the Cylinder Specification dialog:



    • Verify that the X Position, Y Position and Radius are the same as the previously created cylinder.
      If they are not, set these values to match.


    • Set the Height.
      In this example, 2".

    • Set the Z position value.
      In this example, 20 7/8" will account for the Height of the hollow cylinder shape.


  4. On the Materials panel of the Cylinder Specification dialog, select a material for the top of your light fixture, then click OK to apply the changes.


  5. If you were to take a Full Overview  camera view of the progress so far, it should look similar to the image below.



    You can then select
    File> Close to exit out of the 3D view and return to the 2D floor plan view.


To create a curved base

  1. Select 3D> Create Orthographic View> Cross Section/Elevation , then click and drag a camera view towards the cylinder shapes.


  2. Select Build> Trim> 3D Molding Line , then from left to right click and drag out a molding line segment.




  3. Next, select Window> Tile Vertically  so that you can see both the 2D floor plan view tiled with the Cross Section/Elevation view, and observe the line that represents the newly drawn Molding Polyline in floor plan view.


  4. With the floor plan view active, use the Select Objects  edit tool to select the line representing the 3D Molding Line to select it, and use the center square Move edit handle to position it centered over the circles representing the cylinder shapes.




  5. With the 3D Molding Line still selected, click on the Open Object  edit button to display its Specification dialog.


  6. On the Moldings panel:



    • Click on the Replace button to choose a molding profile different from the default square.
      For the purposes of this example, we will use the Round molding profile from the Architectural > Molding > Handrails folder.

    • Set the Height and Width of the molding.
      For this example, both of these values are set to 1/2".

    • Set the Horizontal Offset value.
      For this example, -1/4" will allow the line representing the molding in floor plan view to remain accurately representing the center of the molding, rather than its edge.

    • On the Materials panel, set an appropriate material for the molding, then click OK to apply the changes.


  7. Reactivate the Cross Section/Elevation view, then select and reshape the molding polyline as desired to create the curved base of the path light.



    • The Break Line  edit tool can be used to break the line segment and create additional edit handles to reshape the line.

      You can remove an edge by clicking and dragging an edit handle until it snaps to an adjacent corner handle.


    • The Change Line/Arc  edit tool allows you to convert the selected segment from a line to an arc, or vice versa.

    • You may find it helpful to zoom in on particular segments of the line in order to more accurately adjust it, then zoom back out to see the overall effect.

    • To learn more about reshaping polyline objects, such as the 3D Molding Line, please search the online tutorial videos for the keyword "break line" and review the Editing CAD Polylines training video.

  8. Finally, to connect the curved base to the cylinders, reactivate the 2D floor plan view, then select Build> Primitive> Sphere , then click and drag a small sphere in the center of the existing circle.


  9. You can now resize and reposition the sphere either by opening its Specification dialog, or directly in the Cross Section/Elevation view.




  10. Select 3D> Create Perspective View> Full Overview  to see the results so far.




If there are any additional primitives or molding polylines that you would like to add to embellish the fixture, add them now, and after the basic light fixture has been created, it will be time to turn it in to a symbol.

To convert the objects to a symbol

  1. With the 3D camera view still active, select Tools> Symbol> Convert to Symbol  to display the Convert to Symbol dialog.



    • For the Symbol Category, select Electrical from the drop down menu.

    • Check Add To Library.

    • Check Show Advanced Options.

    • Click OK to display the Symbol Specification dialog.


  2. In the Symbol Specification dialog:



    • On the 3D panel, give the symbol a descriptive name.

    • On the Options panel, check the boxes next to both Outdoor and Light.

    • Click OK to add the symbol to the Library Browser.


  3. Locate the symbol in your User Catalog based on the descriptive name you gave it, then right-click on the name and select Open Object .


  4. In the Electrical Service Specification dialog, on the Light Data panel:



    • Under Light Characteristics, set the Source TypeIntensity and Color.
      For the purposes of this example, use a Point Light of 850 Lumens (60W) and a light yellow color.

    • Check Soft Shadows (Ray Tracing).

    • Above the dialog's 3D preview, use the drop-down of rendering techniques to change from the default of Vector to Standard.

    • Next, under Options, check Show Position in Camera View, which will assist with positioning the light source correctly by indicating the position of the selected light.

    • Using the red light source position indicator, adjust the From Base, X Position and Y Position values until the light source is located at an appropriate position with relation to the fixture. 

      You may find it helpful to rotate the preview to ensure that the light source is accurately centered.

      For the purposes of this example, a From Base value of 18 1/2" and an X Position of 2" works well.

      Once the light source is positioned as desired, you can uncheck Show Position in Camera View so that this indicator does not display in the Library Browser preview or camera views you create of this light fixture in the future.

    • Click OK to apply these changes to the symbol in your User Catalog.


  5. You are now ready to add this new symbol to your designs, or continue creating more custom light symbols.