Browse
Categories

How to Create a Color Palette Toolbar

Reference Number: KB-00816 Last Updated: 12-05-2013 12:16 PM

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors or Chief Architect Lite

QUESTION


I have noticed the Color Palette toolbars that can be used in Vector and Render views and would like to create my own Color Palettes. How can I do this?



ANSWER


Color Palettes are toolbars that feature buttons with materials from the Library Browser assigned to them.  When you click one of these buttons, the Material Painter tool becomes active, with that material ready to apply to surfaces in your view.


Color Palettes can be organized to meet your needs.  You can, for example, create a palette with materials from a particular manufacturer library or select a variety of materials from different libraries that complement one another.

 

To create a custom toolbar 
  1. Select Tools> Toolbars and Hotkeys> Customize Toolbars  from the menu.   


  2. On the Tools panel of the Toolbar Customization dialog, select 3D View from the list of View Types.  

       


    • Your selection will determine what buttons are available in the Main Toolbar Buttons list and also what view types your custom toolbar will be available in.  


  3. Still on the Tools panel, browse the list of Main Toolbar Buttons and click on the Place Library Object  button.  

    • Notice the description of the tool's use that displays at the lower left corner of the dialog.   

       


  4. Hold down your mouse button and drag the selected button outside the Toolbar Customization dialog box and into the drawing area.  

    • As you drag, the cursor will display the library button  icon.  

    • When you release the mouse button in the drawing area, a new toolbar is created with the  Place Library Object  button in it.

    • If you were to drag the button to an existing toolbar, it would be added to that toolbar instead of creating a brand new toolbar.  

    • Just like other toolbars, this toolbar later can be dragged and docked to the top, bottom or side of the Chief Architect drawing area, or it can remain floating.    


  5. Click and drag to add more copies of the Place Library Object  button to your new toolbar as desired. Each copy will be assigned an individual material, so place as many copies as you wish to have materials on the toolbar.  

     


  6. To rename the toolbar, select the Toolbar panel of the Toolbar Customization dialog.  

     

    • Double-Click the Name of the toolbar button to rename it.

  7. Click OK to close the Toolbar Customization dialog.  

    Your custom toolbar will now display at the location that you last placed it any time you are in a Perspective Camera   view.



 

To create Color Palette buttons

  1. Select 3D> Create Perspective View> Full Camera  from the menu, then click and drag to create a render camera view.  


  2. Click on one of the Place Library Object  buttons on your toolbar.  


  3. In the Library Object Button Specification dialog that opens, click the Library button.  

     


  4. In the Select Library Object dialog, which opens next, browse to and select the first material that you would like to assign to your Color Palette, and then click OK.  

    • Library materials are typically found in the Chief Architect Core Catalogs> MaterialsBonus Catalogs, and Manufacturer Catalogs categories. Materials can also be saved in the User Catalog.  


  5. Specify how you would like your new Color Palette button to look by clicking on one of the choices in the Button Icon Choices section of the dialog and specify a name in the Button Name section then click OK.  

     


  6. Repeat these steps for each Place Library Object  button on your toolbar.  

     


  7. If you want to change the material or icon assigned to a button, double-click on that button at any time to open the Library Object Button Specification dialog and make whatever changes you wish.  


  8. If you need to add more buttons to your Color Palette toolbar, open the Toolbar Customization dialog and drag more copies of the Place Library Object  button onto it.  


  9. To remove an unneeded buttons, simply drag it off the toolbar while the Toolbar Customization dialog is open.   


     

To use a Color Palette toolbar

Once you have created a Color Palette, using it to apply materials in your plan is easy.

  1. Select 3D> Create Perspective View> Full Camera  from the menu, then click and drag to create a render camera view.  


  2. Select 3D> Materials> Material Painter  from the menu and select the Material Painter Mode that best suits your needs.  

    • In this example, Material Painter Component Mode  is used to paint individual components of an object.  


  3. Click on a button on your Color Palette toolbar and notice that your cursor displays the Material Painter  icon.  


  4. Move your cursor over an object's surface and click to apply the selected material to that surface.