Browse
Categories

Creating a Beam with a Decorative End Cut

Reference Number: KB-00894 Last Updated: 03-26-2014 10:30 AM

The information in this article applies to:

Chief Architect Premier or Chief Architect Lite


QUESTION

I am designing a custom pergola and need to model beams that have custom decorative end cuts. How can I do this?


ANSWER

If your project calls for custom decorative ends, probably the easiest way to create them is using Polyline Solids. 

You can convert these objects into symbols, allowing you to save them in the library for future use and also customize their Component information so they are calculated in a way that best suits your needs.



To design a ­beam with a decorative end

  1. Open a new, blank plan and select CAD> Boxes> Rectangular Polyline  from the menu.


  2. Click and drag a rectangle in the approximate size and shape that you want your beam to be.

    • Don't worry about drawing it accurately - you can re-size it with precision in a moment.


  3. Click on the rectangle to select one of its edges, then click on the Temporary Dimension that shows you how far it is from the opposite edge. Type in the desired distance and hit Enter on your keyboard.

    • If you do not see a temporary dimension when the polyline is selected, select View> Temporary Dimensions from the menu to toggle them on

    • In Prior versions this was found in CAD> Dimension> Display Temporary Dimensions .

    • In this example, a rectangle measuring 5 1/2" x 14' is drawn with a horizontal orientation.


  4. Use the polyline's edit handles and edit toolbar buttons to customize its shape.


    • Particularly if you would like to add the decorative end design to the library for use as a ­rafter detail profile, it's best to draw the decorative end on the beam's right side.

    • Use the Break Line  edit tool to add breaks, or corners to the polyline's edges.

    • Use the Change Line/Arc  edit tool to change the selected edge from a straight line into an arc, or vice versa.


 

To save the decorative end design as a rafter tail profile

If you would like to use the same end cut design for your roof rafter tails, you can add it to the library. Rafter tail profiles function like molding profiles, so they need to have an open shape with the opening on the left side of the polyline.

  1. Select the closed polyline and click the Copy/Paste  edit button.


  2. Click in the drawing area to place a copy of the polyline at that location. 


  3. Select CAD> Lines> Draw Line  from the menu, then click and drag to draw a vertical line through the newly pasted polyline.



    • Make sure that the CAD line extends past both the top and bottom edges of the closed polyline.


  4. Click on the vertical line near the point where it intersects the either the top or bottom edge of the closed polyline, then click on the temporary dimension that shows the line's distance from the beginning of the decorative edge design.


  5. In the inline text field that displays, type in 1/2" (about 10 mm) and press the Enter key.




  6. With the vertical line still selected:

    • Click the Trim Object(s)  edit button.




    • Click and drag a temporary selection fence (line) through the part of the closed polyline to the left of the vertical line.

    • When you release the mouse button, only the decorative end cut design to the right of the vertical line will remain.



  7. Click on the end cut design polyline to select it, then click the Add to Library  edit button.

    • The end cut design will be added to the User Catalog category.

    • Right-click on it, select Rename from the ­contextual menu, and type a short, more descriptive name for your custom rafter tail profile.

    • You can move the molding profile into customer folder in your User Catalog, where you can organize all of your custom library content to suit your organizational style.


To create a beam symbol using a library rafter tails profile

If you want, you can use a rafter tail profile from the library as a template for your beam symbol's decorative end cut.

  1. Open a new, blank plan and select View> Library Browser from the menu. 


  2. Browse to the rafter tail profile that you would like to use, right-click on it and select Place Molding Profile from the contextual menu. 




  3. Click in the drawing area to place an open polyline in the exact shape of the rafter tail profile. 
  4. Make any adjustments that you may need to the profile's shape or size using the edit handles and/or edit toolbar buttons. 

    • Most rafter tail profiles in the Chief Architect library are 5 1/2" in height. 

    • If you would like to maintain the same shape and proportions but increase its overall size, you can do so using the Concentric Edit Behavior


  5. When the profile looks the way you want it to, click on its top edge to select it and click the Open Object edit button. 


  6. On the Selected Line panel of the Polyline Specification dialog: 



    • Under the Lock heading, click the radio button beside End Point to lock the position of the right side of that edge. 

    • If you selected the bottom edge rather than the top edge, lock the Start point instead. 

    • Under the Length/Angle heading, specify the desired Length of the top edge of your custom beam. 

    • Click OK to close the dialog and apply your change. 


  7. Select Window> Fill Window from the menu or press the F6 key to zoom out so you can see the entire polyline. 


  8. Select CAD> Lines> Draw Line from the menu, then click and drag to draw a vertical line downward from the left end of the newly extend top edge. 


  9. Click on the polyline to select it, then either click and drag the end edit handle on the bottom edge to the left until it meets the vertical line drawn in step 8, or draw a CAD line from the bottom edge to the vertical line. 

    • Make sure that the Default Edit Behavior  is active when editing the shape of the polyline. 


  10. Using the edit handles, adjust the end points as needed so that they snap together to form a closed polyline. 



    • You can confirm that a polyline is closed by opening its specification dialog. On the Polyline panel, check to see if an Area value is provided. If it is not, the Area will be described as "Not closed".



To convert a closed polyline into a ­polyline solid

  1. Select the closed polyline, then click the Convert Polyline edit button. 


  2. In the Convert Polyline dialog, click the radio button beside Polyline Solid, then click OK




  3. In the Polyline Solid Specification dialog, which opens next, specify the desired Elevation at Top, thickness, and material for the newly created 3D object, then click OK

    • In this example, the Height is set at 0", the Thickness is set at 3 1/2", and the material is Fir Framing. 


  4. With the polyline solid selected, click and drag the triangular Rotate edit handle in a counter-clockwise direction until the object is oriented vertically and its decorative end faces downward. 

    • This orientation will specify the decorative end as the object's front, so it will later display a front indicator when selected in floor plan view. 


  5. Create a Camera view to see the results. 





To convert the solid into a symbol

  1. With a 3D view of the polyline solid active, select Tools> Symbol> Convert to Symbol from the menu. 


  2. In the Convert to Symbol dialog: 



    • Select the appropriate symbol category from the drop-down list.  In this example, Fixture (Exterior) is used. 

    • Uncheck Add to Library only if you do not wish to save the new symbol in the library for future use in other plans. 

    • Check Show Advanced Options to open the Symbol Specification dialog. 


  3. On the 3D panel of the Symbol Specification dialog, notice that the symbol's preview shows it lying on its side, just as it was originally drawn. Type a short, descriptive name in the Symbol Name field. Under the Rotation heading: 

     


    • Click the radio button beside Y

    • Click the Rotate - button once. 

    • Notice that the symbol preview rotates to the correct orientation.


  4. On the 2D Block panel, click the  Generate Block button to update the CAD block so the symbol will look correct in Plan View. Next, click OK to close the dialog.




  5. The new symbol will be added to the User Catalog and will use the name you specified in step 3, above.  


  6. Right-click on the new symbol in the library and select Components from the contextual menu. In the Components dialog: 



    • Click on the cell in the ID column that says "FX1" and select Framing from the drop-down list. 

    • Add any required information to the other columns and/or make any desired changes to the information in those columns. Existing text in the columns cannot be edited: to change it, click in the cell and type the text you want. 

    • In this example, the Size is specified as "2 x 6 x 14" and the Description is shortened to "Decorative Beam". 

    • When the symbol's components are correct, click OK.

 

The new framing symbol created using the steps above is ready to be used in a custom application like a pergola.