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Message: The application has failed to start because its side-by-side configuration is incorrect.

Reference Number: KB-01046 Last Updated: 07-22-2014 02:08 PM

The information in this article applies to:

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DESCRIPTION

When I try to install or update the software, I receive this warning:

"The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log for more detail."

or

"An error occurred during the installation of assembly Microsoft.VC90.ATL,version=...publicKeyToken=..."


Why is this message displayed, and how can I fix it?

CAUSE

This issue is typically caused by a conflict between the program and one or more of the files in the C++ runtime libraries. These libraries are part of the Windows operating system and are used, and potentially updated, by installing or updating several Microsoft or other third party products.

If you are experiencing this error when launching or installing the program, and if the program repair option does not resolve the issue, the most effective method to correct this error is to uninstall and reinstall any Microsoft Visual C++ installations currently available on your computer before proceeding with the installation.


RESOLUTION

If you are experiencing this error when updating a program you currently have installed, please first run a Repair in order to ensure all of the program's files are installed correctly.


To repair your current installation

  1. Open the Control Panel and locate the list of programs.

    Windows 8
    From within the Start screen, type "Control Panel"

    Windows 7/Vista
    Click Start> Control Panel
    • If viewing categories, click Programs> Uninstall a Program
    • If viewing icons, click Programs and Features

    Windows XP
    Select Start> Control Panel> Add or Remove Programs

  2. Scroll down and locate your program.

  3. Select it and choose Repair.

  4. Once the repair process is completed, launch the program or run the update again.


 

To uninstall all current Microsoft Visual C++ installations

  1. Open the Control Panel and locate the list of programs.

    Windows 8
    From within the Start screen, type "Control Panel"

    Windows 7/Vista
    Click Start> Control Panel
    • If viewing categories, click Programs> Uninstall a Program
    • If viewing icons, click Programs and Features

    Windows XP
    Select Start> Control Panel> Add or Remove Programs

  2. Scroll down to locate the Microsoft Visual C++ entries.

  3. Select each one, starting from the top entry, and choose Uninstall.

    Do this for each entry, until there are no more Microsoft Visual C++ entries listed.

 


To reinstall new Microsoft Visual C++ packages

  1. Click each of the following links in order.  If prompted, choose to Run the download to install each Microsoft Visual C++ Redistributable Package.


    Note:  If you are running Windows XP or a 32-bit version of Windows Vista/7/8, it is only necessary to download the packages noted as "Redistributable Package (x86)."

    For more information on how to determine if you are running 32 or 64-bit Windows, see Article #1230 in this online Help Database: How to determine if your version of Microsoft Windows is 32 or 64-bit.


  2. Once every package has been downloaded and installed, restart Windows.

  3. Finally, launch the program, or run the update, again.

 

If the error message persists after following all of these instructions, you may need to contact a Microsoft Certified technician to ensure that your Microsoft Visual C++ Runtimes are installed and operating properly.