Browse
Categories

Message: Cannot open custom toolbar configuration file.

Reference Number: KB-01147 Last Updated: 12-13-2013 07:18 AM

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors or Chief Architect Lite

Home Designer Professional


DESCRIPTION

When I try to launch my copy of the software, an error message states, "Cannot open custom toolbar configuration file", followed by a file pathname in parentheses.  And when the program opens, I do not have any toolbars.  How do I fix this problem?



RESOLUTION

This Warning message is typically followed by another, similar message that states, "Cannot open backup toolbar configuration file", followed by a file pathname, and displays when the program cannot find the toolbar file associated with the toolbar configuration that was active the last time the program was used.  Often, this file is named Default Configuration.toolbar.

This issue most commonly occurs when the toolbar file in question has been deleted from the program's Data folder, which is located in your Documents directory (My Documents on Windows XP).

This problem can be resolved by prompting the program to create a new toolbar file.



To replace a lost toolbar file

  1. Save any files that you may have open and select File> Exit to close out of the program.


  2. Browse to your Documents directory and locate a folder that has the name of your program version followed by the word Data.


  3. Open the Data folder and locate a folder named Toolbars.


  4. Right-click on the Toolbars folder, select Rename from the contextual menu, and type a new name: Toolbars_Old.


  5. Next, launch the software.


You may notice a pause as the program searches for the Toolbars folder. When it does not find this folder, it will create a new one and you may briefly see a progress dialog box. You should not, however, see the Warning message and the program should open normally.



If you continue to see the Warning message, or if the toolbars continue to be missing, try the following set of steps.


To import missing toolbar configurations

  1. With a plan or layout file open in the program, select Tools> Toolbars & Hotkeys> Customize Toolbars.

    • In Home Designer Pro, the menu path is Tools> Toolbars> Customize Toolbars.


  2. On the Configurations panel of the Toolbar Customization dialog:

    • Click the Import button.

    • The Toolbar Configuration File dialog will open to the new Toolbars folder in your program Data folder.

    • Select Default Configuration.toolbar from the available files and click Open.

    • "Default Configuration" will now be listed in the box to the left of the Import button.


  3. Continue Importing any additional toolbar files you may want to use, then click the Close button to close the Toolbar Customization dialog.

    Your missing toolbars should now be available.