Browse
Categories

Creating a Custom Cabinet Symbol

Reference Number: KB-01192 Last Updated: 09-30-2013 04:34 AM

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors or Chief Architect Lite

QUESTION


I need to create a custom sinkbase cabinet for use in an accessibility bathroom.  How can I accomplish this task in Chief Architect?


ANSWER


We can create custom cabinet symbols in Chief Architect using primitives and solids.

To begin

  1. First, launch Chief Architect and select New Plan  to start a blank plan file to create our custom cabinet in.


  2. Next, select 3D> Create Orthographic View> Cross Section/Elevation , then click and drag out a view looking to the left or right on your plan.


  3. Here, we can use the CAD tools to create a completely enclosed polyline to draw the profile of the cabinet that we need.



    For the purposes of our example, we will select CAD> Lines> Draw Line , then click and drag out to create the polyline above for an accessible sink base cabinet.


Once you have drawn the profile as needed

  1. Using the Select Objects  tool, select the polyline and use the Convert Polyline  edit tool to display the Convert Polyline dialog.

      Warning: If you have Edit Object Parts enabled, you will only be able to select and individual line, instead of the polyline as a whole. Select Edit> Edit Behaviors> Edit Object Parts  to remove the check mark next to this feature, toggling it back to off.



  2. In the Convert Polyline dialog, move the radio button to Polyline Solid, and click OK to display the ­Polyline Solid Specification dialog.


  3. On the General tab, set the Thickness value, then click OK to apply the change and close the dialog.

    For our example, we will be making the Thickness 32" wide.


  4. Next, select File> Close to close the Cross Section/Elevation view, returning you to your 2D floor plan.


 

To remove a portion of the interior of the cabinet box to allow for an opening for our sink.

  1. In floor plan view, select Build> Primitive> Box  tool and click and drag a rectangle inside the solid, leaving 1 inch space at the front, back and sides.


  2. Use the Select Objects  tool to select the Box, then click on the Open Object  edit button to display the 3D Box Specification dialog.


  3. On the 3D Box tab, set the Height: and Z: Origin.

    For the purposes of our example, we will set Height to be approximately 8" or 9" tall, and approximately 32" off of the ground.


  4. Next, select 3D> Create Perspective View> Full Overview  to create a camera view of the box and polyline solid.

    Adjust the box so that the box protrudes above the polyline solid at least one inch, as in the image below.


     


  5. While in the camera view, use the Select Objects  tool to select the polyline solid cabinet box and click on the Convert to Solid  edit tool.


  6. While the cabinet box is still selected, click on the Solid Subtraction  edit tool and click on the 3D box.

    This subtracts one solid from the other, leaving our hollow area inside the top of the cabinet box.

To add another solid to the front of the cabinet box to represent our false drawer

  1. Select File> Close to close the Perspective Overview.


  2. Next, select 3D> Create Orthographic View> Cross Section/Elevation  and take a Cross Section camera view looking at the front of the solids.


  3. Select Build> Primitive> Polyline Solid then click and drag to create a solid the size you want the drawer to be.


  4. Use the Select Objects  tool to select the polyline solid, click on Open Object edit tool to display the Polyline Solid Specification dialog.


  5. On the Materials tab, change the material to something other than what the cabinet box is made of.

    For the purposes of our example, right now the main cabinet box is set to ­concrete, so we will set the new Polyline Solid to a Red color.


Now we are ready to export our symbol.

  1. While still in the camera view of the solids, click on File> Export> 3D Model (DWG, DXF)...  


  2. Select an appropriate location to save your ­DWG file, such as the Desktop, and name the file.


  3. In the Export Drawing File dialog, under the File Format Options, be sure to place a check mark in Use material names as layers



    For the purposes of this example, we will name the file custom sinkbase.dwg


  4. Click Save to create the 3D .dwg file.


To return to floor plan view and import the .dwg file

  1. Select File> Close to switch back to your 2D floor plan view.


  2. Click on File> Import> 3D Symbol (3DS, OBJ, SKP)... to display the Import 3D Symbol dialog, navigate to the custom sinkbase.dwg file located on the Desktop, and highlight it so that it displays in the File name: field.


  3. Under the Import Symbol Options section of the dialog, use the Choose the symbol category: drop down to choose the symbol category of Cabinet.


  4. Place check marks next to both Add Symbol To Library and Show Advanced Options. and click Open to import the symbol and open the Symbol Specification dialog.


  5. Switch to the Cabinet Front Symbols tab, where we can use the Select Component drop down to assign components to each layer of the imported symbol.




    In our example, the Color - Red is our Drawer and Concrete is the Cabinet Box.


  6. When you click OK, the custom cabinet is then added to the My Library folder of your Library Browser, and is ready to be placed in your plans.


  7. Since the base cabinets will default to a Floor to Bottom value of 0", you will need to select this particular cabinet and open its Specification dialog to change that value and raise the cabinet to the necessary level.