Creating a Custom Cabinet Symbol


Reference Number: KB-01192
Last Modified: July 16, 2015

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors


QUESTION

I need to create a custom sink base cabinet for use in an accessibility bathroom. How can I accomplish this task in Chief Architect?



ANSWER

We can create custom cabinet symbols in Chief Architect using primitives and solids.

To get the shape of the cabinet box, start with the CAD tools to design a precise profile for the accessibility cabinet. 

To design the cabinet box

  1. Start by opening a blank New Plan , then select 3D> Create Orthographic View> Cross Section/Elevation from the menu, and draw an elevation from Right to Left, as demonstrated in the image below.




  2. While in this elevation view select CAD> Lines> Draw Line then click and drag out several lines to draw the enclosed shape shown below.




  3. After you have closed the shape, use the Select Objects tool to the polyline, click the Convert Polyline edit button, select Polyline Solid and click OK.


  4. In the the Polyline Solid Specification which displays:

    • On the General panel, set the thickness to 24".

    • On the Materials panel, change the material to Color - Blue.

    • Now Close the Elevation to return to Floor Plan view. 


  5. Again using the Select Objects  tool, click on the Polyline Solid, then select the Convert to Solid edit button to convert the Polyline Solid to a generic shape.


  6. Now from the menu select Build> Primitive> Box then click and drag to draw a box inside the top of the cabinet box, leaving some space for the sides.




    In this example we are leaving 1/4" on all sides.


  7. With the box still selected, click on the Open Object  edit tool to display the Box Specification dialog, then set the Z Position to 80" and the Height to 7" and click OK.


  8. Select 3D> Create Perspective View> Full Camera , then click and drag a camera view towards the cabinet box to display an image similar to that shown below.




  9. Using the Select Objects  tool, select the cabinet box and click the Solid Subtraction edit button.  Then click on the box to subtract it from the top of the cabinet.




To add the drawer front

  1. Select File> Close View  to exit out of the 3D Perspective view and return to your 2D floor plan view.


  2. Now from the menu select Build> Primitive> Box  and create a new box in front of the cabinet box.




  3. Select the box and click on the Open Object  edit tool to display its Specification dialog, where you will set the Height to 6", the Width to 23". On the Materials panel, set the material for the cabinet face to Color - Red, then click OK.


  4. Now with the box still selected, click the Explode Shape edit tool.


  5. Using the Select Objects tool, drag a selection marquee around the back and side faces (excluding the front face) then click the Delete edit button.




  6. Using the Move edit handle, drag the face into the outer edge of the cabinet box.




  7. Next, from the menu select 3D> Create Orthographic View> Cross Section/Elevation  and create an elevation of the front of the cabinet.


  8. Select and drag the face, which will later become the drawer front, in its position.

     


  9. Once the face has been moved and the new different material set, you can Close the Cross Section/Elevation view.


To convert the box to a cabinet

  1. Select 3D> Create Perspective View> Full Camera , then click and drag a camera view towards the cabinet box to display an image similar to that shown below. 




  2. Select File> Export> Export 3D Model (DWG,DXF)  from the menu.


  3. Check the option for Use Material Names as Layers and use the Scaling unit: to in and click the Export button.

     


  4. In the Save 3D Drawing File dialog, choose an easy to find location, such as your Desktop, and give the file a descriptive name, then click Save.


  5. After exporting the file, select File> Import> Import 3D Symbol  from the menu, browse to file, select it and click Open.


  6. In the Import 3D Symbol dialog:



  • From the Category drop down menu, choose the Cabinet.

  • Check Add Symbol To Library

  • Check Show Advanced Options 

  • Then click OK

     
  • In the Symbol Specification dialog:

    • Under the 3D panel, set the Origin Offset to 0,0,0.

    • Under the Cabinet panel select the Color - Red and change the Component Type to Drawer.



    • Click OK


    The cabinet symbol can now be accessed from your User Catalog in the library browser. 


     

    You may need to adjust its height off the floor once placed in the plan to match the current height of your other cabinets.