Browse
Categories

Creating a Log Truss

Reference Number: KB-02781 Last Updated: 12-16-2014 03:43 PM
 

The information in this article applies to:

Chief Architect Premier or Chief Architect Lite

QUESTION

How do I create log trusses in Chief Architect?


ANSWER

While the ­Truss tool does not produce log trusses, you can download a Bonus Catalog of Log Truss Components that includes a selection of log trusses ready to be placed in your plans, as well as templates that you can use to create custom truss sizes.

This article describes how to use these templates to create a custom log truss with a 22' span and 12/12 pitch.




 

To create a custom truss envelope

  1. Open  a new, blank plan file, then select View> Library Browser .

     
  2. Browse to Bonus Catalogs> Log Truss Components> Log Truss Templates and select the 24' - 12/12 Log Truss Envelope.


  3. Click once in the drawing area to place this ­CAD block at that location.




     
  4. Click the Select Objects  button, then click on the CAD block to select it and click the Explode CAD Block  edit button.


  5. Select Edit> Edit Behaviors> Edit Object Parts  from the menu.

     
  6. Group select the three lines on the right side CAD block:  the lines that represent the end of the bottom log, the top edge of the bottom log, and the top of the right-hand angled log.



     
  7. With these three lines selected as a group, click the Transform/Replicate Object  edit button.


  8. In the Transform/Replicate Object dialog




    • Check the box beside Move.
       
    • Specify the X Delta as -24".

    • Click OK to close the dialog and move the selected objects 24" to the left.

       
  9. Turn off Edit Object Parts .




     
  10. Using their edit handles, reconnect the lines of the envelope so that the top edges meet at the new ­ridge point and the bottom edge snaps to the log end line on the right.



    • When this is accomplished, the lines will form a closed polyline that, when selected, will have a grey fill color.

    • At this point, the envelope polyline can be used as a guide to customize a truss template.



To modify a log truss template

  1. In the Library Browser, under Bonus Catalogs> Log Truss Components> Log Truss Templates.



    • Select the 24' - 12/12 Log Truss Template.
       
    • Click once to place this architectural block in your plan, near the envelope polyline.


  2. Click the Select Objects  button, then click on the truss template to select it.

     
  3. Use the Point to Point Move  edit tool to align the left side of the truss template with the left side of the envelope polyline. To do this:



    • Click the Point to Point Move  edit button.

    • Click once on the lower left corner of the truss template architectural block.

    • Click once on the lower left corner of the envelope polyline.

    • In the image above, the envelope polyline is shown in red for clarity.


       
  4. With the truss template still selected, click the Explode Architectural Block  edit button.

    The template's components can now be edited so that the logs on the right side align with the envelope polyline like those on the left side already do. 

     
  5. Select the right ­top chord log and use the Transform/Replicate Object  edit tool to move it 24" to the left (X Delta of -24"), as described above.

     
  6. Group select the king post and two angled logs and use the the Transform/Replicate Object  edit tool to move them 12" to the left (X Delta of -12").



     
  7. Using the edit handles, shorten each of the modified logs so they fit within the envelope polyline.



    • Be sure to shorten the angled logs so they do not extend through the top chords.

    • To override movement restrictions, you can hold down the Ctrl or Command key on your keyboard while resizing these objects.


  8. Group select the six logs and click the Make Architectural Block  edit button to group them back into a single block again. 


     

To convert the template into a symbol

  1. Select 3D> Create Perspective View> Perspective Full Overview .

     
  2. With the 3D view active, select Tools> Symbol> Convert to Symbol  from the menu.

     
  3. In the Convert to Symbol dialog



    • Select "­Millwork" from the Symbol Category drop-down list.
       
    • Make sure that Add to Library is checked.

    • Check the box beside Show Advanced Options.

    • Click OK.


  4. On the 3D panel of the Symbol Specification dialog, which opens next:



    • Select the X Axis radio button under the "Rotation" heading.

    • Click the Rotate + button one time so the truss is oriented upright in the preview pane.

    • Type a short, descriptive Name for the new symbol, such as "22' - 12/12 Log Truss".

       
  5. On the Options panel of the dialog:
     
    • Specify a Height off Floor. In this example, 102" is used.

    • Click OK to close the dialog and add the truss as a millwork symbol in your User Catalog.



 

To save your custom envelope and template

  1. To save your customized truss template architectural block in the User Catalog of the library for future use, select it using the Select Objects  tool and click the Add to Library  edit button.

     
  2. If you would like to save the 22' Log Truss Envelope polyline in the User Catalog as well, begin by moving the truss template architectural block to a different location.  


  3. Select the text object and click the Open Object  edit button.  

     
  4. In the Rich Text Specification dialog, change the text to say 22' Log Truss Envelope, then click OK.


  5. Group select the polyline and text, click the Make CAD Block  edit button, then click the Add to Library  edit button.