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QUESTION

| am using X16, Home Designer 2025, or a prior version, or Traditional File
Management in X17. How can | backup all of my user content associated with the
software?

ANSWER

Backing up data means creating a copy of your files and saving them in a safe location
so that they can be retrieved in the event of a problem. It's important to routinely back
up your important data - including Chief Architect/Home Designer files and user
content - because in the event of a hard drive crash or other computer malfunction, it's
possible you might lose your work, or access to it, unless you have copies saved
somewhere else.

Additionally, it's helpful to have this same content backed up so that it can be
transferred to another computer.

Note: If you're using Project Management in X17, please see the "Backing Up and
Restoring Chief Architect Content Using Project Management" resource in the
Related Articles section instead.



/

For information about restoring backed up user content in X16, Home Designer
2025 or prior, or if you're using Traditional File Management in X17, please see
the "Restoring Chief Architect Content Using Traditional File Management"
resource in the Related Articles section below.

It is best to use a strategy that utilizes a backup location somewhere other than your
local computer. Options include:

® Copying files to a removable storage device such as a USB flash drive or external
drive;

e Copying files to a server or other location on your network;

e Copying files to an online/cloud storage site or have your backup service do it for
you.

There are a number of different Chief Architect/Home Designer files that you may want
to back up. You can back up some or all of them, depending on your needs:

¢ Plan and layout files
e Core, bonus, and manufacturer Catalogs

e User catalog
e Other user content (templates, archives, toolbars, hotkeys, and more)

Regardless of where you choose to save your backed up files, it is helpful to know how
to copy and paste files in your operating system's file system. There are several ways,
and all are easy.

When copying files associated with Chief Architect or Home Designer, it is important to
begin by saving your work and closing out of the software.

To copy and paste files

1. Open the File Explorer in Windows or Finder in macOS, navigate to a file you would
like to copy to the system Clipboard, and select it.

2. If you would like to select multiple files, hold down the Ctrl key on your keyboard if



you're using Windows, or the Command key if you're using a Mac, then click on
additional files to add them to your selection.
3. Copy the selected file or files to the Clipboard:

o On Windows, click the Copy button in the Home ribbon, right-click and select
Copy from the contextual menu, or press Ctrl + C.

o On macOSs, select Edit> Copy from the menu bar, right-click (Control-click) and
select Copy from the contextual menu, or press Command + C.

On a Mac, hold down the Control key while clicking to initiate a right-
click command. More information about right-click commands on
Apple input devices can be found in the following Apple resource:
Right-click on Mac (https://support.apple.com/guide/mac-help/right-
click-mh35853/mac#).

4. Once they are copied to the Clipboard, navigate to the location where you would
like to paste a copy of the selected file(s).

5. Paste the selected file or files:

o On Windows, click the Paste button in the Home ribbon, right-click and select
Paste from the contextual menu, or press Ctrl + V.

o On macQOs, select Edit> Paste Item from the menu bar, right-click (Control-click)
and select Paste Item from the contextual menu, or press Command + V.

To back up plan and layout files

Plan and layout files often reference a variety of other files such as images and PDFs.
When backing up plans and layouts, it is important that these referenced files be
included. A great way to do this is to use the Backup Entire Plan/Layout tool in X16,
Home Designer 2025 and prior, or the Export Plan/Layout as Project tool in X17, Home


https://support.apple.com/guide/mac-help/right-click-mh35853/mac#

Designer 2026, and newer. This will ensure that all referenced files, including those
that have been imported, are backed up.

It's important to be aware that if either of the tools mentioned above are used in a
layout file, the layout file, as well as all the plans associated with the layout will be

backed up. However, when the tools are used while in a plan file, the layout file will not
be included.

1. Select Open Plan [:l or Open Layout* IE and proceed to open the file that you
want to backup.

*Layout files are not available in Home Designer Suite or Home Designer Architectural.

2. In X17, Home Designer 2026, and newer, navigate to File> Export> Export
Plan/Layout as Project |_'ﬂj and in the dialog that appears:
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Save as type: | Project (*.caproj) w

# Hide Folders Cancel

o Choose a desired backup location and a File name, then click Save.

o An Information dialog will appear stating "Project export is complete. [#] plan
file and [#] layout file were saved." Click OK.



In X16, Home Designer 2025, and prior, navigate to File> Backup Entire
Plan/Layout iy

[™ Backup Entire Plan x

{®) Backup Plan Files and All Referenced Files
(") Backup Plan Files Only
[]:5end Badkup Files to Zip Archive

Cancel Help

o Select the Backup Plan Files and All Referenced Files option, then check the
Send Backup Files to Zip Archive box to create a compressed (zipped) folder
(Recommended).

o C(lick OK.

o Browse to your chosen backup location, then click Save.

Note: If the "Send Backup Files to Zip Archive" box was not checked, you
will need to create a new, empty file folder on the Desktop for the plan and
referenced files to be backed up to:

® On a Windows operating system, right-click in an empty area and choose
"New> Folder".

® On a macOS system, right-click in an empty area and choose "New
Folder".

3. If you used one of these tools while in a plan, a copy of the plan file, including the
referenced files such as images, textures, PDF's, and backdrops will be part of the
compressed (zipped) folder or .caproj file.

If you used one of these tools while in a layout, a copy of the layout, all plan files
sent to the layout, and the referenced files such as images, textures, PDF's, and
backdrops will be part of the compressed (zipped) folder or .caproj file.



To back up core, bonus, and manufacturer catalogs

By default, core, bonus, and manufacturer catalogs are saved in the ProgramData
folder on Windows or the Application Support folder on macOS. These are hidden file

locations and may require you to use the "Run" utility on Windows or the "Go to
Folder" function in macOS to access.

Close out of Chief Architect/Home Designer prior to completing the following steps.

1. Browse to the file location where your library content is stored:

o On Windows, press the Windows Key [ and the letter R on your keyboard at
the same time to open the Run dialog. Type %programdata% and then click
OK to open the Program Data folder.

1 Run >

Type the name of a program, folder, decument, or Internet

= resource, and Windows will open it for you.

Open: Yprogramdata®h v

Cancel Browse...

o On macOSs, open Finder, select Go> Go to Folder, type: /Library/Application
Support then click Return.

[Library/Application Support/ Q

Library * Application Support

Library : Application Support * App Store
Library » Application Support » Apple
Library : Application Support * BTServer

If you have moved your libraries to a custom location, then you will
want to instead reference this location to backup these files. You can
confirm the location of your "System Library Database Folder" on the
Folders panel of the program's Preferences dialog.



2. Open the folder with the same name as the program and version you're using.

For example, "Chief Architect Premier X17" or "Home Designer Pro 2026".

3. Onyour keyboard, hold down the Ctrl key if you're using Windows, or Command if
you're using a Mac, and click to group select the following folders:

o Bonus Libraries

o Core Libraries

o Manufacturer Data

o Manufacturer Libraries
o Referenced Files

Do NOT copy or backup the Program_Data folder or the
dont_change.dat file. They contain unique, encrypted registration
information and if you try to use a copied and pasted version of either,
your license registration will no longer be recognized by our registration
server.

4. When the folders are selected as a group, make a copy of them in your chosen
backup location using the Copy and Paste commands, as described above.

To back up the user catalog

The user catalog stores custom items that you may have added to the Chief
Architect/Home Designer Library Browser. To back up this content, use the Export
Library function.

1. Launch the version of the program that you're using and create a New Plan D

2. Select View> Library Browser f{i{| to open the Library Browser if it's not already

open.
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You can also export just individual items or secondary folders by right-clicking on
those items.

On a Mac, hold down the Control key while clicking to initiate a right-
click command. More information about right-click commands on Apple
input devices can be found in the following Apple resource: Right-click
on Mac (https://support.apple.com/guide/mac-help/right-click-
mh35853/mac#).

4. In the Export Library Data dialog:

o Specify your chosen backup location as the place where you would like to save
your backed up User Catalog.

o Type a short, descriptive name for the library being exported.
o Ensure that the Library File with Textures/Images (*.calibz) option is selected.

o C(Click Save.


https://support.apple.com/guide/mac-help/right-click-mh35853/mac#

Note: This export process may take some time, depending on the size of
the library. If you have an extensive User Catalog and it's taking a
considerable amount of time to export, it may be necessary to consolidate
the catalog or separate it into smaller folders to export

To back up other user content (templates, archives, toolbars,
hotkeys, and more)

User content, such as user-created templates, archives, toolbars, hotkeys, and other
user-specific data is saved in the Chief Architect/Home Designer Data folder. The Chief
Architect/Home Designer Data folder is located in your Documents directory by
default, and its name will begin with the full name and version of your Chief
Architect/Home Designer program followed by the word Data - for example, "Chief
Architect Premier X17 Data" or "Home Designer Pro 2026 Data".

The default file path for this folder on Windows may be one of the following, but may
also vary depending on your product and version:

C:\Users\ [ YOUR USERNAME ] \Documents\Chief Architect Premier X17 Data

C:\Users\ [ YOUR USERNAME ] \Documents\Home Designer Pro 2026 Data

And on macOS:

/Users/ [ YOUR USERNAME ] /Documents/Chief Architect Premier X17 Data

/Users/ [ YOUR USERNAME ] /Documents/Home Designer Pro 2026 Data

If you have moved your Chief Architect/Home Designer Data folder to a
custom file location, refer to the location you have moved it to instead.
You can confirm the location of your Data folder in the Preferences dialog.
On the Folders panel, take note of the file path next to the "My Data
Folder" or "Data Folder for Current User" heading.



You can backup the entire Chief Architect/Home Designer Data folder if you wish, or
only the subfolders and files that are of importance to you. Each of these are described
in further detail below:

® Archives - contains automatically archived plan and layout files.

e Backdrops - contains custom backdrop images. These are also exported when the
User Catalog is backed up, as described above.

e Database Libraries - User Catalog file location. This is also exported when the User
Catalog is backed up, as described above.

e Hotkeys - contains an XML file that links commands/tools in Chief Architect to a
sequence of keyboard keys/presses.

® |Images - contains custom images. These are also exported when the User Catalog is
backed up, as described above.

® |ex - contains customized dictionaries.

e Patterns - contains custom .PAT files. These are also exported when the User
Catalog is backed up using the method mentioned above.

® Scripts - contains custom scripts in the Ruby programming language that may be
referenced by some plans created in Chief Architect Premier.

e Templates - contains plan and layout template files.

e Textures - contains image files that were used for customizing or creating materials.
These are also exported when the User Catalog is backed up, as described above.

® Toolbars - contains files relating to the toolbars in the program.

* mmaster.mat - The Master Materials List file.

¢ sheetSizes.sheet - contains user-created units of measurement.

e _MigrateBackup - If you migrated legacy settings into the current version, additional
folders with names appended with _MigrateBackup may also be present.

e Migrate_Settings_Log.txt - If you migrated legacy settings into the current version,
this log file will detail what was migrated.

If the Chief Architect Premier Data folder is renamed, moved or deleted,
the program will automatically replace it using default information from
the program's installation folder. When this occurs, customized user
settings and custom user library content will not be available.

Do NOT backup, copy, or modify any of this content while Chief Architect is
running.



Related Articles

@l Backing Up and Restoring Chief Architect Content Using Project Management

(/support/article/KB-03211/backing-up-and-restoring-chief-architect-content-using-
project-management.html)

#l Exporting Projects, Assets, and Disconnected Files (/support/article/KB-

03212/exporting-projects-assets-and-disconnected-files.html)

#l Organizing your Plan and Layout Files(/support/article/KB-00562/organizing-your-
plan-and-layout-files.html)

#l Restoring Chief Architect Content Using Traditional File Management

(/support/article/KB-00091/restoring-chief-architect-content-using-traditional-file-

management.html)
#l Using Chief Architect on Multiple Computers (/support/article/KB-00956/using-chief-

architect-on-multiple-computers.html)

#l Using the Backup Entire Plan/Layout Tool (/support/article/KB-00987/using-the-

backup-entire-plan-layout-tool.html)
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