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Creating and Using a Plan Template

The information in this article applies to:

QUESTION
I have a number of di#erent architectural design styles that I often use and would

rather not have to set up my default settings every time I begin a new plan that will

use one of these styles. How can I do this work once and save it for future use?

ANSWER
In Chief Architect, any time you open a new, blank plan, its initial default settings are

copied from a template. You can create your own custom template plans to re.ect the

architectural styles and materials that you use most often.

A template plan is essentially a blank plan with default settings customized to meet a

particular set of design needs. You may 0nd it helpful to create more than one

template, each set up to draw a particular architectural style. It's a good idea to save all

your templates in a particular location, such as a folder in Documents or in the Chief

Architect Templates directory.

If migrating forward to the current version of Chief Architect from an older version,
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please make sure to follow the instructions in the Migration Guide located in your

Digital Locker.

While it's a good idea to go through all of the defaults to make sure the template is

setup exactly how you need it, there are some defaults that are more critical to change

ahead of time, as they can be troublesome to change after the design is complete. It's

recommended that these "Critical Defaults" are set up in the template and reviewed

before starting any plan.

Begin by selecting File> New Plan  from the menu to open a new, blank plan using

the default plan template.

Critical Defaults:

Floor and Ceiling Structure Defaults

Floor and Ceiling Height Defaults

Framing Defaults

Wall Type Defaults

Dimension Defaults

All default settings are important. It's always a good idea to form a habit of

setting the defaults for an item prior to placing them in the plan. 

You can also set up layer sets in your template 0le. A layer set consists of a

complete list of the layers in the current plan or layout along with the

display settings for each layer as set for a particular type of view or

purpose. These display settings can be modi0ed and can be di#erent for

each layer set. Please see the Related Articles section below for more more

information on layer sets.

Saving:

Saving the Template

Setting the Default Template

Floor and Ceiling Structure Defaults

The .oor and ceiling Structure defaults consist of the layers that make up the .oor and

ceiling platforms. For example the .oor joists and sheathing or the ceiling joists. This is



also where the Floor and ceiling 0nishes are set.

1. Select Edit> Default Settings  from the menu to open the Default Settings

dialog.

2. Expand the list for Floors and Rooms, select Floor/Ceiling Platform, and click Edit.

Note: Alternatively, Floor and Ceiling structure settings can be adjusted on a

per-floor basis by expanding the Floors and Rooms category, expanding Floor

Levels, selecting the floor level you'd like to change, and then clicking on the

Edit button. In the Floor defaults dialog that appears, click on the Edit button

located beside each of the platform settings to modify them.

3. In the Floor/Ceiling Platform Defaults dialog, choose which platform settings to

modify and then click the Edit button.

Ceiling Structure typically contains just a layer for ceiling joists

Ceiling Finish typically contains a layer for the drywall and a layer for the paint

color.

Floor Finish typically contains a layer for the floor finish as well as any layers for

underlayment.

Floor Structure typically contains a layer for the floor sheathing and a layer for

the floor joists. 

4. In this example, the Floor Structure Edit button is clicked and in the Floor Structure

Definition dialog, the Layers, Materials, Energy Values, Structure properties, and a

diagram of the floor structure is displayed.



Layers are numbered and listed from the top of the structure to its bottom.

To select a layer for editing, click on the layer to highlight it, and then click once

again in the box you'd like to modify.

For example, if you're wanting to change the material of a layer to something

different, click on the material name for a selected layer. In the image above, you

would want to click on the words: OSB-Hrz. To adjust the thickness, click on the

3/4" value specified for Layer #1.

Use the Insert Above/Below buttons to add additional layers, use the Move

Up/Down buttons to move layers up or down, and use the Delete button to

delete selected layers.

Specify the Energy Values of the selected Floor or Ceiling Structure if desired.

Specify the structure’s Cavity R-Value, which is the R-value of its cavity

insulator: most commonly, the insulation between wood or metal joists.

Specify the Continuous R-Value, which is the R-value of continuous insulators

such as rigid foam sheets.

Specify whether the selected layer has special structural attributes.



Check Framing to produce framing in the selected layer when framing is

generated for the selected structural assembly's type.

Select the framing Type from the drop-down list.

Check Auto Detail as Insulation to generate Insulation boxes in the selected

layer when Auto Detail  is used in cross section views.

Check Air Gap to prevent the selected layer from displaying in 3D views or

being calculated in the Materials List.

Once all desired changes have been made, click OK.

Floor and Ceiling Height Defaults

Many important default values that a#ect rooms are speci0ed in the Floor

Defaults dialog for each .oor in a plan. This dialog controls important information that

the program uses to create a 3D model - particularly .oor and ceiling heights and

materials. Moldings can also be speci0ed in the Floor Defaults dialog.

Only the defaults for the 0rst .oor of a building can be set ahead of time. The program

uses the setting form the 0rst .oor to create subsequent .oors. When a new .oor is

created, its .oor defaults are displayed and can be changed at that time.

1. Select Edit> Default Settings  from the menu to open the Default Settings

dialog. 

2. Expand the list for Floors and Rooms, expand Floor Levels, click on 1st Floor, and

then click Edit. 

3. On the STRUCTURE panel of the 1st Floor Defaults dialog, specify the default

Ceiling height for Floor 1.

Ceiling and Rough Ceiling represent framing dimensions from the bottom of the

wall bottom plate to the top of the wall top plate.

The default Floor Height for Floor 1 is set at 0".

Note: Chief Architect always defines the default height of Floor 1 at 0’-0”.



This height value is measured from the top of the subfloor and is the

constant by which the heights of structural elements in the program like

walls, floors, and ceilings are measured. The heights of architectural objects

can be measured relative to this absolute height, as well. As such, this

default cannot be changed.  

Finished Ceiling represents the dimension between the the floor finish and the

ceiling finish.

At the bottom of the Structure panel, there is a setting for Monolithic

Slab Foundation. If a foundation plan is desired, do NOT put a check

in this setting. Instead, choose Monolithic Slab in the Build

Foundation dialog or the Foundation Defaults prior to building the

foundation. If Monolithic Slab Foundation is checked, the current

Floor Structure will be replaced by a single 4" (100mm) layer of

concrete with footings that can be seen in camera views only.

4. On the MOLDINGS panel:

The default template will have one molding already setup for Base Molding. 



If you want to remove the molding, choose Delete.

If you want to add additional moldings, Click on Add New.

If you want to replace the existing molding with a new one, choose Replace.

If you click on Add New or Replace, the Select Library Objects dialog will appear

where you can then browse to find a molding profile that meets your needs.

Specify the Width and Height, the Type, along with other related properties if

desired.

5. When you are satisfied with your selections, click OK.



Framing Defaults

The Framing Defaults dialog allows you to specify several properties relating to .oor,

ceiling, wall, and roof framing components, including such things as spacing, joist

widths, framing materials, and plate values. Properties for beams, posts, roof trusses,

along with door and window openings can also be setup here.

1. Select Edit> Default Settings  from the menu to open the Default Settings

dialog. 

2. Select Framing and click the Edit button.

3. On the FOUNDATION panel of the Framing Defaults dialog, specify the Spacing and

Width listed for the Subfloor for Floor 1

4. On the 1ST panel specify the Spacing and Width for the Ceiling Above Floor 1 as

well as the Subfloor for Floor 2

Notice that the Floor Structure and Ceiling Structure matches what is

speci0ed in the Floor/Ceiling Platform Defaults section speci0ed earlier.

5. Specify your desired settings for the additional framing defaults located in this

dialog, and then click OK.

Wall Type Defaults

The settings in the various wall defaults dialogs determine what wall types are drawn

when using the di#erent wall tools. It's import to become familiar with these settings

and how they related to your style of building.

1. Select Edit> Default Settings  from the menu to open the Default Settings

dialog.

2. Expand the list for Walls, select Exterior Wall, and then click the Edit button.



3. In the Wall Defaults dialog that displays, click on the WALL TYPES panel and specify

the desired wall type to be used when using this particular wall tool.

Click the Define button if you would like to create or modify a custom wall type in

the Wall Type Definitions dialog.

For more information on customizing or creating a new wall type, please see the

Related Articles section below.

In addition to specifying structural aspects of a wall, such as its framing and

sheathing, you can specify siding material such as lap siding, shingles or stucco

and interior materials including paneling, finished tongue and groove, and

sheetrock.

4. Repeat steps 2 and 3 to define the defaults for Interior Wall, Foundation Wall,

Pony Wall, as well as any other other Wall tools.

Dimension Defaults

There are several saved dimension defaults. Having multiple defaults allows you to

switch between them to have the dimensions change their behavior when you're

dimensioning for di#erent views. For example, you can have dimensions location the

framing layer of the walls for your framing plans and the interior surface of the walls

for your interior design plans. Another example would be specifying a di#erent sized

text style for your plot plan versus a smaller sized text style for interior elevations.

1. Select Edit> Default Settings  from the menu to open the Default Settings

dialog.

2. Expand the list for Dimension, select Dimensions, and click the Edit button.

3. In the Saved Dimension Defaults dialog that opens, the active dimension default is

highlighted in the list as well as being specified at the bottom of the dialog.



4. Select the default that needs to change and then click Edit to open the saved

default. Review these setting to verify that they meet the needs of your projects.

Access each of the LOCATE... panels to specify which objects you want

dimensions to locate when using the various Dimension tools.

Specify the desired Format on the PRIMARY FORMAT panel.

Specify the desired Text Style on the TEXT STYLE panel.

5. Repeat Step 4 for all Dimension Defaults in the template.

Saving the Template

Once the default settings for a 0le are setup to your liking, it's a good idea to save it as

a template to be used for future plans.

1. Select File> Templates> Save As Template . 



2. A dialog will appear allowing you to delete any elements that could have come from

an existing plan file. At the bottom you can select the checkbox to set this template

as the default for imperial (or metric) plans. Click OK.

3. Give the new template a short, descriptive name, then click Save.

The Chief Architect Templates folder is the default file location when choosing the

"Save As Template" option. If you'd like to change the file location in which you save

this to, you can do so prior to clicking Save.  

4. To choose a different template when creating a new plan, select File> Templates>

New Plan from Template , select the template from the list, then click OK.

Setting the Default Template

Access the Preferences dialog to set the default template for when the New Plan or

New Layout action/tool is selected.





1. Select Edit> Preferences  from the menu if you're on a Windows PC or Chief

Architect> Preferences  if you're on a Mac.

2. On the NEW PLANS panel of the Preferences dialog, click the Browse button to the

right of the Plan Template text field for your unit of measurement.

3. In the Select a Plan Template File dialog, browse to the location of your new

template file and click Open to specify this file as your plan template.

4. Click OK to close the dialog and apply your change.

Creating and Using Layout Templates (/support/article/KB-00737/creating-and-using-

layout-templates.html)

Defining a New Wall Type (/support/article/KB-02944/defining-a-new-wall-type.html)

Setting up a Custom Default/Annotation Set (/support/article/KB-01167/setting-up-a-

custom-default-annotation-set.html)

Understanding Layer Sets (/support/article/KB-00765/understanding-layer-sets.html)
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