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Troubleshooting Slowness in Chief
Architect Plans

The information in this article applies to:

QUESTION
I am working on a large plan, and I notice that the program is working very slowly, is

sluggish or seems to lag or stall. Is there something that can be done to remedy this?

ANSWER
In this article, we will discuss the most common reasons for encountering slowness in

Chief Architect plans.

Before completing these steps, please check to makes sure that any other software

running on the computer or in the background is needed, and exit any other programs

that you may not need to have open while working in Chief Architect.

Please make sure to review all of the information in this article, as the cause of

slowness that you may be encountering could be related to more than just one of the

items listed below.
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Work on Files Locally

By far, the most common reason for slowness is working in an unsupported fashion,

such as over a network server location, external hard drive, or USB 4ash drive.

In addition to experiencing slowness working in 5les, working in this type of

unsupported fashion is hazardous because it can lead to 5le corruption and data loss.

For these reasons, it is critical always to work on 5les that are saved on your local hard

drive. This means that you should copy the 5le from a network server, external hard

drive, or USB 4ash drive location to your computer's hard drive before opening it in the

software. Then, make your changes, save the 5le, exit the program, and then copy the

5le back to its network server, external hard drive, or USB 4ash drive location. 

If you are working on your computer's hard drive, and are still experiencing slowness,

then please continue with the information provided in this article.

Verify System Requirements

If you are working on 5les locally, the next step is to verify that your computer meets,

or better yet, exceeds, the minimum system requirements for running your version of

Chief  Architect.

The system requirements for the current version of the software can be located online

at: https://www.chiefarchitect.com/products/sysreq.html

(https://www.chiefarchitect.com/products/sysreq.html)

If you primarily notice slowness with regards to 3D Camera views, check to see what

https://www.chiefarchitect.com/products/sysreq.html


video card is in your system. Please see the Locating your Computer's Specifications

(https://www.chiefarchitect.com/support/article/KB-03129/locating-your-computer-s-

specifications.html) Knowledge Base article to learn more.

If your video card only just meets the minimum system requirements, then you may

want to look into replacing it with a video card that is mentioned in our

recommended system requirements

(https://www.chiefarchitect.com/products/sysreq.html#recommended).

Update your video card's driver by following the instructions in the Troubleshooting

3D Camera View Display Problems in Chief Architect

(https://www.chiefarchitect.com/support/article/KB-00106/troubleshooting-3d-

camera-view-display-problems-in-chief-architect.html) Knowledge Base article, then

verify that the appropriate card and driver are listed in Chief Architect's Preferences 

 under the VIDEO CARD STATUS panel.

If you are using multiple monitors, make sure that your system's video card fully

supports this functionality.

You may experience slowness, particularly with 3D camera views as well as library

and dialog previews if the video card is taxed by three or more monitors as well as

the rendering. You can test shutting the system down, disconnecting the extra

monitors, restarting the system, and then attempt to run Chief Architect on a single

screen to see if speed improves.

If you are looking into purchasing a new system and want to make sure that it offers

good performance, please view both our recommended system requirements

(https://www.chiefarchitect.com/products/sysreq.html#recommended) and our Chief

Blog article (https://www.chiefarchitect.com/blog/computer-for-design-and-gaming/).

Simplify Fill Styles and Patterns
Avoid using complex 5ll styles and patterns extensively in your plan and CAD Details.

If you use a custom Fill Style that requires drawing many tiny lines on the screen, this

can substantially slow down working in floor plan view for such tasks as zooming,

moving, and placing objects.

Particularly for elements of your design such as the layers of your wall type

https://www.chiefarchitect.com/support/article/KB-03129/locating-your-computer-s-specifications.html
https://www.chiefarchitect.com/products/sysreq.html#recommended
https://www.chiefarchitect.com/support/article/KB-00106/troubleshooting-3d-camera-view-display-problems-in-chief-architect.html
https://www.chiefarchitect.com/products/sysreq.html#recommended
https://www.chiefarchitect.com/blog/computer-for-design-and-gaming/


definitions, roof planes, closed polylines, rooms, and landscaping features, try to

avoid the use of many fill patterns.

Material patterns, such as complex stone or tile patterns, in views which utilize the

Vector rendering technique, such as Cross Section/Elevations and Orthographic

Overviews, will also slow down the generation of the view as well as actively working

in it.

If you must add these types of detailed CAD elements for hatching and fills to your

design, make sure to do so as one of the final steps when your plan is near

completion, before creating the layout, and expect to encounter slowness with the

file after doing so.

Slowness in 3D Views

Avoid working with multiple 3D camera views open. Every time you make a change

to the plan, the program will redraw the entire model. Depending on the complexity

of the design, this may take a long time.

You can see how many view windows are open by selecting the Window menu. Open

view windows are listed at the bottom of the menu.

If you are using the Generated Sky setting, keep in mind it takes into account the

orientation of the sun, so if you've set the sun to follow your camera, then the

generated sky will regenerate each camera movement to account for the new sun

direction, which can cause slowness in 3D camera views. 

Manage Displayed Layers - If you need to work in 3D views, turn off any layers that

aren't necessary for the task. This will improve your redraw time.

For example, if you need to work on landscaping or roofs in a Full Overview, consider

turning off the layers for Fixtures and Furnishings in the appropriate layer sets.

In elevation and plan views, if you use a high number of macros in text or labels that

are displayed, this can slow down panning, zooming, and moving objects in these

views. 

Manage 3D Surface Count - Avoid importing 3D objects from outside sources that



have a large number of complex surfaces, as these can significantly slow down

camera views.

To check the number of surfaces for imported symbols, using the Select Objects 

tool, click on an imported symbol to select it. Next, click on the Open Object  edit

tool in X15 and newer versions or Open Symbol  in X14 and prior versions. On

the 3D panel, take note of the Number Of Faces and then Cancel out of the dialog

without making any changes.

If you aren't certain whether or not a symbol has an unusually high number of faces,

you may want to repeat this procedure on a similar type symbol placed from the

Chief Architect catalogs and compare the Number Of Faces.

Control Pictures and PDF 5les Saved in Plan/Layout

By default, picture 5les and PDF 5les are referenced from outside of your Chief

Architect 5le. You can, however, open the Speci5cation dialogs for both of these types

of objects and check the Save in Plan option to embed the picture, or PDF, in the plan.

If you chose this option, it could cause a signi5cant slowdown when working in the plan



or layout 5le.

Instead of saving pictures or PDF 5les in the plan, the recommended method for

transferring a 5le between computers, or to another individual, is to use the Backup

Entire Plan/Layout  feature to ensure that no data is lost that would result in a

missing 5le message. This feature not only allows you to export the picture and PDF

5les along with the plan and layout, but also all of the associated custom backdrops,

materials, and images you may be using for the 5le. For more information on using this

tool, see the Related Articles section below.

Manage Live Views in your Layout

When you send a cross section/elevation, camera view, or overview to your layout, you

have the option to select Live View to make the view dynamically linked to the plan 5le.

You can also select for this view to Update On Demand or Update Always.

Selecting Update Always can potentially contribute to slowness in your plan. To change

a view so that it only updates on demand, select the view in your layout, then click the

Open Object  edit button to open the Layout Box Speci+cation dialog. On the

LINKED VIEW or CAMERA VIEW panel, select Update On Demand, then click OK.

Purge Unused Data

In addition to the suggestions above, if you have been using a file through several

versions of Chief Architect, you may have unnecessary leftover data such as unused

CAD Blocks, materials, and layer sets that can be removed to reduce the overall size

of your plan file.

It's important to always start a new plan or layout 5le from a template. If

you are unfamiliar with setting up template 5les, please review the

appropriate resources located in the Related Articles section below.

To purge unused CAD blocks, select CAD> CAD Block Management  from the



menu. In the CAD Block Management dialog, there is a list of all CAD blocks

referenced in your plan.

Click the Purge button to delete any unused block definitions from the list.

You can also click on an unused CAD block in the list, then click Delete to remove

it from the list.

Check the Automatically Purge CAD Blocks box to prevent unused CAD block

definitions from being saved in the plan.

When you're done making changes, click OK to close the dialog and apply the

changes, then Save the file.

Note: It is not possible to delete all CAD block definitions from a plan file. Even

if no objects are present in the plan, the CAD blocks associated with default

electrical symbols are saved with the plan and cannot be removed.

To purge unused materials from your plan, select 3D> Materials> Plan Materials 

 from the menu to display the Plan Materials dialog. The list on the left includes

all materials present in the plan.



Click the Purge button on the right to remove any unused materials from the list.

You can also select an individual unused material from the list and click the

Delete button.

When you're done making changes, click OK to close the dialog and apply the

changes, then Save the file.

To manage layer sets, select Tools> Layer Settings> Layer Set Management  to

open the Layer Set Management dialog. Use the Available Layer Sets options to

manage the layer sets saved with the current plan or layout file.



Click the Delete button to delete a selected layer set from the current file.

The Delete button is only enabled if the layer set can be deleted.

Do not delete layer sets that are used in views that were previously

sent to a layout 5le.

When you're done making changes, click OK to close the dialog and apply the

changes, then Save the file.

Disable Auto Rebuild Options

There are several settings within the program that aHect rebuilding, which can slow

down a complex plan if they are constantly having to be regenerated after every

change. For speed purposes, you may want to turn oH these auto rebuild settings, and

only turn them back on when the plan is close to completion.



Automatically Rebuild Foundation - This setting can be accessed by selecting Edit>

Default Settings> Foundation.

On the FOUNDATION panel, uncheck Automatically Rebuild Foundation to stop the

foundation from rebuilding every time you make a change on the first floor. Please

note that you will then have to manually update the Floor 0 level, or remember to

turn the feature back on later in the design process.

Automatically Build/Rebuild Framing - There are several settings relating to the

automatic generation of framing, which can be accessed by selecting Edit> Default

Settings> Framing in X15 and prior versions, or Build> Framing> Build Framing in

X16 and newer versions.

In X15 and prior versions, go through every individual floor panel, starting on the

FOUNDATION, up to 1ST, 2ND, etc and uncheck the checkboxes near the top of the

dialog for Automatically Build Floor and Ceiling Framing. On the WALL panel,

uncheck Automatically Build Wall Framing. On the ROOF panel, uncheck

Automatically Build Roof Framing.

In X16 and newer versions, uncheck the Automatically Rebuild Framing box, and

ensure that all of the subcategory boxes are unchecked.

Auto Rebuild Roofs - This setting can be accessed by selecting Edit> Default

Settings> Roof.

On the ROOF panel, uncheck Auto Rebuild Roofs. Any future changes made to the

plan while this setting is disabled will not affect the roof, so you will need to either

modify or add roof planes manually, or wait until the plan is nearer to completion to

turn the setting back on if it significantly slows down your ability to work in the plan.

If you have a complex terrain that requires rebuilding when you make changes,

select  Terrain> Terrain Specification  and remove the checkmark from Auto

Rebuild Terrain.

When you click OK, you will notice that your mouse cursor now has an image of the

Build Terrain  setting following it to remind you that your terrain may not be up

to date.

Select 3D> 3D View Defaults . You can turn off Auto Rebuild

Walls/Floors/Ceilings at this location. While this may speed up changes you make to



your plan, it is extremely important to remember that it also means that your 3D

camera views may not accurately reflect changes that you have made to the plan

view.

You can disable this setting for troubleshooting purposes, however, expect that

when this is unchecked and the structure is not up to date, the Rebuild

Walls/Floors/Ceilings  icon will display next to your mouse cursor.

Again, if these changes offer speed improvement in working with your complex plan,

you will need to remember to manually rebuild the various options, or to wait until

the plan is near completion to turn the automatic settings back on.

ADVANCED TROUBLESHOOTING
If you have completed all of the troubleshooting steps listed in this article and still have

not been able to determine the cause of the slowness in your plan, then please

submitall of the following information to Chief Architect's Technical Support team for

advanced troubleshooting.

1. When you notice the slowness, take a moment to write down what you were doing.

Include what views you had open, what tools you were using, and what types of

objects were being added, edited, or removed.

For example, joining two particular roof planes, modifying a CAD Detail by breaking

lines, editing doors/windows while a 3D camera view is open, rebuilding framing,

etc.

2. If the issue only seems to occur in one particular file, use the Backup Entire

Plan/Layout  tool to create a folder with a copy of the problem file, along with all

referenced files.

See Knowledge Base article: Using the Backup Entire Plan/Layout Tool to Send Files

to Another User (https://www.chiefarchitect.com/support/article/KB-00987/using-

the-backup-entire-plan-layout-tool-to-send-files-to-another-user.html).

3. If you are receiving an error or warning dialog box, make sure to first search this

https://www.chiefarchitect.com/support/article/KB-00987/using-the-backup-entire-plan-layout-tool-to-send-files-to-another-user.html


Knowledge Base for the exact wording of the error, or click on the Check KB button

in the message if one is present, as there may be specific information relevant to

that error in another article. If you are unable to locate any additional information

on the error, make sure to attach a screenshot of the message.

See Knowledge Base article: Creating a Screenshot

(https://www.chiefarchitect.com/support/article/KB-00326/creating-a-

screenshot.html).

4. Locate and save the program's MESSAGE LOG file.

See Knowledge Base article: Locating the Message Log

(https://www.chiefarchitect.com/support/article/KB-02908/locating-the-message-

log.html).

5. Export or save your SYSTEM INFORMATION.

See Knowledge Base article: Retrieving System Information to Send to Technical

Support (https://www.chiefarchitect.com/support/article/KB-01867/retrieving-

system-information-to-send-to-technical-support.html).

6. Sign in to the Technical Support Center (https://support.chiefarchitect.com/) and

create a new support case to send to Technical Support.

See Knowledge Base article: Using the Technical Support Center

(https://www.chiefarchitect.com/support/article/KB-00717/using-the-technical-

support-center.html).

7. Give the case a short but descriptive title.

In the text of the ticket, type a detailed description of the problem, including the

exact steps that caused the slowness to occur if at all possible. The more detailed

you are, the more likely we will be to reproduce the issue and identify the problem.

Click the Browse button and attach the PROJECT BACKUP, SCREENSHOT,  MESSAGE
LOG, and SYSTEM INFORMATION files to your case, then Submit it.

https://www.chiefarchitect.com/support/article/KB-00326/creating-a-screenshot.html
https://www.chiefarchitect.com/support/article/KB-02908/locating-the-message-log.html
https://www.chiefarchitect.com/support/article/KB-01867/retrieving-system-information-to-send-to-technical-support.html
https://support.chiefarchitect.com/
https://www.chiefarchitect.com/support/article/KB-00717/using-the-technical-support-center.html




(https://chieftalk.chiefarchitect.com/)
 (/blog/)



(https://www.facebook.com/ChiefArchitect)


(https://www.youtube.com/user/ChiefArchitectInc)


Note: Some of the requested information may identify you, as well as specific

information about your computer, but it will also help us determine the source

of the problem. Please be assured that any files submitted to Chief Architect

Technical Support will be used for troubleshooting purposes only.

Creating and Using a Plan Template (/support/article/KB-00463/creating-and-using-a-

plan-template.html)

Creating and Using Layout Templates (/support/article/KB-00737/creating-and-using-

layout-templates.html)

Creating Custom Templates from Existing Projects (/support/article/KB-

03094/creating-custom-templates-from-existing-projects.html)

Locating the Message Log (/support/article/KB-02908/locating-the-message-log.html)

Retrieving System Information to Send to Technical Support (/support/article/KB-

01867/retrieving-system-information-to-send-to-technical-support.html)

Troubleshooting 3D Camera View Display Problems in Chief Architect

(/support/article/KB-00106/troubleshooting-3d-camera-view-display-problems-in-

chief-architect.html)

Using the Backup Entire Plan/Layout Tool to Send Files to Another User

(/support/article/KB-00987/using-the-backup-entire-plan-layout-tool-to-send-files-to-

another-user.html)
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