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Creating a Cabinet Detail

Reference Number: KB-00580
Last Modified: October 28, 2021

The information in this article applies to:

B

PREMIER  INTERIORS

QUESTION

Can you offer some suggestions for creating cabinet details?
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ANSWER

Cabinet elevations can easily be created using the Wall Elevation and Dimension tools.
Additionally, Chief Architect Premier can convert an elevation view to a2D CAD drawing
using the CAD Detail from View tool.

To create a cabinet elevation

1. Open D the plan file for which you would like to create cabinet details.

2. Select 3D> Create Orthographic View> Wall Elevation [[8| from the menu, then
click and drag to draw a camera arrow directly towards the front of the cabinets you

wish to detail.
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The Cross Section/Elevation and Backclipped Cross Section tools can
also be used to create a cabinet elevation; however, these tools may
display additional rooms and/or floors by default.



3. If needed, use the Zoom g tools to zoom in on the cabinets you would like to
detail.

If you find it helpful, you can also select View> Color to toggle off the

color while in the elevation view.

4. If you see objects such as decorative furnishings, electrical fixtures, or labels that
you do not want in the view, you can turn off their display in the Layer Display
Options dialog or within the Active Layer Display Options [[%| side window.

o To open the Layer Display Options dialog, select Tools> Layer Settings>
Display Options [] from the menu.

o The Active Layer Display Options [ side window is displayed on the right side
of the screen by default. You can toggle the display of this window on and off by
navigating to View> Active Layer Display Options [F]|

5. Select Tools> Active View> Save Active View @ from the menu, then
select Tools> Active View> Edit Active View .



6. On the CAMERA panel of the Wall Elevation or Cross Section/Elevation
Specification dialog that displays..

™ Cross Section/Elevation Specification

{Camera ! General
Selected Defaults Mame: |Fﬁtchen Elevation A
Plan Display
|
Backdrop S
Layer Rendering Technique: | Vector View e Define...
Label
Shiow Calaor
[] show wWatermark
[] show shadows
Ray Casted Sun Shadows
[[] edge Smoothing when Idle
Pasitioning
¥ Position: 3Ty
' Position: 623"

scene Clipping

[] Badk clip
Back Clip After: 35
Clip Sides
Clip Width: 443 5/16

Clip Elevation
Bottom Clip Elevation: |1
Top Clip Elevation: 109
Clip to Room
[] 1gnore Railings and Invisible Walls
[ 1gnore walls Above

Mumber Style. .. Cancel Help

o Type a short name for your saved cabinet elevation in the Name field, such as
Kitchen Elevation A.

o Choose your desired rendering options.

o Uncheck Clip to Room if you would like to manually control where the view is
clipped along the bottom, top, and both sides of the elevation.

Once the Clip to Room setting is unchecked, you may find that it
easier to adjust the side clipping of the elevation using the edit
handles that display in a floor plan view.
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In X12 and prior, you must use the Cross Section/Elevation 4 or the
Backclipped Cross Section é tool, then uncheck Clip To Sides before you can

modify the side clipping of the view. The ability to clip the bottom and top of
cross section/elevation views is not available in X12 and prior versions.

7. Click on the SELECTED DEFAULTS panel, make sure the settings here are setup to your
liking, then click OK.

In this example, the Kitchen and Bath Default Set is specified, the Kitchen and Bath
Elevation Layer Set is selected, and CAD, Kitchen & Bath is the current CAD layer for
this view. Take note of the Dimension Default that is also set here, as this will be
discussed in the next section.

Note: To learn more about Default Sets and how they work in Chief Architect,
please view Video 240: Understanding Default Sets
(https://www.chiefarchitect.com/videos/watch/240/understanding-default-

sets.html).



https://www.chiefarchitect.com/videos/watch/240/understanding-default-sets.html

Camera

iSelected Defaults

Plan Display
Backdrop
Layer

Label

MNumber Style...

-\1 Cross Section/Elevation Specification

Default Set

Currently Using:

Selected Defaults

Dimensions:
Rich Text:
Text:

Revision Cloud:
Callouts:
Markers:
Motes:

Arrows:

Layers

Layer Set:

Current CAD Layer:

Kitchen and Bath Default Set

Kitchen and Bath Dimension Defaults

Kitchen and Bath Rich Text Defaults

Kitchen and Bath Text Defaults

Kitchen and Bath Revision Clouds

Kitchen and Bath Callout Defaults

Kitchen and Bath Marker Defaults

1/2" Scale Note Defaults

Kitchen and Bath Arrow Defaults

Kitchen and Bath Elevation Layer Set

CAD, Kitchen & Bath

Ll O
+| |f
+| |/
+| |/
+| |/
+| |/
+| |f
+| |/
+| |/
Define...
Define...
Cancel

XX XXX XX X

Help

To setup dimension defaults

1. Select Edit> Default Settings @ from the menu, and in the Default Settings

dialog:




2.

3.

™ Default Settings x

30 View Defaults r'\
Cabinets
CAD
Camera Tools
Corner Trim
Default Sets
* [Dimension
‘Dimensions
Auto Story Pole Dimensions
Termporary Dimensions
Doors

Dormer
Electrical
Floors and Rooms W

Done Help

o C(Click the arrow next to Dimension.

o Select Dimensions and click the Edit button.
In X12 and prior, options for the various automatic dimension tools were listed

under the Dimension category. These can now be located by accessing the
Dimensions option in X13.

In the Saved Dimension Defaults dialog that opens next, select the Dimension
Default that was specified for the elevation view in the section above, then click Edit.
If you recall, we are using the Kitchen and Bath Default Set, which is connected to

the Kitchen and Bath Dimension Defaults.

In the Dimension Defaults dialog:



™ Dimension Defaults - Kitchen and Bath Dimension Defaults

General

Setup Automatic

Locate Manual
Locate End to End
Locate Centerline
Locate Interior
Locate Auto Exterior
Locate Auto Interior
Locate Auto Elevation
Locate Auto MKBA Elevation
Locate Elevations
Primary Format
Secondary Format
Extensions

Layer

Arrow

Text Style

Mumber Style. ..

General

Line Separation:

1st Line Offset:

Exterior
Reach:

Minimum Area:

Interior

Minimum Area:

MEBA

Minimum Area:

Elevation

MKBA Elevation

192"

10,0

SqFt

[] 1gnare Interior Walls

Owerall Dimension
[] Auto Refresh

10.0

Overall Dimension

10.0

[] auto Refresh

COwerall Dimension
[] auto Refresh

[] auto refresh

SqFt

SqFt

Cimension on Left
Dimension on Right
Dimension Across Top
Dimension Across Bottom

Dimension on Left
Dimension on Right
Dimension Across Top
Dimension Across Bottom

Cancel

Help

o Select the SETUP AUTOMATIC panel and check the desired boxes in the Elevation

and/or NKBA Elevation section if you will be creating automatic dimensions.

In X12 and prior, these options can be found by opening the Auto Elevation
Dimensions and NKBA Auto Elevation Dimension Defaults.

o Access each of the LOCATE... panels, and choose what you would like each of the

dimension tools to locate.

Note: The ability to dimension to cabinet face items was introduced in X13.
Check the Doors/Drawers/Panels and Openings check boxes located within
the Cabinets category, then use the automatic and manual dimension tools



to locate cabinet doors, drawers, panels, and openings in your elevation
views.

o On the PRIMARY FORMAT panel, select the desired Units, Accuracy, and
Dimension Text Position and Orientation.

o Adjust the EXTENSION line, ARROW, LAYER, and TEXT STYLE properties to your
liking.

To learn more about the various settings relating to dimensions,
select the Help button located at the bottom of the dialog.

o Click OK to close the dialog and apply your changes.

To add dimensions

1. Dimension lines can be added to an elevation view automatically or manually:

o To generate dimensions automatically, navigate to CAD> Automatic
Dimensions> Auto Elevation Dimensions fi| or NKBA Auto Elevation

Dimensions %

o To generate dimensions manually, navigate to CAD> Dimensions {f“ , select your
desired tool, such as the Manual Dimension <‘“ or End to End Dimension

tool, then click and drag to draw a dimension line through one of the cabinets
that you would like to detail.

2. Once dimensions are created, they can be edited further to your liking. Using the
Select Objects ,\\5 tool, click on a dimension line, near the dimension number, to

display various edit handles.

In this example, a dimension line that is displayed along the bottom edge of the
elevation is selected.
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In the image above, the numbers displayed at the bottom represent each
extension line. You can see that the extension line on the left (1) is the very first
extension line in this dimension string.

The diamond-shaped edit handles near the top are Extension Line edit handles.
Select and drag these handles to move an extension line to another location or
object.

To delete an extension line, drag an Extension Line edit handle away from any
dimensionable object, and release the mouse button once the line disappears.

Use the large square Move edit handle located near the dimension number to
move the dimension string in your desired direction.

The diamond-shaped edit handle just below the Move edit handle is the Add
Extension Line edit handle. Drag this handle to an object that you want to locate,
then release the mouse button.

The smaller square edit handle in the middle of the dimension number allows
you to relocate the dimension number, while the triangular edit handle will rotate
the dimension number.

Use the circle edit handle to add a segment onto the end of the dimension line,
and use the large triangular edit handle (not pictured) to rotate the dimension
string.



3. Extension lines can also be selected separate from the dimension line. When an
extension line is selected, the square edit handles that display can be used to resize
the line's length.

In the image below, you can see that the left extension line (1) was resized to be
shorter than the right extension line (2).

B 24" [

4. With either the dimension line or extension line selected, click the Open Object I |
edit button to open the Dimension Line Specification dialog.



™ Dimension Line Specification x
‘Dimension Inherits Properties From
Primary Format Dimension Default: |Kitchen and Bath Dimension Defaults Define...
Secondary Format
Marker Farmat Locate Settings:  Manual Dimension
Extensions/Markers Options
Segments
Layer Mumber Height: 2" l,‘:'.], |
Arrow Display Wall Widths
I%Display Gaps Between Cabinet Face Items
Rounded Value Indicators
Use Default
Show + or - After Mumber
Show ~ Before Mumber
Murnber Style... Cancel Help

o On the DIMENSION panel, notice that the dimension line is following the
Dimension Default that was set in the first section of this article.

o Check the Display Gaps Between Cabinet Face Itemsbox if you would like the
opened dimension line to display dimension numbers for built-in appliances,
blank areas, openings, and other gaps between cabinet face items.

o Make any other desired adjustments to the dimension line, then click OK to close

the dialog.

5. Add any additional information, such as Text |", Leader Lines T, and Notes (N)
to the detail, then select Tools> Active View> Save Active View K1 one final time.
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6. This view can now be sent to a layout file using theSend to Layout tool.

In Chief Architect Premier, you can also add, change, or delete unwanted lines in the
view by converting it into a CAD drawing using the CAD Detail from View tool.

To create a CAD Detail from an elevation view*
*Applies to Chief Architect Premier Only

1. With your saved elevation view open, select CAD> CAD Detail from View RN from

the menu.

Note: The CAD Detail from View tool creates a line-based 2D drawing based
on the current view and places it in a CAD Detail window. This drawing is saved
with the plan file but is not linked to the 3D model in any way. Future changes
made to the original view will not be reflected in the CAD Detail. When this
occurs, you will need to create a new CAD Detail, so it is best to create details

only when your plan is near completion.



2. Select CAD> CAD Detail Management |= | from the menu, and in the CAD Detail
Management dialog:

o C(lick on the name of your new CAD Detail. Its name will begin with "Elevation"
followed by a number, and it will be indicated as open under the Open column.

[™ CAD Detail Management x
CAD Detail Mame Open New...
Elevation 1 \/ —

Copy...

Delete

Open
Cancel Help

o Click Rename and type a short, descriptive name for your detail, then click OK.

o Click OK to close the dialog and return to your CAD Detail.

To delete or trim unwanted CAD lines

1. Using the Select Objects ,\\: tool, select any lines that you want to remove from the
detail, then Delete [ them.

2. If you'd like to trim CAD lines, you can do so using the Trim Objects == edit tool.

To learn more about the Trim Objects edit tool, please view Video 306:
Using the Trim and Extend Commands
(https://www.chiefarchitect.com/videos/watch/306/using-the-trim-and-
extend-commands.html).



https://www.chiefarchitect.com/videos/watch/306/using-the-trim-and-extend-commands.html

3. To trim all CAD objects around a certain area, select CAD> Boxes> Rectangular

Polyline [* |from the menu, then click and drag a rectangle around the portion of

the drawing that you want to keep for your detail.
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o Don't worry about positioning it accurately as you draw. Once the polyline is
created it can be edited with precision.

o In addition to the edit handles, the polyline's edit tools can be used to resize,
reshape, and move it into position.

4. When the polyline has been edited to your liking, select it, and click theTrim
Objects .i’_“é edit tool.

5. Click and drag to draw a temporary line just outside one edge of the polyline.
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o This temporary line is called a fence and it will select every line intersecting your
polyline, and delete the portion of that line that is outside the polyline.

o You may find it helpful to turn off Object Snaps[ﬁJ while drawing temporary
fences. This can be done by navigating to Edit> Snap Settings> Object Snaps[jJ
from the menu.

6. Repeat steps 4 and 5 for each edge of the polyline, if needed.

7. Using the Select Objects ,\\5 tool, click and drag to marquee-select any remaining
lines outside of the polyline, then Delete jﬂ them.
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8. When you are finished, you may want to select andDelete IZ the rectangular
polyline as well.
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Related Articles

#l Adding a CAD Object, CAD Detail, or Text to the Library (/support/article/KB-
00002/adding-a-cad-object-cad-detail-or-text-to-the-library.html)
#ll Clipping Cross Section/Elevation Views (/support/article/KB-00066/clipping-cross-

section-elevation-views.html)
#ll Creating CAD Details (/support/article/KB-00766/creating-cad-details.html)
#ll Setting up a Custom Default/Annotation Set (/support/article/KB-01167/setting-up-a-

custom-default-annotation-set.html)

#l Understanding Layer Sets (/support/article/KB-00765/understanding-layer-sets.html)

#l Using the Project Browser (/support/article/KB-03003/using-the-project-

browser.html)
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