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QUESTION

How do | create a post and beam pavilion in Chief Architect?

ANSWER

There are a wide variety of post and beam construction styles, and a variety of
different methods that can be used to model this type of structure in Chief Architect.


/

To learn more about post-frame construction for the purposes of creating

a pole building or pole barn, please refer to the resources in the Related
Articles section.

In this article, a simple pavilion composed of posts, beams, trusses, and purlins is
created.

To create the perimeter

To add roof trusses

To add beams

To add roof purlins

To create the perimeter

1. Select Edit> Default Settings () from the menu.
2. In X17 and newer versions, select Framing> Manual Framing from the list and click
the Edit button.

o Switch to the BEAMS panel and under Floor/Ceiling Beams, set the Depth and
Width. In this example, 5 ¥%2" is used for both.

o Set the Placement to Under Joists.
o On the PosTs panel, set the Depth and Width to match the beam width of 5 %2".
o Click OK.

o While still under Framing, select Trusses> Roof Trusses and click the Edit
button.

o On the GENERAL panel, under the Member Sizing heading, set the Top and
Bottom Chords, as well as the Webbing to 5 %2".

o Click OK and Done to make these changes and close the dialogs.



In X16, select Framing> General Framing from the list and click the Edit button.

o Switch to the BEAMS panel and under Floor/Ceiling Beams, click the Edit Floor
Beam Defaults button.

o Under the GENERAL panel of the Floor Beam Defaults dialog, set the Depth and
Width of the beam. In this example, 5 %" is used for both.

o Click OK, then set the Placement to Under Joists.

o On the PosTs panel, click the Edit Post Defaults button and set both Width 1
and Width 2 to match the beam width of 5 %2".

o C(lick OK.

o On the TRUSSES panel, under the Member Depth heading, set the Top and
Bottom Chords, as well as the Webbing to 5 %2".

o Click OK and Done to make these changes and close the dialogs.

3. Next, select Build> Framing> Post 3% from the menu, and click in the drawing area

to place a post.

If you don't have the "Framing, Posts" layer turned on, you may see the
message: "The layer "Framing, Posts" is not displayed. Do you want to
turn on the display of this layer in the current view?". Click Yes if you see
this message.

4. Click on the post to select it, then click the Transform/Replicate Object(-[ edit
tool. In the Transform/Replicate Object dialog:



[™ Transferm / Replicate Object x

Copy

Mumber of Copies: 4

Move
X Delta: 120" © Relative To ltself
¥ Delta: 0" () Absolute Location
Relative Te Current Point
£ Delta: 0"
Angle: 0.0° () Relative Angle To ltself
Distance: 120" © Absolute Angle

o Check the box beside Copy and specify the number of copies you would like to
make. In this example, 4 copies are created.

o Check the box beside Move and specify the interval at which you would like the
copied posts to be created. In this example, a Move interval of 120" along the X
Delta is used.

o Click OK to close the dialog and create the copies at the specified interval. In this

example, a total of five posts spaced 10 feet (On Center) apart are produced.

. Next, using the Select Objects % tool, click and drag a rectangular marquee
around all five posts to group-select them.

. With the five posts selected, click the Transform/Replicate Object -0 edit button
again. In the Transform/Replicate Object dialog:
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Copy
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o Check the box beside Copy and specify 1 copy.

o Check the box beside Move and specify the interval to move the copied posts. In

this example, the posts are moved 24 feet down on-screen, or -24' on the Y Delta

then press your Tab key on your key board. You will see a value of-24' converts

to -288"

o Click OK to close the dialog and create the copies at the specified interval.

7. Open your program Preferences

sP

, and on the BEHAVIORS panel, move the radio

button to Concentric and set the Jump value, which is the distance you want
between the outside of the posts and the edge of the pavilion's concrete slab, then
click OK. In this example, 6" is used.



On a Windows PC, Preferences can be found by selecting Edit>
Preferences from the menu. On a Mac, select Chief Architect>
Preferences from the menu instead.
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8. Next, select CAD> Boxes> Rectangular Polyline |¥ |from the menu, then click and

drag a polyline that snaps to the outside of the array of posts.



clicking on the polyline to select it, then Zoom g in on a corner of the polyline.
Since you've already set Concentric as the active Edit Behavior, slowly drag the

corner outward until it snaps to one Jump increment of 6", then release the mouse
button.

=

41' & 52

. Select Edit> Edit Behaviors> Default E to return to the Default edit behavior.

. Select Build> Wall> Room DividerE from the menu, then draw Room Divider

walls over the polyline that you created in the previous steps. When the Room
Dividers completely surround the area they will automatically convert to full width,
invisible walls.



12.

13.

14.

15.

Using the Select Objects ,\\5 tool, click inside of the room's floor area to select the
room, then click on the Open Object l | edit tool.

On the GENERAL panel of the Room Specification dialog, change the Room Type to
Slab so there is no additional flooring on top of the slab foundation, then click OK.

Next, navigate to Build> Floor> Build Foundation ™= from the menu, and in the

Build Foundation dialog, move the radio button under Foundation Type to
Monolithic Slab, then click OK.

Finally, select 3D> Create Perspective Overview> Perspective Framing Overview
([ from the menu to see the results so far.
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To add roof trusses

1.

Select File> Close View from the menu to close the framing overview and return to
the floor plan view.

From the currently active foundation level, goUp One Floor /A, to Floor 1, select the

two vertical side walls that were created using the Room Divider tool, then click on
the Change to Gable Wall(s) {™} edit tool on the Edit toolbar to change them to

gable walls.

With the two vertical side walls still selected, click on the Open Object I | edit tool.

On the ROOF panel of the Wall Specification dialog, under Roof Options
uncheck Include Automatic End Truss Above, then click OK to close the dialog.

Select Build> Roof> Build Roof@ from the menu. In the Build Roof dialog:
o On the ROOF panel, check Trusses for the Framing Method.

o Specify the desired Pitch (in12), Overhang, as well as any other settings, such as



MATERIALS.

o Check the box next to Build Roof Planes, then click OK to close the dialog and
build a roof over the structure.

. Select Build> Framing> Roof Truss {». from the menu, then click and drag a line
perpendicular to the roof ridge from one exterior wall to the opposite wall to draw a

If the "Framing, Roof Trusses" layer is not being displayed, then you
may receive the following message: "The layer "Framing, Roof Trusses"
is not displayed. Do you want to turn on the display of this layer in the
current view?". Click Yes on this message to turn on the display of Roof
Trusses in this view.

. To move the truss over the top of the first two posts on the left side of the building,
select the truss and then click on the Center Object %+ tool. Place your mouse over
the top of one of the first posts until you see the vertical centerline indicator, then
click.



8. With the truss still selected, click the Transform/Replicate Object -0 edit button.
In the Transform/Replicate Object dialog:

o Specify the number of copies that you want across the building. In this example, 4
copies are specified.

o Set the distance between each truss by selecting the Move box and specifying a
value in the X Delta. In this example, a value of 120" is used, which if you recall, is

the same distance between each of the posts that we placed earlier.

o Click OK to close the dialog and create the copies at the specified interval.

9. Create a Perspective Framing Overview ([ to see the results. Select File>
Close View from the menu when you are finished to return to floor plan view.

To add beams



1. Zoom @ in on the two posts located at the top left corner of the structure.

2. Select Build> Framing> Floor/Ceiling Beam <&, then click and drag to draw a
beam between these two posts. Drag the beam's end point to fall just short of the
2nd post.

If the "Framing, Ceiling Beams" layer is not turned on for display in this
view, then you may receive the following message: "The layer "Framing,
Ceiling Beams" is not displayed. Do you want to turn on the display of
this layer in the current view?". Click Yes to this message to turn on the
display of the Ceiling Beams in this view.

By default, beams will snap along their centerlines as they are drawn, and you can
snap them to the post's midpoints.

3. Navigate to Window> Fill Window Building Only [}]]

4. Select the beam, then click and drag the end edit handle to the right. Cross over the
top of all the posts and snap to the right side midpoint of the last post on the right
side of the structure.

5. To copy the beam to the line of posts on the opposite side of the building, select the
beam, click on the Copy/Paste m=:1 edit button on the edit toolbar, click on the

Reflect About Object MD} edit button on the edit toolbar, hover over the roof ridge
line until you see the horizontal center line indicator, then click.



You should now have beams over each line of posts.

6. Create a Perspective Framing Overview [[ﬁ to see the results.

To add purlins
1. Select Build> Roof> Build Roof@ from the menu.

2. On the GENERAL panel of the Build Roof dialog, ensure that either Build Roof
Planes or Auto Rebuild Roofs is checked.

3. On the STRUCTURE panel:

o Check the Build Roof Framing box.

o Change the Rafter/Truss Spacing to be equal to, or greater than, the length of
the building to prevent roof rafters from generating. In this example, 45" is
specified.

o Uncheck the Lookout box, as well as any other boxes associated with framing

that you don't want to build.

4. Click on Edit next to Surface under the Roof Layers section.



[™ Build Roof

Roof

Options
Structure

Rafter Tails
Ridge Caps
Gutter

Frieze

Shadow Boards
Line Style

Fill Style
Materials
Arrow

Label
Components
Object Information
Schedule

Roof Styles

[ Automatically Build Roof Framing

O use Framing Reference

Roof

Rafter/Truss Spacing:

Maxirnum Lookout Spacing:

@ Build Roof Framing

a Angled Dormer Hole

[ Trim Framing To Soffits
540" On Center

1a" On Center

Murmber Style...

5. In the Roof Surface Definition dialog:

Blocking Style: [ Vertical O Cross/Bridging @] Stagger O InLine
Roof Layers
Surface: 5/8"
Structure: 512" Edit...
Ceiling: 5/8" Edit... B Use Room Ceiling Finish
B soffits: 378" ("] Flat Under Eave Sub Fascia
Roof Size
Width Depth Framing Censtruction
Rafter/ Truss: 112" 51/2" Determined by Roof Structure
@ Ridge: 112" 111/4" Roof Ridge ¥  Define..
[ Lookout: 31" 112" Rafters *  Define...
Blocking: 112" 512" Reoof Blocking ¥  Define..
B shoe Plate: 112" 51/2" Roof Shoe Plate *  Define...
Gable Sub Fascia:  11/2" 312" Roof Gable Subfascia ¥ Define..
B Eave Sub Fascia: 11/2" 512" Roof Eave Subfascia ¥  Define...
B Gable Fascia: 374" 71/4"
B Eave Fascia: 3/4" 71/4"
Hip Girder Truss
Count: 2
Distance From Wall Main Layer: 96" B Automatic
[ Roof Overframing
Overframe Layen Roof Finish Sheathing Structural
0K Cancel

Help



-\1 Roof Surface Definition

Material L - —
aterial Layers IZ‘ [[E]
Layer # Material Pattern Texture  Fill Thickness Insert Above
ose-He E:i:i Move Up
- Fir Framing 1 | Move Down
Delete
Total Thickness:
21/8"
Structure
B purlins
Construction: General ~ Define...
Width: 3172"
Spacing: 24" On Center
[ Max Length: 144
Bottom Run Offset: o
Top Run Offset: o
[[] Use Equal Spacing
[ Auto Detail as Insulation
[ air Gap
Mumber Style... Cancel Help

o Add a bottom layer with the framing material for the purlins and set the
Thickness.

o With that new layer selected, check the Purlins box and then set the desired
Type, Width, and Spacing.

o Check the box if you want to specify the Max Length of the purlins. This is
available in X14 and newer program versions.

o Set the Bottom Run Offset and Top Run Offset.
o Check the box for Use Equal Spacing if you want to space the purlins equally

between the top and bottom runs.

6. Click OKto close the dialog and OK again to build the purlins.

Return To Top



Related Articles

#ll Creating Roof Trusses (/support/article/KB-00981/creating-roof-trusses.html)

@l Designing a Structure Using Post-Frame Construction (/support/article/KB-

03137/designing-a-structure-using-post-frame-construction.html)

#l Manually Drawing Framing Members (/support/article/KB-00727/manually-drawing-

framing-members.html)
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