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QUESTION

| have a DWG file containing terrain data that | received from my
surveyor or engineer. How do | import this into my design?

ANSWER

Importing terrain data from a DWG or DXF file is a straight-forward
task, though it requires some knowledge of what layers were used
when the drawing was created and which layers contain the data that
you need.

Terrain drawings typically contain several types of data, specifically
lot boundary data, elevation/contour data, and other CAD data such
as text. There is no single CAD standard, and which layers the


/

different data is on is determined by who created the drawing.

In this article, we will discuss the following topics:

e Determining which layers contain pertinent terrain data
e Importing lot boundary data and elevation/contour data
e Importing other CAD data

To determine which layers
contain pertinent terrain data

1. In the plan you'd like to import the DWG into, select File>
Import> Import Drawing (DWG, DXF) pda from the menu.

2. Find the file on your system, select it, and choose Open.

In Chief Architect Premier X17 and newer, you can
select multiple DWG files to import more than one at a
time.

In X16 and prior versions, in the Import Drawing Assistant
dialog that displays, click Next or Continue to go to the Select
File portion of the dialog, then use the Browse button to browse
to the DWG or DXF file's location on the computer, select it, then
click the Open button.



-‘\l Import Drawing Assistant

Select File
Select the file to import and specify how some CAD entities are handled.

Click the Browse button to select a file to import.
File C:\Users\SB\Downloads\GrandView-TOPO.dwg

Convert lines with shared end points into:
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|_| Boxes

How would you like to handle CAD blocks that are not referenced in the drawing?

) Import all CAD blocks

© Only import CAD blocks that are referenced in the drawing

Hatch entities can be imported as solid-filled polylines. Do you want to import Hatch entities?

] Import Hatch entities
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3. In the Import Drawing dialog:

If using X16 or prior, skip to Step 4 instead.

™ Import Drawing Pt

Files Selected For Import:

e /Users) /Downloads/GrandView-TOPO.dwg

Opticns
/] Show Import Assistant
[ Show For Each File
[_] Create CAD Blocks
Place In Current View
Auto Position Blocks
Add To Library

Cancel Help

o Check the box for Show Import Assistant.



o Uncheck the box for Create CAD Blocks.

o Click OK.

4. On the Import File portion of the dialog:

‘\1 Import Drawing Assistant >

Select File
Select the file to import and specify how some CAD entities are handled.

Click the Browse button to select a file to import.

File: CilUsersy "Downloads\GrandView-TOPC.dwg Browse...

Convert lines with shared end points into:
[ Polylines

|_| Boxes

How would you like to handle CAD blocks that are not referenced in the drawing?
() Import all CAD blocks
© Only import CAD blocks that are referenced in the drawing

Hatch entities can be imported as solid-filled polylines. Do you want to import Hatch entities?

[ Import Hatch entities
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o Do not check Polylines or Boxes under the Convert lines with
shared end points section at this time.

o Choose to Only import CAD blocks that are referenced in
the drawing.

o You can check the Import Hatch entities box if you'd like to
import areas of hatching as solid-filled polylines.

o Click Next or Continue.



5. On the Select Layers page, make sure there is a check beside
the name of each layer shown in the Layer Name column, then
click Next/Continue.

You can click the Select All button to check all layers at once,
ensuring that every layer will be imported during this process.

‘\l Import Drawing Assistant

Select Layers
Specify which layers to import and specify which contain terrain and elevation data.
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6. On the Layer Mapping page, select the Chief Architect layers
by name. radio button, leave the Import all layer attributes
into the current layer set. radio button selected, then click
Next/Continue.



‘\l Import Drawing Assistant b4

Layer Mapping
Associate layers in the DWG/DXF drawing file with layers in Chief Architect.

Map all drawing file layers to:
() A single layer in Chief Architect:

CAD, Default Define...

OEChief Architect layers by name.é

(o] Impart all layer attributes into the current layer set.

) Do not import layer attributes

You can map each layer individually and specify layer attributes on the Advanced Layer Mapping panel.
[ Go to the Advanced Layer Mapping panel,
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7. On the Drawing Unit page, select the unit of measurement that
was used to create the drawing using the drop-down list, click
Next/Continue, then click Finish/Done to close the dialog and
import the drawing.

Note: If you are uncertain of which unit of measurement to
select, contact your surveyor or engineer.



‘\l Import Drawing Assistant b4

Drawing Unit
Specify the imported drawing's original unit of measurement and how dimension lines are imported.

What unit of measurement was used to create the imported drawing?

i 4

Import dimension lines as:

© Import as dimensions where possible.
() Impert as cad blocks,
DWG/DXF drawings are sometimes located far from the origin (0,0).

[_] Move drawing to the origin
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8. You should now see the drawing in the plan. If you do
not, select Window> Fill Window [} 7 from the menu to center it
in the drawing area.

If you still do not see the drawing, please refer to the
ADDITIONAL INFORMATION section at the end of this article.

9. Click on the polyline representing the lot boundary to select it,
click the Open Object | | edit button, then select the LINE STYLE

panel of the object's specification dialog. Make a note of the
Layer that it is on, then click OK.

In this example, the lot boundary is on a layer called C-PROP-
BNDY.
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10. Next, determine which layer(s) the contour/elevation lines are on
using the same technique just mentioned in Step 7.

11. Once you have determined the layers that the terrain data is on,
close the file without saving it, then proceed to the next section.

To import lot boundary data and
elevation/contour data



1. Inyour desired plan, and with the appropriate plan view active,
navigate to File> Import> Import Drawing (DWG, DXF) pia from
the menu to open the Import Drawing Assistant, then click
Next/Continue.

2. On the Select File page, click the Browse button to open the
Import Drawing File dialog and select the desired DWG or DXF
file saved on your computer. Once the desired file is selected,
click Open to return to the Import Drawing Assistant. Check the
Polylines box under the Convert lines with shared end points
into: heading, then click Next/Continue.

‘\l Import Drawing Assistant b4

Impaort File
Specify how some CAD entities are handled.

File: ChlUsersy "Downloads\GrandView-TOPC.dwg

Convert lines with shared end points into:

|_| Boxes

How would you like to handle CAD blocks that are not referenced in the drawing?
() Import all CAD blocks

© Only import CAD blocks that are referenced in the drawing

Hatch entities can be imported as solid-filled polylines. Do you want to import Hatch entities?

] Import Hatch entities
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3. On the Select Layers page:



-‘\l Import Drawing Assistant

Select Layers
Specify which layers to import and specify which contain terrain and elevation data.

Layer Name Visible Frozen Convert To
[ C-SURF-TREES vy
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(] FIGURE vy
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Select All Clear All

Convert Selected Layer(s) to: | Terrain Perimeter

Terrain Perimeter
Elevation Data = Back Mext » Cancel Help

o Uncheck any unwanted layers using the Layer Name
column. You can click the Clear All button to quickly, and
easily, uncheck all layers at once.

In this example, the CONT-MJR, CONT-MNR, and C-PROP-
BNDY layers are the only layers selected.

o Select the layer containing the lot boundary polyline, then
select Terrain Perimeter from the Convert Selected
Layer(s) to drop-down list.

In this example, the C-PROP-BNDY layer is the lot boundary
layer and is specified to be converted to the Terrain
Perimeter.

o Select the layer(s) that contain contour/elevation data and
select Elevation Data from the Convert Selected Layer(s)
to drop-down list.



In this example, the CONT-MJR and CONT-MNR layers consist
of minor and major contour/elevation data and are specified
to be converted to Elevation Data.

o Once the correct layers are selected and defined correctly,
click Next/Continue.

4. On the Layer Mapping page, select a layer mapping option. Any
option will work in this instance; however, you can, for example,
map the lot boundary directly to the native Chief Architect
Terrain Perimeter layer by checking the box beside Go to the
Advanced Layer Mapping panel, then clicking Next/Continue.

5. (Optional) On the Advanced Layer Mapping page, click on the
layer(s) that you would like to remap, then use the drop-down
menu at the bottom to map the layer(s) to the desired Chief
Architect layer(s). Once the layers are mapped to your liking, click
Next/Continue.

In this example, the C-PROP-BNDY layer is mapped to the Terrain
Perimeter layer. You could also map the contour/elevation layers
to native Chief Architect layers at this time.

You can also click on the Define button located beside
the layer drop-down option to open the Layer Display
Options dialog, where additional layer properties can

be adjusted.



-‘\l Import Drawing Assistant

Advanced Layer Mapping
Map imported layers individually and specify their attributes.

Select one or more imported DWG/DXF layers from the list.

DWG/DXF Layer Chief Layer New
C-PRGP-ENDY TerainPerimeter | |
CONT-MIR CONT-MIR Mew
COMNT-MMR CONT-MMR Mew

Choose a Chief Architect layer from the drop-down list to map the selected DWG/DXF layer(s) to.
Click the Define button to specify the layer's attributes,

Terrain Perimeter . e Define...
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6. On the Drawing Unit page, select the desired unit of
measurement, click Next/Continue, then click Finish/Done to
close the dialog and import the drawing.

Note: If you receive a message stating: "The imported CAD
line/s could not be converted to a Terrain Perimeter. You
must have one closed polyline to convert to a Terrain
Perimeter.", the lot boundary was not recognized as a fully
enclosed polyline. Click "OK" on this message, then analyze
the lot boundary. Once you have found the culprit and have
enclosed the polyline, use the Convert to Polyline edit button
to convert the polyline to a Terrain Perimeter. Please refer to
the "Converting a Polyline into a Terrain Perimeter" resource
in the Related Articles section to learn more.




7. You should now see the drawing in the plan. If you do

not, select Window> Fill Window [ | from the menu to center it
in the drawing area.

If you still do not see the drawing please refer to the
ADDITIONAL INFORMATION section at the end of this article.

8. Additional changes to the terrain perimeter and elevation data
can now be made.

9. Once your desired changes are complete, navigate to Terrain>



Build Terrain i} from the menu, then take a Camera (18] view to

see the results.

Note: In some circumstances, you may receive a message
stating: "The terrain interpolation will take a long time to
generate. Would you like to use the linear interpolator
instead?" Click "Yes" to proceed.

To import other CAD data

o Navigate to File> Import> Import Drawing (DWG, DXF) pia
from the menu to open the Import Drawing Assistant,



then click Next/Continue.

o On the Select File page, click the Browse button to open the
Import Drawing File dialog, select the desired DWG or DXF
file saved on your computer, then click Next/Continue.

1. On the Select Layers page, select layers not
containing perimeter or elevation data by unchecking the layers
that were already imported, then click Next/Continue.

2. Choose your desired options on the Layer Mapping page, then
click Next/Continue.

3. On the Drawing Unit page, select the unit of measurement, click
Next/Continue, and finally, Finish/Done. You should now see
the additional data in your plan.



ADDITIONAL INFORMATION

e Drawings imported into Chief Architect should be created in
Model Space in AutoCAD®. If a drawing was created on Page 1 in
Paper Space, it will be imported as it's own CAD block.

e Chief Architect does not recognize layers that are frozen in
AutoCAD®. You can see if any layers in your drawing file are



frozen on the Select Layers page of the Import Drawing
Assistant.

e Chief Architect is able to import layers that have been turned off
in AutoCAD®; however, the 2D display of these layers will be
turned off in Chief Architect, as well, so you will not see them
when the drawing is first imported.

e Elevation data saved in a text file format can also be imported by
selecting File> Import> Import Terrain Data .5 from the menu.
Elevation data that is saved in this format is usually done with the
X, Yy, and z coordinates in mind, where x and y define the location
of a point on a Cartesian grid, and z defines the elevation for the
point. When using this import method, each data point must be
on a separate line in the text-based file.

For more information, navigate to Help> Launch Help ?within
your program, and search: Import Terrain Assistant.

e GPS data in a .gpx file format can also be imported by selecting
File> Import> Import GPS Data [4.GPS data may include three
types of points - Way, Track and Route. Chief Architect can only
import a .gpx file if it includes one or more Way Points. If a *.gpx
file is imported and it contains no Way Points, no data will be
imported. Route Points contained in a .gpx file will not be
recognized upon importing.

For more information, navigate to Help> Launch Help ?within
your program, and search: Import GPS Data Assistant.

Related Articles



# Converting a Polyline into a Terrain Perimeter
(/support/article/KB-00324/converting-a-polyline-into-a-terrain-
perimeter.html)

# Converting Plan Files to DWG or DXF(/support/article/KB-
00013/converting-plan-files-to-dwg-or-dxf.html)

# Troubleshooting DWG/DXEF File Import Issues
(/support/article/KB-00283/troubleshooting-dwg-dxf-file-import-
issues.html)

# Using CAD to Walls from an Imported DWG/DXF
(/support/article/KB-00170/using-cad-to-walls-from-an-imported-
dwg-dxf.html)
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