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The information in this article applies to:

PREMIER  INTERIORS

QUESTION

| would like to create and use a layout template in Chief Architect. How do | do this?

ANSWER

A template file has all of your preferred default settings, layer display options, and
other file-specific information saved and waiting for you.

A layout template can also feature a border with your company information, logo, text
macros and other details. When you identify a file as a template, Chief Architect refers
to that file for this information any time you open a new layout file.

Creating a layout template is easy and can save you a lot of time when creating a new
layout file. In this article, we will discuss how to:

e Setup the orientation and size
e Setup the layout box defaults (Applies to X14 and newer program versions)
e Set default designer and client info



/

e (Create the layout title block and border
e Save and use the file as a template
e Change the default layout template

To setup the orientation and size

1. Start by selecting File> New Layout || | from the menu to create a new, blank
layout file.

2. Navigate to File> Print> Drawing Sheet Setup [f |.



[™ Drawing Sheet Setup x

Drawing Sheet
Orientation: l:::l Portrait @ Landscape
Size: ARCHD (24" x 3587 * | | Customize...

Show Drawing Sheet in View

Drawing Scale

Printer for View
Remember Print Settings after Printing

Printer: Last Printer Used: Chief Architect Save As PDF | Choose...

Drawing Margins

Populate From Printer

Top: 0" |
Bottom: |07 |
Left: 0” |
Right: 0" |

Advanced Line Weight Options

Use 1 for all line weights (Home Designer compatibility)

Aline weight of 1 = 1/ 100.0 mm -

Preview of Line Weight at Drawing Scale of 1in = 1in

Line ! : :
Weight Approximate Printed Size

26
53
132

'
205 J

Murnber Style... Cancel Help

o Set the Drawing Sheet Orientation and Size to your liking.

In most cases, the Printer Paper and Drawing Sheet sizes should be the same.

o Make sure the Drawing Scale is set at a 1 to 1 scale.

Example: 1in=1in

It is important not to change this, as the drawing scale is set when
you send individual views to the layout.



For more information about drawing scale as well as line weight scaling, click the
Help button at the bottom of this dialog.

o Make any other desired changes, then click OK to apply your settings and close
the dialog.

To setup layout box defaults*

*Applies to X14 and newer program versions

1. Within a layout file, navigate to Edit> Default Settings @ select Layout Box, then

click Edit to set up default behaviors for views sent to layout, as well as control their
properties.

2. On the LINE STYLE panel:



™ Layout Box Defaults x
Line Style Line Options
Fill Style Layer: Default Layout Box Borders w Define...
Label
Style: By Layer e Library...
weight: [] By Layer |1 |
Burnping
[ ] CAD Stops Move
Drawing Group
Default: 21 - CAD e
Mumber Style... Cancel Help

o Set the Layer the layout boxes will be created on.

o Choose the line Color, Style, and Weight if the layout box borders are set to
display.

o If you want CAD information to stop the movement of the layout box, check the
box for CAD Stops Move.

o Set the Drawing Group you want these layout boxes to display with.

3. On the FiLL STYLE panel, choose a Pattern, Scale, Offset and Angle, and Pattern



Appearance if you want the layout boxes to come in with a fill for the entire view.

™ Layout Box Defaults et
LineStyle | Pattem
Fill Style Type: Mo Pattern “ | | Library. .. |
Label
Scale
Width: 2" S
Height: 2" >
Scale: 1.0 Z
Offset and Angle
Horizontal Offset: |0" >
Vertical Offset: 0" >
Angle: 0.0 >
Pattern Appearance
Line Weight: | o
Color:
Custom Color
IUze Layer Color
lUse Background Color
Transparency: 0%
Background
Calar:
Custom Color
IUze Layer Color
IUse Background Color
Transparency: 0%
Preview Width: |12' V|
T

4. On the LABEL panel:



™ Layout Box Defaults x

Line Style L] Suppress Label
Fill Shyle ......
Label Label Options

(® Automatic Label
(O Specify Label

Insert; = M

() Use Callout Edit...

(0 Use Marker Edit...
Use Default Formatting

[] Display Border

Alignment: | Left ~

Auto Adjust Text Direction

Plan View Position and Crientation

X Offset: (0" |

¥ Offset: |3/4" |

Angle: |D.D‘ |@ Relative Angle O Absolute Angle

Camera View Display
Automatic
Show in this View
Hide in this View
Label Layer
® Use System Layer (Layout Box Labels)
O Use Object Layer (Layout Box Borders)
(O Use Custom Layer

Layout Box Labels Define...

Mumber Style... Cancel Help

o Choose if you want to Suppress Label, use the Automatic Label, Specify Label,
use a Callout, or use a Marker for your layout box labels.

Using a Callout or a Marker will allow you to Specify details of that callout or
marker respectively.

o Decide if you want to display a border around the label and the alignment of the
label.



o Set the Position and Orientation of the label.

o Decide what layer the label should be on.

5. Click OK and Done to close the dialogs and confirm the changes.

To set default designer and client information

In X15 and newer you are able to set default designer/client information within the
Preferences dialog.

In X14 and prior you can still set this information, but it must be done in each
individual plan/layout or within your template file.

1. To set this information in X15 and newer, select Edit> Preferences ;|| from the

menu if you're on a Windows PC or Chief Architect> Preferences |;p| if you're on a

Mac. In Preferences, go to the NEw PLANS panel located under GENERAL.



N

w

Preferences

Appearance
Colors
Font
Library Browser
Text
General
File Management
Folders
Ruby
Mew Plans
Unit Conversions
Time Tracker
Architectural
CAD
Edit
Coordinate System
Behaviors
Snap Properties
Materials List
Report Style
Master List
Render
Ray Trace
Video Card Status
Reset Options

Mumber Style...

Mew Plans and Layouts
®) U.S. Units

Plan Ternplate:

|C:\Users\ChieP\ Documents\Chief Architect Premier X14 Data'\ Temp!ates\Residential Template.plan

Layout Template:

lC:‘\Users\Chief\Dacuments\Chiel Architect Premier X14 Data' Templates\ArchD 24x36 Layout Ternj;l

(O Metric Units

Plan Ternplate:

|Re«sidentia| Template - Metric.plan

Layout Template:

IISO'IA 394x841 Layout Template layout

Open and Save As

(®) Use Last Folder
() Use This Folder

C:

Designer/Client Information

Default Designer/Client Information: | Define...

Copy Designer Information from Templates for:
] New Plans
[ Mew Layouts

Copy Client Informaticn from Templates for:
D[ New Pans|

[ New Layouts

Browse...

Browse...

Browse...

Browse...

Browse..

Help

o To the right of Default Designer/Client Information click Define.

o Fill out the information for both the designer and the client. Once you are done

filling out this information, click OK.

o Next, you can choose whether you'd like to copy this information to your newly

In X14 and prior you can still set this information, but it must be done in each
individual plan/layout or within your template file.

created plans or layouts by checking the boxes for New Plans or New Layouts

which can then be reported by using macros.

o Open ﬁ__j your layout template or the file where you would like to specify this

information.




o Go to Tools> Designer/Client Information and select either the Designer
Information7| or Client Informationgg! to edit it.

o Fill out the information and click OK.

2. To report the Designer/Client information in your files you will need to use a text

Mmacro.
Fich Text Spe ®
e I C PAYBI/USAESEE U™
i Gekal  * Comactinfa 3 s
TT Fie Info Designer  + [P
Company
Phiine
Second Phone
Cell Phon
chess =
'''' Wiy St
E-Masd
Seeewt
ity
State
Zp Code
Comnbry
Murmbas Style._. Cancel Help

o Inyour layout template file go to CAD> Text> Rich Text T

o Click where you would like the text box to be to open the Rich Text
Specification.

o In the Rich Text Specification select the select the Insert Macro M tool and go
to Global> Contact Info> Client/Designer and select the macro that correlates
to the information you would like to be reported. You can then use these macros
when creating your custom title block.

To create a layout border and title block
1. First, go to Page O of the layout file.

[0] >



Page 0 is the Default Page Template. Iltems placed on this page show on
every page of the layout that is assigned to follow this Page Template.
It's possible to set up more than one page template. Please refer to the
Related Articles section below for more information.

. Using the CAD tools, create a border and title block that you want to display on each
page of the layout.

. Using Text T or Rich Text T add a company name, project information and any

other notations that you may want to display on each page of the layout.

. Toinsert a company logo, image, or PDF, select File> Import> Import Picture@
or File> Import> Import PDF .} .

. Macros are special commands that insert dynamic information into a text box. After
placing a text object in the layout, select the Insert Macro>Mtool to insert a macro.

Text Macros are available in both plan and layout files, but are particularly useful in
layouts, allowing you to automatically insert useful information such as the page
number, date and time, and file name.



™ Text Specification X
Jext ] Insert: ] Add an Arraw Spell Check... E F)
Attributes
Link Global 4 Contact Info 4
Line Style Object Specific  * File Info r
Fill Style Plan Info »
Text Style
Layout Info L Layout Page Number (Fepages)
Reom Info 4 Printed Page Mumber (Yepage.print?5) %
Wall Info 4 Mumber of Printed Pages (%enumpages?s)
Special Characters  # Last Used Layout Page (Zelastpages)
Time Date 4 Layout Page Label (¥layout.label %)
Layout Page Title (Zelayout.title%s)
Layout Page Description (layout.description 35)
Layout Page Comments (3tlayout.comments)
Last Revizion Label (Ferevizion.label 35)
Last Revision Description (%erevision.description%5)
Last Revision By (Zerevision.by%)
Last Revision Date (Yerevision.date?)
Mumber Style... Cancel Help

o

number for each page of the layout.

You can use the Layout Page Number (%page%) macro to show the page

o Use one of the Time or Date macros to insert the date or time in the layout to

automatically let you know when you printed this layout.

o Add the file name for this layout sheet using one of the File Info text macros.

o Inserting this next to the binding edge will allow you to determine which file it is

or even where this set of plans is located on your computer, should you need to

reprint them in the future.

To save and use the file as a template

1. Select File> Templates> Save As Template



2. Inthe Save as Template dialog that displays:

™ Save as Layout Template x

Revision Entries

Client Info

Delete Unused
CAD Blocks
Layers
Line Styles

Unlink External References
Reference Plans
Callouts

[®] Delete Mon-Template Page Data

(] caD L] Page Tables
Pictures [] Revision Tables
Layout Boxes L] Text

Options

[] Set Template as Default for U.S. Units Layouts

Cancel Help

o Check the box beside each category of object or data that you want to delete
from the current file.

Starting in X13, the Delete Objects tool can be also be used to delete
specific information from one or more pages of a layout file.

o Check Set Template as Default for Imperial/Metric Layouts to use the new
template as your default template whenever you select File> New Layout .

o Click OK.

3. Give the new layout template a short, descriptive name.



4. Click Save, and the program will automatically save the template to the program's
Templates directory on your computer.

To change the default layout template

You can change the default layout template that is used whenever you open a new
layout file by accessing the program's Preferences dialog. If the Set Template as
Default for Imperial/Metric Layouts was checked in the section above, it's not
necessary to follow the instructions below as you've already set your customized layout
to be the default layout template.

1. Select Edit> Preferences [|p| from the menu if you're on a Windows PC orChief
Architect> Preferences 3P| if you're on a Mac.

2. On the NEw PLANS panel of the Preferences dialog:

™ Preferences >
v Appearance Mew Plans and Layouts
Colors ® U.S. Units
Library Browser Plan Temelad
Text an Template:
Pattern Editor |Re5identia| Template.plan | Browse...
W
Gene.ral Layout Template:
File Management
Folders |ArchD 24x36 Layout Template.layout | | Ernwse..[g
:RUb}' () Metric Units
iNew Plans i
Unit Conversions Plan Template:
Time Tracker |Re5identiaITempIate - Metric.plan | Browse...
Architectural
CAD Layout Template:
v Edit |ISO1A 384y 241 Layout Template.layout | Browse...

Coordinate System

o Click the Browse button to the right of the Layout Template text field for the unit
of measurement you're using.

o In the dialog that opens next, browse to the location of your new layout template
file, select it, and then click Open to specify this file as your default layout
template.



o Click OK to close the dialog.

Related Articles

#l Creating and Using a Plan Template (/support/article/KB-00463/creating-and-using-a-

plan-template.html)

#l Creating Custom Templates from Existing Projects (/support/article/KB-

03094/creating-custom-templates-from-existing-projects.html)

#l Resizing a Layout Title Block and Border (/support/article/KB-02862/resizing-a-layout-
title-block-and-border.html)
#ll Setting Up Layout Template Pages (/support/article/KB-03018/setting-up-layout-

template-pages.html)
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