Chiet Architect

Architectural Home Design
Software

Understanding Layer Sets

Reference Number: KB-00765
Last Modified: January 17, 2024

The information in this article applies to:

PREMIER  INTERIORS

QUESTION

What are Layer Sets and how are they used in Chief Architect?

ANSWER

Layer Sets can be thought of as a stack of transparency sheets gathered together for a
particular purpose that can be quickly applied to your drawing. Rather than turning on
and off layers one-by-one, Layer Sets allow you to quickly switch from one collection of
layer attributes to another.

Additionally, Layer Sets are connected to Saved Plan Views, which allow you to change
a variety of options in the program all with a single click. If you're editing your electrical
plan, for example, your job will be easier if unrelated objects such as roof planes and
ceiling framing are not in the way. You could access your Layer Display Options and
browse the dozens of layers in the list, turning off each unneeded layer for the view
you're in; or, you could simply switch to the Electrical Saved Plan View, which could be
associated with an Electrical Layer Set that has all of your preferred display settings
already setup to your liking.
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Chief Architect template plan files include a number of Saved Plan Views and Layer

Sets created for a variety of purposes, including:

e Display settings for different types of views.
e Display settings for specific drawing tasks.
e Settings for the Reference Display.

Understanding how Layers and Saved Plan Views function, and how they
are associated with Layer Sets, is fundamental in establishing a productive
workflow. Please view our Related Articles section to learn more about

these topics.

You can learn more about Layer Sets in the following sections:

e Managing, customizing, and creating Layer Sets
e Linking Layer Sets to Saved Plan Views
e Linking Layer Sets to other types of views




Using Saved Plan Views to switch Layer Sets

Using the Active Layer Display Options to switch Layer Sets
Exporting and importing Layer Sets

Modifying all Layer Sets in a file

To manage, customize, and create Layer Sets
1. Open | |your desired plan, or create a New Plan | 1.

2. Navigate to Tools> Layer Settings> Layer Set Management @5

Here, you can scroll through the various Layer Sets that are contained within the
plan and make any desired modifications.



™ Layer Set Management x

Available Layer Sets

All Layers OFF Define...
All Layers OM
Working Layer Set
3D Framing Layer Set

Mew...

Copy...
CAD Block Detail Set 2
Carmera Clay View Layer Set Rename...
Carmera Yiew Layer Set
Detail Layer Set Delete
Electrical Layer Set Import...

Floor Plan Dimensioned Layer Set
Floor Plan Shell Layer Set Export...
Framing Layer Set

Framing, Ceiling Layer Set

Framing, Floor Layer Set

Framing, Roof Layer Set

Kitchen and Bath Elevation Layer Set
Kitchen and Bath Layer Set
Materials List Layer Set

Mechanical Layer Set

Plan Footprint Layer Set

Plot Plan Layer Set

Reference Display Layer Set

Roof Plan Layer Set

Section View Layer Set

Terrain Layer Set

Active Layer Set For Current View
Working Layer 5et =~ Define...

Cancel Help

o To customize layer properties for an existing Layer Set, select the name of the
Layer Set to highlight it, then click Define to open the Layer Display Options
dialog.

Layer settings such as Line Style, Line Color, Line Weight, Text Style, whether or
not a layer is locked, and if a layer is displayed for the Layer Set can be specified
here.

For more information on layers and their properties, please see the
"Understanding Layers" resource in the Related Articles section

below.



™ Layer Display Options O x
Layer Sets
Waorking Layer Set ~ | | Copy Set... ] Modify All Layer Sets
Reset Layer Marmes | |Delete Unused Layers

Properties for Selected Layer Set

Marne Filter: |
Name Used Disp Lock Color Weight Line Style Text Style ~
30 Solids '};P v 18 — Schedule Style
Architectural Blocks S J 25 —— Default Text Style
Architectural Blocks, Labels S 10 — Default Label Style
AudieVideo 4 12 — Default Text Style
Brick Ledge Lines S v Default Text Style
‘Cabinets, Base “ .(' -= Default Text Style
Cabinets, Full L Default Text Style
Cabinets, Shelves & Partitions 'H] v 25 — Default Text Style W

Select All Mew... Copy Merge Delete
Properties for Selected Layer - "Cabinets, Base"
Display [] Lock

Color: | [T

Line Weight: |25 |

LineStyle: | - = - - =-—-—-———-——-— - - — - w Library...

Text Style: Default Text Style w Define...

Cancel Help

o Click the New button to open the New Layer Set dialog and create a new Layer
Set. Layer Sets must have unique names. If you try to give the new Layer Set a
name that already belongs to a Layer Set in the current plan, the program will ask
you to choose a new name.

™ Mew Layer Set et

Mame: New Layer Setf

Cancel Help

Once a name is specified and you click OK, the Layer Display Options dialog will
open for the newly created Layer Set allowing you to specify your desired layer
settings.

o Click the Copy button to open the New Layer Set dialog and create a new Layer



Set based on a copy of the currently selected Layer Set.

Again, once a name is specified and you click OK, the Layer Display Options
dialog will open for the newly created Layer Set allowing you to specify your
desired layer settings.

o (Click the Rename button to rename a Layer Set and the Delete button to delete
Layer Sets.

The Layer Set specified as the Active Layer Set For Current View cannot be
deleted.

Don't delete Layer Sets that are being referenced or used by a layout
file.

Also, it's important to be aware that any changes made to a Layer Set
in one view will affect all other views that use the same Layer Set.

o Click the Import button to import layer settings from a .layers file or theExport
button to export the layer settings in the current plan to a .layers file.

More information on importing and exporting Layer Sets can be found further
down in this article.

o The Active Layer Set for Current View drop-down option displays the Layer Set
that is used in the plan view that was active when this dialog was opened.

3. When you're finished customizing Layer Sets, clickOK to confirm the changes and
close the dialog.

To link Layer Sets to Saved Plan Views

Layer Sets should be linked directly to a Saved Plan View unless the Layer Set will be
used for 3D Camera views, Cross Section/Elevation views, CAD Details, Wall Details,
Truss Details, or in unison with the Reference Display. For more information on linking
Layer Sets to other types of views, please see the following section.




1. Navigate to Tools> Active View> Edit Active View B‘ or right-click on the desired
plan view in the Project Browser , then choose Edit View.

New Saved Plan Views can be created by navigating to Tools> Active
View> Save Active View As, or by right-clicking on the Plan Views folder
in the Project Browser and selecting "New Saved Plan View."

On a Mac, hold down the Control key while clicking to initiate a right-
click command. More information about right-click commands on Apple
input devices can be found in the following Apple resource: Right-click
on Mac (https://support.apple.com/guide/mac-help/right-click-
mh35853/mac).

Project Browser n

v B Smith.plan

= CAD Details

[~ Cameras

[~ Cross Sections

[~ Floor Levels

[ Materials Lists

v [=7 Plan Views
*“" Warking Plan View
H Electrical Plan View Open View
i Floor Plan View Dimensioned Save View
= Fleor Plan View Shell Close View
i Framing, Ceiling Plan View Edit View... I},
= Framing, Fleor Plan View Delete

(o Framing, Roof Plan View
H Kitchen and Bath Plan View
Ho Mechanical Plan View
H Plot Plan View
Ho Roof Plan View
H Terrain Plan View

[~ Schedules

= Wall Details

Update Preview(s)

O

Send to Layout...
Rename F2

Duplicate...

2. On the SELECTED DEFAULTS panel of the Plan View Specification that displays,
select the the Layer Set drop-down to designate which Layer Set you'd like to link to
the plan view. In most cases, you will want to have a different Layer Set associated
with each different plan view.


https://support.apple.com/guide/mac-help/right-click-mh35853/mac

General

‘Selected Defaults

Reference Display

[™ Plan View Specification for " Working Plan View"

Default Set

Currently Using: Plan Default Set ~ lt”
Selected Defaults
Dimensions: Plan Dirmension Defaults ~ —I—
Rich Text: Plan Rich Text Defaults ~ —I—
Text: Plan Text Defaults w —I—
Revision Cloud: General Revision Clouds w~ —I—
Callouts: Plan Callout Defaults w~ —I—
Markers: Plan Marker Defaults ~ —I—
Motes: Plan Mote Defaults ~ —I—
Arrows: Plan Arrow Defaults ~ —I—
Layers
Layer Set: Working Layer Set %j
Current CAD Layer: | CAD, Default ~

<5
[

| | | | | | s
XXX XXX XX

Define...

Define...

Cancel

Help

3. Click OK to close the dialog. Now, the Layer Set and the Saved Plan View will be

linked.

To link Layer Sets to other types of views

When a view other than a Saved Plan View is created, you may notice that it is also

linked to a Layer Set. For example, when a Cross Section/Elevation view is created, the

Section View Layer Set is used for that view by default; when a Framing Overview is

created, the 3D Framing Layer Set is used by default. These can be managed and setup
to your liking by accessing the Default Settings.

1. Navigate to Edit> Default Settings @ click on Layer Sets, then click Edit.

2. In the Layer Set Defaults dialog, notice the Layer Sets that are setup for each

particular type of view.




I™ Layer Set Defaults
CAD Details: iCAD Block Detail Set P Define...
CAD Block Details: | CAD Block Detail Set W Define...
Plan Foeotprints: Plan Footprint Layer Set i Define...
Reference Display: | Reference Display Layer Set i Define...
Wall Details: Detail Layer Set i Define...
Truss Detail: Detail Layer Set i Define...
Cancel Help

3. Make any desired changes, then click OK.

We don't recommend using the same Layer Set between a Saved Plan
View and a different type of view. For example, don't link the "Working
Layer Set," which is connected to the "Working Plan View," to any other
type of view listed in this section.

4. Staying within the Default Settings dialog, expand the Camera Tools category,
select each camera tool, either all at once, or one-by-one, then click Edit.

5. On the SELECTED DEFAULTS panel of the Camera Defaults dialog that displays,
specify your desired Layer Set to be used.

-\"1 Full Camera Defaults

Camera Default Set

Pesitioning - (Lh 7
Currently Using: | Plan Default 5et ~
Below Grade Y ? L qjl

Selected Defaults
Plan Display .
Backdrop Motes: Plan Mote Defaults w —I— . ><
Layer
Label Layers

Selected Defaults

Layer Set: Carnera View Layer Set e Define...

6. Once all desired changes are made, click OK and Done to close the dialogs.




To use Saved Plan Views to switch Layer Sets

Saved Plan Views are linked to Default Sets, Layer Sets, and a variety of other settings
in any given plan. With this mind, Chief Architect makes it easy to switch between all of
these various settings simultaneously with a single click.

1. Access a plan view that you want to switch the Layer Set for.

2. Onyour toolbar, look for the Saved Plan View Control drop-down, click on it once,
then select a different Saved Plan View from the list. You can also switch between
Saved Plan Views by accessing the Project Browser side window.

oy K1) E)[@p Electrical Plan View V= W

Mone

Working Plan View

?ﬁ’p Electrical Plan View
Flocr Plan View Dimensioned i}
Floor Plan View Shell

Framing, Ceiling Plan View

Framing, Floor Plan View
Framing, Roof Plan Yiew
Kitchen and Bath Plan View
Mechanical Plan View

Plot Plan View

Roof Plan View

Terrain Plan Yiew

When you switch between Saved Plan Views, the Layer Set should also change if it's
setup to do so.

For demonstration purposes, you can see that the image below shows that the
Layer Set matches the Saved Plan View, as they are linked.

E-'p Electrical Plan View e IE-'L Electrical Layer Set ~

Note: If changing the plan view does not also change the active Layer Set, the
plan view may not be setup to change, or it's not linked correctly to the view.
Please refer to the first section in this article or view the Related Articles

section to learn more.



To use the Active Layer Display Options to switch Layer Sets

The Active Layer Display Options is a side window that is typically docked beside the
Project Browser and Library Browser. This side window allows you to see and make
layer-related changes on the fly for the view that's active. The Layer Set can also be
switched here if it's displayed.

1. Access a view that you want to switch the Layer Set for.

2. If the Active Layer Display Options is not displayed, navigate to View> Active Layer
Display Options [ to turn on the display of this side window.

3. Click the Settings button at the bottom of this side window and enable theLayer
Set Control option to be displayed if it's not already.

"  Layer Set Control
Layer Management

~  Layer Mame Filter
Layer Edit Buttons

~  Layer Properties
Show All Layers

Columns r

&

4, With the Layer Set Control now displayed, the Layer Set can be switched for the
active view.

If you use the Active Layer Display Options to switch the Layer Set while
a Saved Plan View is active, you should be in the "Working Plan View" or
you should have the intention of switching back to the Layer Set you
want to be linked with the currently active plan view.



To export and import Layer Sets

If have created or customized your Layer Sets, you can transfer them to other plan
files by exporting and importing them.

1. In the plan file where you created or customized Layer Sets, select File> Export>
Export Layer Sets g from the menu or navigate to Tools> Layer Settings> Layer

Set Management ({4, and click on the Export button.

All layers in the file will be exported to a .layers file no matter which method is
chosen.

2. Inthe Export Layer Set File dialog, type a short, descriptive Name and choose an
easy-to-find location on your computer such as the Desktop or Documents, then
click OK.

3. Open U a plan file in which you would like to use your custom Layer Sets, select
File> Import> Import Layers Sets Z- from the menu or navigate to Tools> Layer

Settings> Layer Set Management @ﬁ and click on the Import button.

4. In the Import Layer Set File dialog, browse to the location where you saved your
file in Step 2 above, select it, and click the Open button.

5. In the Import Layer Sets dialog which opens next, browse through the list of Layer
Sets and select the Layer Set(s) that you would like to import into the current plan.



™ Import Layer Sets x

Select layer sets to import:

All Layers OFF A
L All Layers ON !
[l Working Layer Set

[] 3D Framing Layer Set

[] CAD Block Detail Set

[] Camera Clay View Layer Set

[] Camera View Layer Set

[] Detail Layer Set

[] Electrical Layer Set

[] Floer Plan Dimensioned Layer Set

[] Floer Plan Shell Layer Set v

Select 4All Clear All

Existing Layer Sets
(® Replace

(0 Create a new copy

QK Cancel Hel
BN :

o Choose whether you want to Replace existing Layer Sets that have the same
name or to Create a new copy.

If you're importing Layer Sets that have the same name as existing Layer Sets
already present in the file, and you choose the Create a new copy option, the
new, imported Layer Sets will have a number appended onto the name.

o Click OK to close the dialog and import the selected Layer Sets.

To modify all Layer Sets in a file

In most cases, you will want changes that you make to a given Layer Set to affect only
that individual set. Occasionally, though, you may find it helpful to apply a particular
change to all Layer Sets in a plan.

1. Select Tools> Layer Settings> Display Options [/| from the menu.

2. Inthe Layer Display Options dialog that opens, check the box beside Modify All
Layer Sets.



3. Make any changes that you want to any layer(s) that you would like reflected in
every Layer Set located in the file.

4. Uncheck the box beside Modify All Layer Sets once you're done making changes,
then click OK to apply the changes to all Layer Sets in the file.

Return To Top

Related Articles

# Customizing Toolbars (/support/article/KB-00811/customizing-toolbars.html)

# Displaying the Active Layer Set Control on the Toolbar or in the ALDO
(/support/article/KB-03122/displaying-the-active-layer-set-control-on-the-toolbar-or-
in-the-aldo.html)

# Message: This new layout box references the "Layout Set 1" layer set saved in your

plan. (/support/article/KB-00939/message-this-new-layout-box-references-the-layout-

set-1-layer-set-saved-in-your-plan.html)

# Understanding Default Sets (/support/article/KB-01167/understanding-default-
sets.html)

# Understanding Layers (/support/article/KB-03183/understanding-layers.html)

# Understanding Saved and Active Defaults (/support/article/KB-03184/understanding-
saved-and-active-defaults.html)

# Understanding Saved Plan Views (/support/article/KB-03185/understanding-saved-
plan-views.html)
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