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QUESTION

| have an image on my computer that | would like to use in my plan as a
material or | would like to create a custom material that can be applied
to 3D objects. How do | do this?
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ANSWER


/

Materials in Chief Architect have two primary attributes that determine
what they look like in 3D views: patterns composed of CAD lines, and
textures which are created using image files such as .jpg's or .png's. A
new material with both a custom pattern and texture can easily be
created in the User Catalog, which is located in the Library Browser.

If you want to import a new material that will be tiled seamlessly across
a surface, make sure that the image that will be used will line up
accurately to look realistic for 3D camera views.

In X17 and newer, you can also use the Material Builder to create a new
custom stone, masonry, tile, or wood material.

Additional information on materials can be found in the

Materials: Patterns & Textures
(https:.//www.chiefarchitect.com/videos/playlists/170/materials-
patterns-textures.html) Video Playlist, as well as the Materials
(https://www.chiefarchitect.com/support/category/8/materials.html)
Knowledge Base category.

To create a new material through
the Define Material dialog

1. If the Library Browser is not already open, navigate to View>
Library Browser [ffi.

2. Right-click once on the User Catalog folder and select New>
Material from the contextual menu that displays.


https://www.chiefarchitect.com/videos/playlists/170/materials-patterns-textures.html
https://www.chiefarchitect.com/support/category/8/materials.html

Note: On a Mac, hold down the Control key while clicking to
initiate a right-click command. More information about right-
click commands on Apple input devices can be found in the
following Apple resource: Right-click on Mac

(https://support.apple.com/guide/mac-help/right-click-
mh35853/mac).
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If you would like to add a new material to a folder or
subfolder in your User Catalog, right click on the desired
folder and select New> Material.

3. The Define Material dialog will open.

The settings on the PATTERN panel control how the material will


https://support.apple.com/guide/mac-help/right-click-mh35853/mac

appear in the Vector View, Technical lllustration, and Hand Drawn
Line rendering techniques. When the Hand Drawn Lines on Top
setting is enabled within the Standard, Physically Based, Clay, or
Watercolor rendering techniques, pattern lines are also used.

™\ Define Material

Pattern Material Mame: Gray Slate Wall
Texture
Properties
Materials List

Keep Pattern/Texture in Sync

Colors

Material Color: _

Line Color:

Line Weight: 0

Shading Contrast: 31%

Pattern
Pattern Type: Mo Pattern w Library...
Pattern From Texture...
Scale
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Retain Aspect Ratio

Offset and Angle
Row Offset: 1/
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Horizontal Offset; 0"
Vertical Offset; 0"

Angle:

Global Symbol Mapping

o Specify a Material Name.

o If desired, choose a Material Color and a Pattern Type using
either the drop-down menu or clicking the Library button.



Note: You can manually create a custom pattern, or a
custom pattern can be automatically generated based
upon a texture image by clicking the Pattern From Texture
button. However, it's recommended to only select this
option after a texture image is specified for the material,
which is discussed in the next step.

4. The settings on the TEXTURE panel control the appearance of the
material in the Standard, Physically Based, Watercolor, and Duotone
rendering techniques.



™\ Define Material

Pattern

Texture

Properties
Materials List

Material Mame: Gray Slate Wall

Keep Pattern/Texture in Sync

Texture Source
Mame:

Scale
X Scale 20 Stretch to Fit
Y Scale: 20 Stretch to Fit

Retain Aspect Ratio

Reset Criginal Aspect Ratio

Offzet and Angle
Horizontal Offset; 0
Vertical Offset: 0

Angle: 0.0

Global Symbol Mapping

Material Color

Blend with Texture

Color _ Set Using Texture

Burnp Map
Mame:
5 0.01

Scale; 0.0

[vert

Meormal Map

Mame:

Ambient Occlusion Map

Marme:

Mo Texture
Import.. |*
Import... [+
Import... |«

o In the Texture Source section click Import and browse your
computer for the image that you'd like to use as a custom

material.

If you see Select instead of Import, either click Select to choose
an image from your Asset Management, or click the dropdown
next to Select and choose Import.

If using Traditional File Management or using X16 and prior,



click the Browse button next to Texture Source File and
browse your computer for the image that you would like to use
as a custom material.

If using Traditional File Management and you see Edit Path
instead of Browse, click the dropdown next to Edit Path and
choose Browse.

o Once it's specified, adjust the Scale and Offset and Angle
settings to your liking.

For more information on each of the options listed
here, click on the Help button at the bottom of the
dialog box to open your software's documentation.

5. The settings on the PROPERTIES panel control how materials appear
in most rendered 3D views.



™\ Define Material

Pattern Material Mame: Gray Slate Wall
Texture
Properties Material Class: General Material >~
Materials List -
] Metallic
Thin
Diffuse: I 100%
Specular: I 30%
Roughness: I 40%
Roughness Map: Invert | Import...
Transparency: I 0%
Opacity Map: Invert | Import...
Emnissive Map: Invert | Import..
Emissive: 0 (Mot Emissive) el 1) =
(] Apply Emissive and Color from Light(s)
Material Class Mix
Metal Map: Invert | Import...
Translucent Map: Invert | Import...
Transparent Map: Invert | Import...
(] Clear Coat
[ Brushed

Note: To learn more about material properties, please view

Video 83: Advanced Materials

(https://www.chiefarchitect.com/videos/watch/83/advanced-

materials.html).

. The settings on the MATERIALS LiST panel control how the material is

counted in the Materials List.

Once all desired changes have been made, click OK to add the

material to the User Catalog.


https://www.chiefarchitect.com/videos/watch/83/advanced-materials.html

You can also click the Add to Library button to add the material to
the User Catalog without closing the dialog box. This allows you to
add several material variations to the library without the need to
create copies beforehand.

Your new material is now available for use in any plan.

To create a new material using the
Material Builder*

*Applies to versions X17 and newer.

1. Select 3D> Material Builder ¢z to open the Material
Builder dialog.

2. At the top of this dialog, click Select Builder to select a material
builder:



™ Material Builder
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o The Chief Architect Masonry and Stone Builder is helpful for
creating various stone materials that can be used for stone walls

or terrain pathways.

o The Chief Architect Tile Builder is helpful for creating various
tile materials with custom configurations, colors, and grout

styles.

o The Chief Architect Wood Builder is helpful for creating
various wood materials that can be used for flooring, ceilings, or



3D objects

o You can also Select External Substance (SBSAR) Files that you
may have downloaded from the internet. This allows you to
utilize other SBSAR files that aren't provided by Chief Architect.

3. Once you're done customizing your material, you can decide how
it's added to your library:

o Underneath Maps Included in Material, you can choose to
include/exclude the Texture, the Normal map, the Roughness
map, and the Metal map.

o Fill out the Material Name, as this will be the name of the
material once added to your User Catalog.

o Adjust the Material Scale to your liking.

o Check the Open Material When Added to Library checkbox if
you'd like to open the Define Material dialog once added to
your User Catalog.

The Material Name and Material Scale can always be
customized after the material is added to the User
Catalog. For more information, please see the Related
Articles section below.

Note: To learn more about this feature please see your
software's Help documentation, or see our Custom Tile &
Materials - New Material Builder



https://www.chiefarchitect.com/videos/watch/10301/custom-tile-materials-new-material-builder.html

(https://www.chiefarchitect.com/videos/watch/10301/custom-
tile-materials-new-material-builder.html) video.

4, Once your material is completed click the Add to Library button to
add it to your User Catalog.

MORE INFORMATION

e Materials can also be created within the Plan Materials dialog by
navigating to 3D> Materials> Plan Materials 4, by copying/pasting
images that are located on your system's clipboard by navigating to
Edit> Pate> Paste [, as well as when using the Capture Screen
tool by navigating to Tools> Screen Capture> Capture Screen [5|.
For more information on these various options, please access the
"Creating Materials" section in your software's Reference Manual
(https://www.chiefarchitect.com/support/documentation.html?
version=25).

e |n 3D views, you can create a new material by blending a solid color
such as a paint color with a textured and/or patterned material.
Select 3D> Material Painter> Blend Colors With Materials to
toggle this feature on or off. The result is a new material that is
saved in the current plan. It can be found in the Plan Materials
dialog, edited as needed, and added to the library if desired.

Materials created using this tool are given the name of the
patterned/textured material with the extension “--PAINTED.”
followed by the name of the solid color material.

e Materials often have a texture and one or more material maps,
which are images files that add realism to the material's
appearance. In order to display a material's texture and material


https://www.chiefarchitect.com/support/documentation.html?version=25

maps, Chief Architect needs to be able to locate the image files
associated with them on your computer.

If a texture or material map referenced by a newly created material
is not located in either the Chief Architect program's Data folder or
the installation folder for the program’s library textures, a copy of
the file will be made in Chief Architect program's Data folder, and
the material will reference that copy.

When the Adjust Material Definition 4 tool is used with any
scoping mode other than Plan Mode, the program will prompt you
to choose whether to edit the original material or create a copy of it.

In X17 and newer versions, a material's texture can be edited in real
time in camera views by navigating to 3D> Adjust Materials>
Interactive Material Editor 9V, and then clicking on the material in
your camera.

An entire folder of textures can be converted into a library of
materials. Select 3D> Materials> Convert Textures to Materials
Tgi and then browse to a folder of textures on your computer. The
converted library folder assumes the same file structure as the
original folder. Materials created using this tool do not refer to the
original folder of texture files. Instead, they refer to files copied into
the Data folder like individually-created materials do.

Select 3D> Materials> Create Plan Materials Library [g: to create
a library of materials based on the materials used in the current
plan. This is useful for converting material template plans, a
common way to store material definitions in prior versions of Chief
Architect, into a materials library. This command creates a new
library in the Materials category using the same name as the plan.
Adding materials to the library individually allows you to store the
material within the existing directory structure.



Related Articles

#Blending Colors with Materials (/support/article/KB-00004/blending-
colors-with-materials.html)

# Changing the Direction of a Material's Pattern and Texture
(/support/article/KB-00194/changing-the-direction-of-a-material-s-
pattern-and-texture.html)

# Customizing a Library Material (/support/article/KB-
01006/customizing-a-library-material.html)

#Importing and Applying a Custom Picture to a Frame, Computer, or
TV Screen (/support/article/KB-00007/importing-and-applying-a-
custom-picture-to-a-frame-computer-or-tv-screen.html)

# Incorporating Custom Colors (/support/article/KB-
00730/incorporating-custom-colors.html)
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