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QUESTION

How can | customize my toolbars to improve my workflow?

ANSWER

You can increase your productivity by customizing various settings relating to your
toolbars. This article will explain how, including:

® (Creating and switching between custom toolbar configurations
e (Creating custom toolbars

e Using the Place Library Object tool

e Using the Child Tool Palette setup

e Changing the toolbar button size

e Backing up toolbars

Creating and switching between custom toolbar configurations


/

1. Launch Chief Architect and create aNew Plan D

2. Select Tools> Toolbars and Hotkeys> Customize Toolbars|# | from the menu.

In Home Designer Pro, navigate to Tools> Toolbars> Customize Toolbars | 4 |.

3. Onthe Configurations panel of the Toolbar Customization dialog that displays:

[™ Toolbar Customization >
Tools Toolkar Configurations
Toolbar Active Configuration:  Extended Tool Cenfiguration
- Default Configuration Switch To
Extended Tool Configuration
Space Planning Configuration
Terrain Configuration Remave
Impart...

Current Toolbars Folder: C:/Users/Josh/Documents/Chief Architect Fremier X135 Data/Toolbars/

Close Help

o C(lick on a configuration in the list that is most similar to the custom configuration
that you would like to create.

o With a configuration selected, click the Copy button.

4. In the New Toolbar Configuration File dialog:

_‘\1 Mew Toclbar Configuration x

Mew Mame: |Cusb:um Configuration

Cancel Help




o Type a short, descriptive name for your new configuration, then click OK.

o Your new configuration is added to the Toolbar Configuration list and is also
specified as the new Active Configuration.

5. Select the configuration you would like to have active from the list and use the
Switch To button to change to it. When you click the Close button, your new
configuration will be in use.

You can also switch configurations using the toolbar buttons or by right-clicking any
toolbar and selecting the configuration under Toolbar Configurations.

6. With your new toolbar configuration active, make any desired changes to the
program toolbars.

o Existing toolbars can be moved so that they dock to the top, bottom or either side
of the Chief Architect program window, or they can float within the view window.

o You can add or remove buttons on existing toolbars or create entirely new
toolbars using the Customize Toolbars dialog.

o You can customize the toolbars in all views - not just floor plan view.

7. When you are satisfied with the organization of your toolbars, selectFile> Exit from
the menu to close Chief Architect completely.

Closing the program will save your changes to the toolbar configuration made
during this program session in the .toolbar file created in Step 4, above.

If you have made changes to an existing toolbar configuration, such as the
Default Configuration, it is a good idea to make a copy of it. Creating a
custom copy will help you protect your customization's should you need to
reinstall the program or restore your toolbar defaults.



Creating custom toolbars

1. Select Tools> Toolbars and Hotkeys> Customize Toolbars |4 | from the menu.

In Home Designer Pro, navigate to Tools> Toolbars> Customize Toolbars | 4 |.

2. Onthe Tools panel of the Toolbar Customization dialog, select an option using
the View Type drop-down.

o Your selection will determine not only what buttons are available in the Toolbar
Buttons list, but also what view types your custom toolbar will be present in.

™ Toolbar Customization >
Tools View Type
Toolbar Plan —

Configurations :
Availak fleyation t} |

30 View

Material

CAD Detail bols .
Layout efaults...

Ray Trace .

Dashboard laterial Tools

1y Active Default Set Control

[lI:P/ Active Defaults...

% Active Dimension Defaults Control
@L Active Layer Set Control

Active View Tools ]

Tool Description

3. Still on the Tools panel, browse the list of Available Toolbar Buttons and click on
a toolbar button that you would like to add to your custom toolbar.

o A description of the tool's use displays under the available buttons list.



o If the selected button is a Parent Tool you will see a small arrow > displayed to

the left of the name which can be used to expand the list of associated Child
tools.

Note: If you are still unable to locate a particular tool, it may be that the
feature you are looking for is actually an Edit tool, which will only be available
on the Edit Toolbar when it can be applied to a selected object.

4. Click on a button in the list, hold down your left mouse button and drag the selected
button outside of the Toolbar Customization dialog box.

o If you drag the toolbar button to an existing toolbar, the button will be added to
that toolbar when you release your mouse button.

o If you drag the toolbar button into the drawing area, a new toolbar will be
created and the button will be placed in that toolbar.

g
m

o This toolbar can be dragged and docked to the top, bottom or side of the Chief
Architect drawing area, or it can remain floating.

o Similarly, you can dock or undock existing toolbars to customize their locations as
you wish at any time.

5. Continue adding toolbar buttons to your new toolbar as desired.

Custom 4ll Elevatinn...n
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6. To remove an item from the toolbar, click and drag the item from the toolbar and
drop it into the Toolbar Customization dialog.



7. To rename the toolbar, select the Toolbar panel of the Toolbar
Customization dialog, select the toolbar from the list, and then click once on the

name to rename it.

[™ Toolbar Customization x
Tools View Type
Toolbar Plan
Configurations
Toolbars
Toolbar Name Plan Elevation 3D View Material CAD Detail Layout Ray Trace Dashboard ™
Active Default... \/ \/
Active Layer 5. v
Active Saved ... \./
Annotate v v v v
Arc Creation ...
Architectural ... \./ \./ q"r v'"
Cameras and ... \/ \/ \/ J
Custarm All ElevationsTu:u:uIbarl --_--_
Edit Modes
File .. v v v v v v v
Floor Up/Down  + v v
Layout 4
Materials List v'"
Page ... 4
Ray Trace 4 W
Delete Reset Toolbars

8. Also on the Toolbar panel, you can choose which views you wish to see this toolbar
in, by simply placing checkmarks in the appropriate columns.

Using the Place Library Object tool

The Place Library Objectﬁul_ tool can be added to the toolbar and customized to
place a symbol from the library.

1. Place the Place Library Objectﬁﬂ | tool on a toolbar by dragging it from the Toolbar
Customization dialog on to the toolbar of choice.



Tools
Toolbar
Configurations

[™ Toolbar Customization

View Type

Plan ~

Available Toolbar Buttons

Search: |p|ace

gﬁ Library Object Painter Object Mode
g?ﬁ Library Object Painter Plan Mode
E{.ﬁ Library Object Painter Room Mode
c:'ﬁ Material Painting Modes

2| Place Library Object |

><_ Paoint Tools .

4,
font Replace Fonts

B Road Tools

Tool Description

Click to place the assigned library object.

Close

Help

2. Click the Close button to close the dialog.

3. Using the Select Objects [Q- tool, click the Place Library Objectﬁﬁ | tool that was
just placed to open the Library Object Button Specification dialog box.

4. Click the Library button to open the Select Library Object dialog.




™ Library Object Butten Specification x

Likrary Object

Mone Selected
—

Button Mame

Button lcon Choices

ﬁﬂL Default Image

Browse...

Cancel Help

5. Navigate through the library to the symbol you want to place using this tool. select
it, then click OK.

In this example, we have selected the Composting Toilet.



Select Library Object O >
ny )

Filters b 4
Type to start searching... | 4 ) i‘
Folders »
E Partitions
E Showers
(] Sinks
v (] Toilets
Bidet

B Composting Toilet
Corner Toilet

Elongated Back Drain Toilet W
Details X | Preview x
Fs A = ‘_ |
Composting Toilet E Li
Type: Fixtures Interior

Catalog: Core Architectural

Folders: Architectural/Plumbing

Fixtures/Toilets A-"'
Tags:
Motes:
W
Toolbar

& g

Cancel Help

6. Back in the Library Object Button Specification dialog, choose your desired
Button Icon, then click OK to return to the plan.



™ Library Object Butten Specification x

Likrary Object

Library... = Composting Toilet

Button Mame

|C|:|mp|:|5ting Toilet

Button lcon Choices

uﬁL Default Image
iﬂ“ Automatic 1

. Automatic 2

Browse...

Cancel Help

This tool is now linked to the Composting Toilet symbol located in the library and can
be selected anytime to place this object in your plan.

Using the Child Tool Palette setup
1. Launch Chief Architect and create aNew Plan D

2. Select Edit> Preferences (3p|if you're on a Windows PC or Chief Architect>

Preferences |;|p| if you're on a Mac.

3. Select the Appearance panel of the Preferences dialog, and under the Toolbars
section, move the radio button to Child Tool Palette, then click OK.



-\1 Preferences

~ Appearance
Colors
Library Browser
Text
Pattern Editor
v General
File Management
Folders
Ruby
Mew Plans
Unit Conversions
Time Tracker
Architectural
CAD
v Edit
Coordinate System
Behaviors
Snap Properties
Master List
¥ Render
Ray Trace
Video Card Status
Reset Options

Contextual Menus
[ Click Twice to Display

Status Bar
] Show Screen Redraw Time

Show Coordinates

Line Weights
[ Show Line Weights

Minimurmn Display Weight: I:| Pixels

Display

Images and Pictures: O Display in Color when Possible

Menus: Show lcons
Color Off is: {® Black and White
O Grayscale

Dialog Previews

(O Standard
® Vector View
Toolbars
Drop Down
Scale Toolbar lcons for High DPI
Button Size: Pixels (Sizing Will Update on Mext Launch)

Note: If the Tool Palette doesn't open automatically, navigate to View> Tool

Palette from the menu.

Changing the toolbar button size

1. Select Edit> Preferences ||| from the menu if you're on a Windows PC, orChief

Architect> Preferences [3p| if you're on a Mac.

2. Onthe Appearance panel of the Preferences dialog, under the Toolbars section,
change the value to the right of the Button Size field, then click OK. The higher the
value entered here, the larger the Toolbar buttons will be.

In this example, the Button Size was changed from 20 pixels to 40 pixels.
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Preferences

b

Appearance

Colors

Library Browser

Text

Pattern Editor
General

File Management

Folders

Ruby

Mew Plans

Unit Conversions

Time Tracker
Architectural

Contextual Menus

Status Bar

Line Weights

Minimurmn Display Weight:

[ Click Twice to Display

] Show Screen Redraw Time
Show Coordinates

[ Show Line Weights

CAD Display
v Edit Images and Pictures: O Display in Color when Possible
Coordinate System
Behaviors Y Menus: Show lcons
Snap Properties Color Off is: {® Black and White
Master List
v Render O Grayscale
Ray Trace Dialog Previews
Video Card Status
Reset Options O standard
®) Vector View
Toolbars
® Child Tool Palette
O Drop Down
Scale Toolbar lcons for High DPI
Button Size: 4[1”: Pixels (Sizing Will Update on Mext Launch)

3. When you relaunch the program, the change in button size will take effect.
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Note: An increase to the toolbar button size may result in tools no longer
fitting on your toolbar. Such toolbar buttons can be viewed by clicking on the
double arrow icon on the far right of the toolbar.

After making modifications to your toolbars, you may want to back them up for
transfer to another computer, or in the case a computer or program malfunction
occurs.



Backing up toolbars

The toolbars, as well as other user-specific data, is saved in the Chief Architect/Home
Designer Data folder, which is located in the Documents directory by default. This Data
folder will begin with the full name and version of your Chief Architect/Home Designer
program followed by the word Data - for example, "Chief Architect Premier X15 Data"
or "Home Designer Pro 2024 Data."

The default file path for this folder on Windows may be one of the following, but may
also vary depending on your product and version:

C:\Users\ [ YOUR USERNAME ] \Documents\Chief Architect Premier X15 Data
C:\Users\ [ YOUR USERNAME ] \Documents\Home Designer Pro 2024 Data
And on macOS:

/Users/ [ YOUR USERNAME ] /Documents/Chief Architect Premier X15 Data

/Users/ [ YOUR USERNAME ] /Documents/Home Designer Pro 2024 Data

If you have moved your Chief Architect/Home Designer Data folder to a
custom file location, refer to the location you have moved it to instead.
You can confirm the location of your Data folder in the Preferences dialog.
On the Folders panel, take note of the file path next to the "My Data
Folder" or "Data Folder for Current User" heading.

1. Close the Chief Architect/Home Designer program.

2. Browse into the Data folder for your program version and locate the "Toolbars" sub-
folder.

3. Right-click on the "Toolbars" sub-folder and select Copy from the contextual menu.



On a Mac, hold down the Control key while clicking to initiate a right-
click command. More information about right-click commands on Apple
input devices can be found in the following Apple resource: Right-click
on Mac (https://support.apple.com/guide/mac-help/right-click-
mh35853/mac#).

4. Navigate to the location in which you want to backup your toolbars to, then right-
click and select Paste.

Note: For safety's sake, it is best to use a strategy that utilizes a backup
location somewhere other than your local computer. Options include
removable storage devices such as a USB flash drive or external drive, a server
or location on your network, or an online cloud storage service.

5. To restore the backed up "Toolbars" sub-folder, simply copy/paste the folder back
into your program's Data folder, ensuring that the original name is intact.

Do note that two folders with the same name typically can't exist alongside each
other, so you may have to overwrite the default "Toolbars" sub-folder that the

program generates automatically. Take caution as any data that's overwritten will be
lost and can't be retrieved.

Related Articles

# Backing up Chief Architect Content (/support/article/KB-00001/backing-up-chief-
architect-content.html)

# Customizing Hotkeys (/support/article/KB-00238/customizing-hotkeys.html)

# Restoring Chief Architect Content (/support/article/KB-00091/restoring-chief-
architect-content.html)

# Troubleshooting Missing Toolbars (/support/article/KB-00467/troubleshooting-
missing-toolbars.html)
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