Creating a Custom Sail Shade


Reference Number: KB-00842
Last Modified: May 18, 2016

The information in this article applies to:

Chief Architect Premier


QUESTION

How can I create a custom shaped sail shade in Chief Architect?




ANSWER

A custom sail shade can be created by utilizing Chief Architect's terrain or roof tools. Both methods will be discussed in this article. 


Creating a custom sail shade using the roof tools

  1. Select Build> Roof> Roof Plane, then left click and drag in the plan to draw a manual roof plane. In this example, a roof plane was drawn and then its edit handles were manipulated to create a triangular roof plane.



  2. Select the Roof Plane and then click the Open Object  edit button to open the roof plane's specification dialog.



    In the Roof Plane Specification dialog, modify the pitch and curve of the roof plane to shape it like a sail shade. In this example a pitch of 4" was used, Curved Roof was checked, and Angle at Eave was set to 0.0°.

  3.  In the Options panel of the Roof Plane Specification dialog, uncheck Gutter.

  4. In the Structure panel, uncheck Gable Fascia and Eave Fascia



  5. Click Edit to the right of Surface, delete all but one layer, then set the last layer's thickness to 0". 

  6. Click Select Material, select Opening (no material), which can be found under Core Catalogs> Materials> Insulation, and then click OK, and OK.

  7. Click Edit to the right of Structure, delete all but one layer, then set the last layer's thickness to 1/16". Click Select Material, and then select a color for the sail shade, and click OK until back in the plan. In this example, the material Color - Red is used.



  8. Select 3D> Create Perspective View> Perspective Full Overview  to create a 3D view and see the result.



  9. The roof plane can now be used as a sail shade in your plan, or if the roof plane was drawn in an otherwise empty plan, you can convert the roof plane into a symbol by following the steps outlined in the section To create a symbol out of the sail shade object.


To create the shape

  1. Select CAD> Boxes> Rectangular Polyline  , then click and drag out a rectangular polyline in a blank plan. 



  2. To reshape the Rectangular Polyline, use the Select Objects  tool to select it, then use its edit handles, along with the Break Line  and Change Line/Arc  edit tools to create the desired shape for the Shade Sail. 



  3. Once the shape is finalized, use the Select Objects  tool to select the CAD polyline, and then click the Convert Polyline  edit button to display the Convert Polyline dialog. 

  4. Move the radio button to Terrain Perimeter and click OK to display the Terrain Specification dialog.  



    Note: If the Terrain Perimeter option is greyed out, then the template that you started this new plan from must have already had an existing Terrain Perimeter in it. Locate and remove this terrain perimeter to continue.


To add elevation points at each corner of the sail at the height you will attach it.

  1. Select Terrain> Elevation Data> Elevation Point  and click to place an elevation point, setting the appropriate value for each corner.  



    For the purposes of our rectangular example, we set the upper right and lower left elevation points to 10' and the bottom right and upper left elevation points to 5'.


  2. Now that the elevation points are set, use the Select Objects  tool to select the terrain perimeter and click the Copy and Paste in Place  edit button.  


  3. With the copy now selected, click on the Convert to Plain Polyline  edit tool to convert it to a plain polyline.  


  4. Next, with the plain polyline still selected, click the Convert Polyline  edit toolbar button again to display the Convert Polyline dialog. This time, select the Terrain Feature option and click OK.  




  5. The Terrain Feature Specification dialog will display. Select the Line Style panel, use the drop down menu to change the Layer to CAD, Default, and click OK.  




  6. Select 3D> Create Perspective View> Perspective Full Overview  to create a 3D view.  




  7. Select Tools> Layer Settings> Display Options  to display the Layer Display Options dialog for the Camera View Set.  


  8. Remove the check mark from the Disp column for the "Terrain Perimeter" layer and click OK.




  9. You should now see the shape of the sail shade.  




To create a symbol out of the sail shade object

  1. While still in the 3D view, select Tools> Symbol> Convert to Symbol  from the menu.  



  2. In the Convert to Symbol dialog, use the drop-down menu to select the symbol category of Fixture (Exterior), check Add To Library and Show Advanced Options, and click OK.  




  3. The Symbol Specification dialog will display.  

    On the 3D panel, specify the Symbol Name, such as Shade Sail.  



    In Chief Architect X2, check Double-Sided under Faces.  


  4. Click OK to complete these changes and add the sail shade to the Library Browser.  

  5. Right click the sail shade in the Library Browser and select Open Object if you would like to specify the Floor to Bottom value that the sail shade will default to when placed into a plan, and then click OK.

  6. You can then place this shade sail symbol from the Library Browser into future plans, as well as change its size, specify materials, etc.

We also offer a sail shade bonus catalog for Chief Architect X8 and newer, which can be found here.