Creating a Soldier Course

Reference Number: KB-00797
Last Modified: October 9, 2015

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors


How do I create a brick soldier course around a window and a sloped brick sill using the symbol moldings in Chief Architect? 


A soldier course is a set of vertical bricks lined up in a row with the narrow edge facing outward. These can be modeled in Chief Architect using a Symbol Molding.

In this article, we will walk you through:

  • Creating a brick and mortar symbol molding.
  • Creating a brick and mortar angled sill architectural block.
  • Creating an arched soldier course.

To create a basic brick with mortar

  1. Select File> New Plan  from the menu to open a brand new, blank plan file.  

  2. Select View> Library Browser  from the menu, then browse the Library to CAD Blocks> Detail Components> Brick and choose a brick style from one of the many  choices in this section.   

    • We will use this as a template for the size that will  be used during construction. If you have custom size, simply draw it using CAD tools.  

    • In this example, we will use "Engineer modular brick (depth)."

  3. Click the Select Objects  button, then click on the CAD block to select it and click the Explode CAD Block  edit button to break the block into its individual components.   

  4. Select the brick and mortar sections in turn and click the Convert Polyline  edit button to display the Convert Polyline dialog, then move the radio button to Polyline Solid and click OK to display the Polyline Solid Specification dialog.

  5. For the polyline solid which will be representing the mortar:

  • On the General panel, set the polyline solid's Elevation at Top to -1/4".

  • Set the Thickness to 3 1/8"

  • On the Materials panel, choose an appropriate material for your Mortar.
    For the purposes of this example, we will leave the mortar as the default Concrete material.

  • Click OK to apply these changes and close the Polyline Solid Specification dialog

  • For the polyline solid which will be representing the brick:

    • On the General panel, set the polyline solid's Elevation at Top to 0".

    • Set the Thickness to 3 5/8"

    • On the Materials panel, choose an appropriate material for your brick.
      For the purposes of this example, we set this material to one called "9645 Local Legend - 273 Brick Dust" from the Mohawk® manufacturer catalog.

    • Click OK to apply these changes and close the Polyline Solid Specification dialog

  • You should now have something that looks like the images below in 2D and a 3D camera views.


  • To create brick molding symbol

    1. Select 3D> Create Perspective View> Perspective Full Overview  from the menu to create a 3D view of the polyline solids making up the brick and mortar.

    2. Select Tools> Symbol> Convert to Symbol .

    • Choose the symbol category of Molding.

    • Check both Add to Library 

    • Check Show Advanced Options .

    • Click OK.

  • For use as a soldier course, you will need to rotate the symbol, so in the the Symbol Specification dialog:


    • On the 3D panel, under Rotation, move the radio button to Y, leave the Angle set to 90 degrees, then click Rotate + once.

    • Move the radio button to Z, leave the Angle set to 90 degrees, and click Rotate + once more.

    • After rotating the symbol, under Origin Offset, set the X, Y and Z Positions all to 0".

    • Give the symbol a descriptive name, then click OK to add it to your User Catalog.

  • Now that this molding has been added to your User Catalog, you will be able to use the Build> Trim> 3D Molding Line  tool with this molding applied in a Cross Section/Elevation  view to quickly create a soldier course around a door or window.

    A selection of Keystone symbols can be located in the Library Browser in the Architectural > Millwork folder.

  • Using the components we created earlier, we can also create a a sloped sill. Since we have already discussed how to use a symbol molding, for this section, we will instead walk through creating the angled sill as an Architectural Block, which can be added to the Library for use in future plans and exploded to make modifications to the individual solid objects so that there is not mortar left on the outside of one of the brick edges.

      To create an angled sill
      1. First, to rotate the brick and mortar components at an angle equal to the slope that you eventually want for the sill.

        In this example, we will create a slope of 1/4" in 12".  

      2. In order to rotate the polyline solids, we will need to convert each to a solid object. Select each of the objects and click the Convert to Solid  edit button.  

      3. Next, select 3D> Create Orthographic View> Cross Section/Elevation  from the menu, then click and drag a cross section camera arrow towards the components as shown below.  


      4. First, select the concrete solid which represents the mortar, then hold down the Control key and click on the solid which represents the brick to group-select them both.  The Status Bar should reflect "2 objects currently selected" near the lower left.

      5. Click on the triangular Rotate edit handle and while dragging the Rotate handle, press the Tab key on your keyboard to display the Enter Coordinates dialog.


        • Click the Num Style button, change the Angle Style to Pitch and click OK.  

        • Select Relative to Start and check the box beside Polar.

        • Specify the Distance as 3/8".

        • Specify the Angle as .25 in 12, then click OK.  

      6. Close the Cross Section/Elevation View to return to floor plan view.

      7. In floor plan, use the Select Objects  tool to drag a marquee around the two solids to group-select them, click on the Multiple Copy  edit button, then select the Multiple Copy Interval  edit tool.

      8. In the Multiple Copy dialog under General Objects, set the Primary Offset to 3 3/16" (the thickness of the solids representing the brick and mortar), click OK, then use the center edit handle to drag up or down and create several copies of the brick and mortar.

      9. Once you have the desired number of bricks copied, select the solid representing the mortar from the end and Delete  it.

      10.  Next, drag a marquee around all of the solids to group-select them, and click on the Make Architectural Block  edit tool.

      11. Finally, click on the Add to Library  edit button to add the block to your Library Browser so that you can use it in future plans, and explode it if needed to add or remove brick and mortar elements.

        You can also rename this Architectural Block to Angled Sill in your User Catalog to allow for easily finding it using the Library Search feature.

      A similar method can be used to create an arched soldier course over a round top window.

      To create an arched solider course

      1. Open the plan with the arched window you want to create a solider course over, then take a Cross Section/Elevation View  of the window.

      2. Select CAD> Arcs> Draw Arc , then draw in an arc matching the top of the window.

        You may find it helpful to change the color of this line so it is more easily visible in the view.  For the purposes of this example, we have changed the line to be an orange color.

      3. Next, select View> Arc Centers and Ends  to toggle the display of Arc centers on, then go to CAD> Points> Place Point  and click to place a temporary point where the Arc Center is located.

        You should then return to View> Arc Centers and Ends   to toggle the display of Arc centers back off.

      4. Next, select CAD> Boxes> Rectangular Polyline  and draw a rectangle that represents the top brick in the solider course.

        You may find it helpful to apply a Solid Fill to the polyline, as shown in the example above in red.

      5. Using the Select Objects  tool, select the CAD polyline and click on the Transform/Replicate  edit button.

      6. In the Transform/Replicate dialog:

      • Place a checkmark next to Copy and specify the number of copies of this polyline that you want to create.
        For the purposes of this example, we will use a value of 8.

      • Place a checkmark next to Rotate and set the angle.
        For the purposes of this example, a value of 5° works well

      • Under Rotate/Resize/Reflect About, move the radio button to About Current Point, then click OK.

    1. Now you will observe that you have rectangular polylines replicated along one side of the arc, as shown in the image below.

    2. Select the top rectangular polyline again and use this same method to replicate rectangular polylines along the right side, this time specifying a value of -5° for the Rotate value.

    3. Select the polyline furthest to the left, then hold down the Shift key on your keyboard and click to select all of the remaining rectangular polylines to group-select them.

    4. Click on the Convert Polyline   edit tool, move the radio button to Polyline Solid then click OK to display the Polyline Solid Specification dialog.

      • On the General panel, set the Thickness to 3 1/2" and click OK to complete converting all of these 2D CAD polylines in to Polyline Solid 3D objects.

      • On the Materials panel, set an appropriate brick material.

      • Click OK  to apply these changes.

    5. You may find it helpful at this point to minimize the Cross Section/Elevation view and take a normal Full Camera view of the design to see the progress thus far.


    6. Once you've created the polyline solids which represent your brick, you will need to create one more arched polyline solid to represent the mortar.

      To create an arched polyline solid

      1. From the Window menu click on the Cross Section/Elevation view listed near the bottom to reopen this view.

      2. Next, select CAD> Boxes> Rectangular Polyline  and draw a rectangular polyline over the polyline solids.

      3. Once created, use the Select Objects  tool to select the top of the new rectangular polyline, and click on the Change Line/Arc  edit button, then repeat this process on the bottom segment of the rectangular polyline so that you have an arc at the top and bottom, and two straight lines on either side.

      4. Using its edit handles, reshape this closed polyline so that it extends within the rectangular bricks, as shown in the image below.

      5. Once resized, click on the Convert Polyline  edit tool and convert this arched polyline in to another Polyline Solid.  

      6. As before, choose an appropriate Thickness and Material for the mortar and click OK.

      7. Finally, use the Shift key on the keyboard and click to select all of the polyline solids for both the brick and the motor, then click the Make Architectural Block  edit button to group all of these elements together.

      8. If you will frequently be needing an arched soldier course this size, you may also want to use the Add to Library  edit tool on the Architectural Block to add it to the Library Browser in the User Catalog for future use.

      9. Take a 3D camera view to see the results thus far.

      Using the tools and techniques discussed in this article, you should be able to create custom moldings symbols which can be applied directly to windows, doors, or 3D molding lines and polylines, create architectural blocks of polyline solids, and understand how to rotate objects to create angled brick sill or arched soldier course symbols.