Browse
Categories

Creating a Custom Molding Profile for an Exterior Door's Casing

Reference Number: KB-01144 Last Updated: 07-22-2014 02:59 PM

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors or Chief Architect Lite

QUESTION


How can I create a new ­molding for my exterior doors, apply it to a template plan so that I can use it every time I start a new plan, and add it to my library so that I can apply it to existing files?


ANSWER



To create the molding profile:

  1. First, launch Chief Architect and select File> New Plan .

    Custom molding profiles can be drawn in either floor plan view or in a CAD detail window.


  2. Select CAD> Lines> Draw Line  from the menu, or switch to the CAD Configuration  toolbar and select the Draw Line tool.

    • Draw a vertical line to form the back of the molding profile. 

      The back of the molding (the part that is against the wall) must be drawn vertically so that it forms the left side of the polyline.

    • In nearly all cases, this line's length should match the height of the profile you are creating as for the door casing.


  3. Using the CAD tools, draw your molding profile, similar to the example below. 



    In order to be used as a molding profile, the polyline must be a closed shape.

     
    Moldings should be drawn at their actual size.




To add the molding profile to your Library Browser

  1. Using the Select Objects  tool, select the closed polyline.


  2. With the profile highlighted select Tools> Symbol> Add to Library  or click on its button in the edit toolbar.

    In X3, the molding profile will now be placed in the My Library category of your Library Browser.

    In X2, the molding profile will now be placed in the Import category of your Library Browser.


  3. Your molding profile can now be renamed and placed into the appropriate folder that you have created for objects of this type in your User Catalog.



    Chief Architect X2 will have your custom libraries in the User Libraries folder.


If you would like to be able to have this molding applied to your exterior doors every time one is placed, you may want to consider adding it to your Default Settings for your default style template.

For more information on creating style templates, see the following online Help Database articles.


Article Number 463: How to create and use a plan style template


Article Number 737: How to create and use a layout template

Remember that we always want to keep our default style templates blank, so never start a drawing on a template, or try to delete objects from an existing plan to reuse it and create a new template 

It is also important to remember to set up new templates for each new version of Chief Architect that is released, as you do not want to bring forward templates from prior versions of the software.


To apply the molding to one of your style templates as the default for exterior doors:

  1. Select File> Open Plan , browse to your style template's location on your computer, select the template to highlight it, and click on the Open button.


  2. Next, select Edit> Default Settings .


  3. Click on the plus [+] sign next to Doors to expand out this category, highlight Exterior Door, and click on the Edit button.


  4. In the Exterior Door Defaults, select the Casing tab.


  5. Make sure the radio button is set to Exterior, then click on the Library button to display the Select Library Object dialog.


  6. Browse to your User Catalog folder, select the molding profile that you have created, and click OK.




  7. Make any other desired changes to the Exterior Door Defaults, then click OK to apply them.


  8. Select the Done button in the Default Settings dialog, then choose to Save  and Close  the template.


  9. Now, every time you start a new plan using that template style, your exterior doors will automatically use your custom molding profile.


To apply the molding to a single exterior door in an existing plan

  1. Launch Chief Architect and select File> Open Plan  and open the plan in which you would like to modify an existing door so that it uses the new molding profile.


  2. Using the Select Objects  tool, select the Exterior Door in the plan and click on the Open Object  edit button to display its Specification dialog.


  3. Select the Casing tab.


  4. Make sure the radio button is set to Exterior, then click on the Library button to display the Select Library Object dialog.


  5. Browse to your User Catalog folder, select the molding profile that you have created, and click OK.


  6. Make any other desired changes to the Exterior Door, then click OK to apply them.


  7. Finally, take a 3D Camera  view to see the results.