Browse
Categories

Creating a Post and Beam Structure

Reference Number: KB-00598 Last Updated: 12-23-2013 02:15 PM

The information in this article applies to:

Chief Architect Premier or Chief Architect Lite

QUESTION


I would like to design a ­post and beam structure in Chief Architect.  How can I do this?


ANSWER


There is a wide variety of post and beam construction styles, and a variety of methods that you can model this type of structure in Chief Architect, as well.  In this example, a simple structure composed of posts, beams, and trusses is created.

 



To create the perimeter

  1. Open the Chief Architect plan in which you would like to create a pole structure or select File> New Plan  from the menu to open a new, blank plan.

  2. Select Edit> Default Settings from the menu, then double-click on Framing to open the Framing Defaults dialog. 

  3. On the Beams panel:
    • Under the Size/Position heading, make sure that the Under Joists radio button is selected and specify the desired Depth and Thickness.  In this example, 5 1/2" is used for both. 

  4. On the Posts panel:
    • Specify the desired Dimension.  In this example, 5 1/2" is used.

  5. On the TRUSSES panel, specify the desired Member Depths.  In this example, the Top ChordBottom Chord, and Webbing are all specified as 5-1/2"
    • Click OK.

  6. Select Build> Framing> Post  from the menu, then click in the drawing area to place a ­post at that location.

  7.  Click on the post to select it, then click the Transform/Replicate Object  edit button.  In the Transform/Replicate Object dialog:   

     
    • Check the box beside Copy and specify the number of copies you would like to make. In this example, 4 copies are created.
    • Check the box beside Move and specify the interval at which you would like the copied posts to be created. In this example, a Move interval of 120" along the X Delta is used.  
    • Click OK to close the dialog and create the copies at the specified interval. In this example, a total of five posts spaced 10 feet apart are produced.



  8. Select the five posts as a group. To do this, click and drag a rectangular selection marquee around them.

  9. With the five posts selected, click the Transform/Replicate Object  edit button. In the Transform/Replicate Object dialog: 




    • Check the box beside Copy and specify 1 copy. 
    • Check the box beside Move and specify the interval to move the copied posts. 
    • In this example, the posts are moved 24 feet down on-screen, or -24' on the Y Delta then hit your tab key on your key board.  You will see it converted to -288".
    • Click OK to close the dialog and create the copies at the specified interval.  



  10. Select Edit> Preferences from the menu, and on the BEHAVIORS panel, specify the Concentric Jump or the distance you want between the outside of the posts and the edge of the structure's ­concrete slab. In this example 6".




  11. Select CAD> Boxes> Rectangular Polyline from the menu, then click and drag a polyline that snaps to the outside of the array of posts.


  12. Concentrically resize the polyline so it represents the size of the ­slab you need.  To do this:
    • Click on the polyline to select it.
    • Zoom  in on a corner of the polyline.
    • Hold down the C key on your keyboard.
    • Slowly drag the corner outward until it snaps to one Jump increment, then release the mouse button.


  13. Select Edit> Preferences from the menu, and on the BEHAVIORS panel, click on the Default button under Edit Type.

  14. Using the Wall or Railng tool of your choice, draw walls that snap to the polyline as they are drawn.



    • In this example, the Room Divider tool  is used.  When the area is completely surrounded by the room divider it will convert them in to full width invisible walls.
  15. Double Click in the middle of the floor area to bring up the Room Specification dialog. 
    • In the General panel select the desired Room Type.  In this example we selected the Slab type room so there is no additional flooring on top of the slab foundation.

  16. Select Build> Floor> Build Foundation  from the menu and generate a Monolithic Slab Foundation.

  17. Select 3D> Create Perspective Overview> Perspective Framing Overview  from the menu to see the results so far.




       

To add the roof trusses

  1. Return to the Floor Plan view.

     
  2. Go Up One Floor  to Floor 1, then specify the two side walls as Full Gable Walls.  To do this:
    • Shift + select the two walls and then click on the Change to Gable Wall(s) tool   in the edit menu at the bottom of your screen.

  3. Select Build> Roof> Build Roof  from the menu.  In the Build Roof dialog:  

    • On the ROOF panel, check Trusses (no Birdsmouth).
    • Specify the desired Pitch, Overhang, materials and other settings.
    • Check the box next to Build Roof Planes and click OK to close the dialog and build a roof over the structure.  
  4. Select Build> Framing> Roof Truss  from the menu, then click and drag a line perpendicular to the roof ­ridge from one exterior wall to the opposite wall to draw a roof ­truss at that location.  



  5. To move the joist over the top of the first two posts on the left side of the building, select the truss and then click on the Center Object tool  and then place your mouse over the top of one of the first posts until you see the vertical centerline indicator and click.


  6. With the truss still selected, click the Transform/Replicate Object  edit button.  In the Transform/Replicate Object dialog:

    • Specify the number of copies that you want across the building, in this example 4 copies. and the distance, in the example 120" in the direction (the X Delta or right on your screen) to copy them across the building. 



    • Click OK to close the dialog and create the copies at the specified interval.  

  7. Create a Perspective Framing Overview to see the results.  Select File> Close View    when you are finished to return to floor plan view.



To add the beams

  1. Zoom in on the two posts located at top left corner of the structure.
  2. Select Build> Framing> Floor/Ceiling Beam , then click and drag to draw a beam between these two posts.  Drag the posts endpoint to just short of the 2nd post.




    • By default, beams will snap along their centerlines as they are drawn, and you can snap them to the posts midpoints.
  3. Go to the Window drop down menu and select Fill the Window Building Only  .
  4. Select the beam and click and drag the end edit handle to the right to cross over the top of all the posts and snap to the right side midpoint of the last post on the right.
    • To size the beam correctly, double click on it to open the  Beam Specification Dialog.  Change the Depth:  and Width: fields to the desired size.

  5. To copy the beam to the line of posts on the opposite side of the building, select the beam click on the Copy/Paste tool  in the edit tool bar at the bottom of the screen.  Then click on the Reflect About Object   tool in the tool bar at the bottom of the screen, then hover over the roof ridge line until you see the horizontal center line indicator and click.  You should now have beams over each line of posts.
  6. Create a Perspective Framing Overview  to see the results.