Browse
Categories

Working with Light Sources

Reference Number: KB-00777 Last Updated: 11-27-2013 10:12 AM

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors or Chief Architect Lite



QUESTION


I know that I can use lighting to produce realistic 3D views of my work, but am not sure where to begin.  Can you suggest some tips for working with light sources?





ANSWER


In Chief Architect, you can use light sources to help produce dramatic, photorealistic 3D views of your model. To do so effectively, though, takes an understanding of the different types of light sources available in the program, as well as practice.

There are three types of light sources in Chief Architect:

  • Point lights, which emit light in all directions, similar to light bulbs. 

  • Spot lights, which emit a cone of light in a particular direction only. 

  • Parallel lights, which emit light in one direction, as though from a distant source like the sun.


For most interior lighting needs, Point lights are recommended because they are most similar to electric light bulbs. Spot lights can be used in combination with point lights for directional lighting.

In addition to the three types of lights in the program, materials can be given emissivity, allowing surfaces to give off light.  This property can be very effective when applied to a TV or projection screen.


To place lights

There are a variety of ways to add lights to a plan in Chief Architect.   

  1. Select Build> Electrical> Light  from the menu, then click at a location where you would like to place a light fixture.   

    • If you click on a wall, a wall fixture will be created.  

    • If you click away from a wall, a ceiling mounted fixture will be placed.  


  2. Select View> Library Browser  from the menu:  

    • Navigate to Architectural> Lighting and select a fixture.
    • When you move your cursor into the drawing area, it will display the Electrical  icon.

    • Click to place the selected library symbol in your plan. 

       
  3. Select 3D> Add Lights  from the menu, then click to place a light source that emits lights but is not actually a 3D object.  


    • Add Lights  lets you to customize the lighting in a space without adding electrical fixtures.  

    • You can also add emissivity to 3D objects, such as candles, or images, such as fireplace flames.  


To edit lights

Once a light or light symbol has been placed in your plan, it can be edited. Add an object, such as a base cabinet, if you'd like to see how shadows are affected as the light's specifications are changed.

  1. Begin by selecting Edit> Preferences  (Chief Architect> Preferences  for Mac) from the menu. On the Render panel of the Preferences dialog:  

    • Check the box beside Show Shadows under the Preview heading.  

    • Click OK to close the dialog and apply the change.  


  2. Select 3D> Create Perspective View> Full Overview  from the menu, then click and drag a camera arrow towards the light fixture.  


  3. Click on the light symbol to select it, then click the Open Object  edit button.  


  4. On the Render Data panel of the Electrical Service Specification dialog, click the drop-down arrow at the top of the dialog and notice that this light has two light sources associated with it.   

     


    • Light fixtures can have any number of light sources associated with them.  

    • Each light source can have its own unique settings and can be turned on in render views ("real-time"), ray trace views, or both ("all views").  


  5. With Light 1 (camera view only) selected as the current light source:  

    • If you want to, click the Color box and select a color for the selected light source from the Color Chooser dialog.  

      Selecting a distinct color such as red or blue will help make changes to the light's settings more apparent in the 3D view. 


    • In version X4, you can select an Intensity from the drop-down list. The options in this list correspond to commonly used light bulb wattages.

    • Select Custom from this list to open the Custom Light Intensity dialog.  For the purposes of this exercise, we will uncheck Auto Adjust Intensity and experiment with the Intensity and Attenuated settings.




    • In version X3 and prior, both Intensity and Attenuated are adjusted on the Light Data panel. Uncheck Auto Intensity to enable the Intensity slider bar.  

    • Click OK to close the dialog and apply your changes.  


Let's take a quick look at how adjusting some of these values affects the light in a plan.  

In this example, a simple 15' x 15' square room is drawn, with a ceiling flush mounted light from the library is placed inside it.  

Notice how changing in the light's Intensity value affects the 3D camera view.

 


Next, recheck Auto Intensity, then repeat steps above, experimenting this time with the Attenuated values.
   
   
     
  • Attenuation refers to how quickly the intensity of the light decreases as distance from its source increases.   

  • Only small changes to the Attenuated values can have significant effects on the distance the light can travel.  


For more information on the options in the Electrical Service Specification dialog, select the Help button located at its lower right to launch the software's context sensitive Help on this dialog.  



To add a spot light

  1. On the Light Data panel of the Electrical Service Specification dialog, select Light 1 (all views) and then choose Spot Light from the Type drop-down list.  

     


  2. As with the intensity and attenuation, experiment with the Tilt Angle and Dir. Angle.   




    •  A Tilt Angle of -90° points straight down, while +90° points straight up. 

    • A Dir. Angle of 0° points to the right horizontally in floor plan view.  


  3. You can also experiment with the Cut Off Angle and Drop Off Rate.   




    • The Cut Off Angle defines the angle of the cone of light created by a spot light and can be between 0 and 180 degrees. 

    • The Drop Off Rate describes the rate at which the light intensity within the cone of light decreases. 

    • When the Cut Off Angle is decreased, it is often a good idea to increase the Drop Off Rate.


To edit a fixture's multiple light sources

Because multiple light sources can be applied to a single fixture, you can model the appearance of a chandelier or the effects of directional track lighting.

  1. Click on the light fixture to select it, then click the Replace From Library edit button. 


  2. In the Replace From Library dialog:   

     


    • Click the Library button, then browse to Architectural> Lighting> Track Lighting and select a fixture. 

      In this example, the Basic 24" Track fixture is used. 

    • Click OK to close both the Select Library Object and Replace From Library dialogs. 

       


  3. Click on the light fixture to select it, then click the Open Object edit button. 


  4. On the Light Data panel of the the Electrical Service Specification dialog: 

    • Notice that there are five light sources associated with this fixture. 

    • For the purposes of this example, Lights 4 and 5 have been deleted. 


  5. Select Light 1 (ray trace only) and click the radio button beside Use in Both so that this light source will display in rendered views that support lighting. 

    • Make any changes to the settings for this light source. 

    • As it is the only light source displaying in 3D views, it is easy to see its effects and make any needed changes. 

      In this example, Light 1 has a Tilt Angle of -90 degrees. 


  6. When Light 1 is set up as desired, change it to Use in Ray Tracing so that it will no longer update your render camera view, and repeat this process with both Light 2 and Light 3. 

    • In this example, Light 2 has a Tilt Angle of -35° and a Dir. Angle of 40° and Light 3 has a Tilt Angle of -20° and a Dir. Angle of 320°. 


  7. When all three lights are set up as desired, specify Use in Both for all of them and then see how they display when they are all enabled together. 



     



  8. If you want, you can check the box beside Show Position in Render View to display markers indicating the position of the light source in render views without shadows. 


       

    If the light source is a spot light, a directional arrow will display as well. 




To use Added Lights

The Add Lights tool can be used to illuminate surfaces without creating electrical light fixtures in the plan.


  1. Open a plan in which you would like to add a light source that isn't associated with a light fixture. 

    • In this example, two directional spot lights will be used to highlight a painting. 


  2. Select 3D> Add Lights from the menu, then click at a location where you would like to create a light source. 


  3. With the light source selected, click the Open Object edit button. In the Light Specification dialog: 

    • Specify the light source Type as a Spot Light. 

    • Specify the needed Height.  In this example, 32" is used. 

    • Click OK to close the dialog and apply your changes. 


  4. With the light source still selected, click the Copy/Paste edit button, then click beside the original to place a copy. 


  5. Use the Rotate edit handles that display at the end of each angle line and at the focal point to adjust the Dir. Angle and the Cut Off Angle of each spot light. 


     

    • In this example, the Dir Angles are moved to approximately 102 and 78 degrees, and the Cut Off Angles are both 112 degrees. 

      You can check these values in the Light Specification dialog. 


  6. As you work with lights, you will often find that you need to make changes to their settings.  

    After these lights are placed, their Attenuated values were edited: 


     


  7. A point light was also added to this view, behind the camera, so that the spot lights aren't the only light sources in the view.  


     



To use an emissive material

One of the advanced properties of a material is emissivity, which refers to its ability to emit light. This property can be used to create a realistic image such as for a television or projection screen.


  1. Use a digital image to create a custom material for display on a TV screen.


  2. Select 3D> Create Perspective View> Full Camera , then click and drag a camera arrow towards the TV or projection screen.

    In Chief Architect X1 and prior, use 3D> Create Render View> Render Full Camera.


  3. In the 3D view, use the Material Painter tool to apply the image to the screen surface.


  4. Select 3D> Adjust Material Definition and click on the screen with your image.


  5. Select the Properties panel, then move the Emissive slider to adjust this setting.





    • Emissive controls how bright a material appears independent of the lighting in the scene. It can be used to simulate surfaces that are glowing with their own light, such as the glass on a light fixture and this option is only available for General materials.

    • For the purposes of this example, Emissive is set at 15%

    • In Chief Architect X2 and prior, the Emissive setting is on the on the Render panel of the Define Material dialog. To access it, click the radio button beside Advanced.


  6. To see the results, select 3D> Create Perspective View> Perspective Full Overview from the menu, then click and drag a camera arrow towards the TV.