Browse
Categories

Creating a Custom Door Symbol

Reference Number: KB-01808 Last Updated: 02-24-2015 01:02 PM

The information in this article applies to:

Chief Architect Premier


QUESTION

Is there a way that I can create a custom door symbol and add it to my library in Chief Architect?




ANSWER

You can create custom door symbols in Chief Architect using many methods. In this article, we will cover how to accomplish this using solids to create a custom panel door and add it to our library for use in other plans.

To get started you will need to open an empty plan by selecting File> New Plan  from the menu. This is so that only the door is captured when we convert it to a symbol. 

To create the shape

  1. Now that you have your new plan, start by opening a cross section/elevation view by selecting 3D> Create Orthographic View> Cross Section/Elevation from the menu.




  2. In this new elevation click CAD> Boxes> Rectangular Polyline and draw a polyline to the dimensions that you need.



    For this example, use the following dimensions:
    • Width: 30" (2ft 6in)
    • Height: 80" (6ft 8in)


  3. Now, make a second polyline to serve as the first panel, making it 18" wide and 18" tall.


  4. Select the top of the new polyline and click the Change Line/Arc  edit button.


  5. Repeat this for the bottom, then grab the triangle handle on the bottom's arc and curve the arc upward, as demonstrated below.




  6. Align this shape to the door 8" down from the top and 6" in on either side. 
     

  7. With this shape selected, click Copy and Paste in Place  , then using the shape's larger triangle handle, rotate the shape 180°.


  8. Finally, place the rotated shape 8" up from the bottom of the door.




  9. Next, go to CAD> Circles> Ellipse  and draw an ellipse that is 18" wide and 12" tall, and center it on your door.

    You may find using the Point to Point Move  tool helpful in aligning your ellipse.


  10. Select the three polyline objects inside of the door and Copy/Paste   the objects away to the side of your door for later use.

    Do this twice, as shown below.



Now that you have the general layout of our door panels, you are ready to begin converting it into a solid object. 


To convert to a solid

  1. Select the door outline and click Convert Polyline , choose Polyline Solid from the Convert Polyline dialog and click OK.




  2. Specify a thickness of 2" in the Polyline Specification dialog and click OK


  3. Select the three polyline objects inside of the door and click Convert Polyline  to convert these into polyline solids as well.



    • Specify these as holes in the larger ­polyline solid by checking the Hole in Polyline Solid check box in the Polyline Specification dialog.


  4. Now select the next set of three polyline objects and, using the Point to Point Move  tool, align them with the newly created holes in your door.


  5. With the polyline objects still selected, click Convert Polyline  , and convert them to polyline solids, specifying their thickness to be 1/4" thick.


  6. Return to the Floor Plan view and center the 1/4" polylines in the door and toggle back to the elevation.

     


Now you are ready to finish off the door by adding the trim to the panels and the arced section. 


To finish the panels

  1. Select the final set of three polyline objects and click the Convert Polyline button, select 3D Molding Polyline and click OK.

     

  2. On the Molding panel of the 3D Molding Polyline Specification dialog, assign a different molding profile by clicking Replace.



    In this example, use CA-03 as the molding profile, and make it 2" high and 1/4" wide. 


  3. Return to Floor Plan view and draw a selection marquee around the new 3D molding polyline using Select Objects .




  4. Now move the molding into place and line it up to the outer edge of the door. You may need to toggle between Floor Plan and Elevation in order to line it up properly as shown with the 1/4" thick panels earlier in this article. 



Now that the door is built, you are ready to convert it to a symbol and add it to the library. First, however, you should assign some materials to the door.  If all the pieces of the door are left with their default material, you will not be able to customize the materials fully as you might wish later on. 


To convert to a door

  1. While still in the Elevation view, click the Material Painter and select a material of your choosing.


  2. Apply a different material to the trim, panels, door and arced opening as shown in the example below.



    For this example use the following materials:
    • Door: Maple
    • Trim: Maple 3
    • 1/4" Panels: Maple 1 

  3. Now we can close the Elevation view and click 3D> Create Perspective View> Full Overview .


  4. Within the Full Overview, click Tools> Symbol> Convert to Symbol  .


  5. In the Convert to Symbol dialog, choose Door from the Symbol Category drop-down.



    • Check Add To Library and Show Advanced Options, then click OK.


  6. In Symbol Specification dialog that appears next, select the 3D panel and specify the Symbol Name that you want displayed in the Library Browser then OK to finish adding the door to your library. 


Your door is now ready for use in other plans.

You can use any combination of shapes to create a variety of object and then convert them to the appropriate symbol category depending on your intended use of the object.