Browse
Categories

Creating a Custom Door Symbol

Reference Number: KB-01808 Last Updated: 11-11-2014 09:37 AM

The information in this article applies to:

Chief Architect Premier


QUESTION

Is there a way that I can create a custom door symbol and add it to my library in Chief Architect?




ANSWER

You can create custom door symbols in Chief Architect using many methods. In this article, we will cover how to accomplish this using solids to create a custom panel door and add it to our library for use in other plans.


Creating the shape

To get started you will need to open an empty plan by selecting File> New Plan from the menu. This is so that only the door is captured when we convert it to a symbol.

  1. Now that you have your new plan, start by opening a cross section/elevation view by selecting 3D> Create Orthographic View> Cross Section/Elevation from the menu.




  2. In this new elevation click CAD> Boxes> Rectangular Polyline and draw a polyline to the dimensions that you need.



    For this example we will be using the following dimensions:


    • Width: 48" (4ft)

    • Height: 84" (7ft)


  3. Now we will make a second polyline to serve as the first panel, making it 36" wide and 6" tall.


  4. Select the top of the new polyline and click the Change Line/Arc  edit button.




  5. Make two copies of the new polyline using Copy/Paste .




  6. Move the first polyline into the top of your door template.




  7. Now use the same process to create 8 more polylines and place them in the template as shown below.




Converting to solids

Now that we have the general layout of our door panels we are ready to begin converting it into a solid object.

  1. Select the door outline and click Convert Polyline .


  2. Choose Polyline Solid from the Convert Polyline dialog.




  3. Specify a thickness of 2" in the Polyline Specification dialog and click OK.


  4. Select the top, arced, polyline and the 4 larger, rectangular, polylines below and click Convert Polyline  to convert these into polyline solids as well.



    • Specify these as holes in the larger ­polyline solid by checking the Hole in Polyline Solid check box in the Polyline Specification dialog.


  5. Now select the smaller, rectangular polylines on the door and convert these to polyline solids making them 2 1/2" thick.


  6. Return to the Floor Plan view and center the 2 1/2" polylines in the door and toggle back to the elevation.




  7. Now select the second, arced polyline that we created earlier and convert it to a polyline solid, specifying its thickness to be 1/4" thick.



    • Then center it inside the hole created in step 4 of this section.


Finishing the panels

Now we are ready to finish off the door by adding the trim to the panels and the arced section.

  1. Select the 3rd arced polyline we created earlier and click the Convert Polyline button. Select 3D Molding Polyline and click OK.




  2. On the Molding panel of the 3D Molding Polyline Specification dialog, assign a molding profile. In this example we will be using profile CA-03 and making it 2 1/4" high and 1/4" wide.




  3. Return to Floor Plan view and draw a selection marquee around the new 3D molding polyline using Select Objects .




  4. Now move the molding into place and line it up to the outer edge of the door. You may need to toggle between Floor Plan and Elevation in order to line it up properly as shown with the 2 1/2" thick panels earlier in this article.


  5. Select one of the smaller, 2 1/2"-thick panels while in Elevation and Copy/Paste it off to the side of the door.




  6. With the polyline solid selected click Convert to Plain Polyline then Convert Polyline .

    • Convert it to a 3D Molding Polyline giving it the same molding profile of CA-03 and the same Height (2 1/2") and Width (1/4").


  7. Repeat the process from Step 3 to move the new 3D molding polyline into position.




  8. Continue this until you have 3D molding polylines on both sides of the door.




Converting to a door

Now that our door is built, we are ready to convert it to a symbol and add it to the library. But first, we should assign some materials to the door. In this example we will be using some generic blues and greens to serve as place holders for the different components.

If all the pieces of the door are left with their default material, you will not be able to customize the materials fully as you might wish later on.

  1. While still in the Elevation view, click the Material Painter and select a material of your choosing.


  2. Apply a different material to the trim, panels, door and arced opening as shown in the example below.




  3. Now we can close the Elevation view and click 3D> Create Perspective View> Full Overview .


  4. Within the Full Overview, click Tools> Symbol> Convert to Symbol  .


  5. In the Convert to Symbol dialog, choose Door from the Symbol Category drop-down.



    • Check Add To Library and Show Advanced Options, then click OK.


  6. In Symbol Specification dialog that appears next, select the 3D panel and specify the Symbol Name that you want displayed in the Library Browser.


  7. There are four entries for materials which we can customize under the Materials panel.



    • Click OK to finish adding the door to your library.

Your door is now ready for use in other plans.

You can use any combination of shapes to create a variety of object and then convert them to the appropriate symbol category depending on your intended use of the object.