Creating Stairs in Sloping Terrain


Reference Number: KB-00547
Last Modified: June 1, 2021

The information in this article applies to:

Premier



QUESTION

My plan calls for a set of stairs that cuts into sloping terrain to join two sidewalks, but when I draw stairs in my plan, they do not follow the terrain or join to my sidewalks. What should I do?


ANSWER

You can create stairs that follow your terrain by drawing stairs in your desired area, while snapping them to landings at each end.

terrain stairs

To create stair landings

The first step to creating stairs that follow the terrain in a plan is to create the landings that the stairs will attach to. We can define the heights of these landings to control the staircase's height, as well.

  1. Open  the plan in which you want to create stairs in sloping terrain.

    In this example, the terrain has a single slope between two flat areas, as shown in the image below.  

    Showing a five foot slope between two flat areas
     

  2. Select Tools> Layer Settings> Display Options  from the menu and turn off the display of the Terrain, Primary Contours layer, then click OK. While not strictly necessary, this will make drawing the landing and stairs easier.


  3. Navigate to Terrain> Terrain Specification  from the menu.


  4. On the General panel of the Terrain Specification dialog that displays, uncheck the Automatic box beside Subfloor Height Above Terrain, specify an appropriate value in this field, then click OK. This will help control how the landing's height relates to the terrain.

    In this example, 0" is used.

    Turning off Automatic next to Subfloor Height Above Terrain in the Terrain Specification dialog.


  5. Select Build> Stairs> Landing , then click and drag to create a rectangular landing.

    Placing the first landing on the terrain

    Note: While you can begin with either the top or bottom landing, you may find it easier to begin with the one closest to the height of your building pad.  

  6. Edit the size and shape as needed using the edit handles that display.

     
  7. Select the newly created landing, then click the Open Object edit button.


  8. On the General panel of the Stair Landing Specification dialog, which opens next, specify the Top Height and Thickness of the landing, check the radio button beside No Railing, check the box for Apply to All Edges, then click OK.  

    Adjusting the height values for the landing and turning off the railings 

    • The Height value of a stair landing is measured relative to the Default Subfloor Height of Floor 1, which is defined as 0". 

    • Because the terrain's Subfloor Height Above Terrain value was set to 0", a Landing Top Height of 1" indicates the landing's top height will be 1" above any terrain elevation of 0".


  9. With the stair landing still selected, click the Copy/Paste  edit button, then click and drag the Move  edit handle, releasing the mouse button to place a copy at the desired location.  

    Copying the first landing to the location of where the other landing should be

    If you need to position the copy with greater precision, consider using the Transform/Replicate Object edit button.


  10. When the copied stair landing is in place, select it and click the Open Object  edit button. On the General panel of the Stair Landing Specification dialog, specify the Top Height of this new landing, then click OK.  

    Changing the heights for the second landing


  11. To check the heights of your landings relative to the terrain, select 3D> Create Orthographic View> Backclipped Cross Section from the menu, then click and drag a camera arrow parallel to the slope of your terrain and within the length of the landing.  


  12. If the landing and terrain are not near one another, return to floor plan view and make any necessary adjustments to the landing heights.  

    Depending on the requirements of your drawing, you may need to make changes to your slope, or your terrain's Subfloor Height Above Terrain value instead.

 

To draw stairs between landings

  1. In floor plan view, select Edit> Snap Settings  from the menu and make sure that Object Snaps  are enabled, particularly Midpoint  snaps.  


  2. Select Build> Stairs> Draw Stairs  from the menu, then move your cursor to the landing with the lower Height value. Position it near the midpoint of the edge closest to the other landing.  


  3. When your cursor is over the midpoint, a triangular red Midpoint  snap indicator will display. Click and drag to the midpoint of the other landing, then release the mouse button. A staircase will be created and will be attached to the two landings.  

    Drawing a run of stairs from the lower landing up to the higher landing


  4. Select the stairs and click the Open Object  edit button.  


  5. Make any changes you'd like in the Staircase Specification dialog, then click OK to apply your changes.  

     
  6. Create a Camera  view to see the results so far.

    Stairs in a Sloping Terrain Perspective Camera View

    Notice that the terrain can be seen in parts of the staircase area. You can always modify the riser height by de-selecting the Automatic Heights checkbox located in the Staircase Specification dialog to make it rise over the terrain.

    If the terrain continues to conflict with the staircase, consider using retaining walls placed around the stairs. You can also entirely remove the terrain from under the stairs using the Terrain Hole tool found by navigating to Terrain> Feature> Terrain Hole.