Controlling the Information that's Displayed in a Materials List


Reference Number: KB-00510
Last Modified: July 15, 2021

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors



QUESTION

When I create a materials list, a complete list of all the materials and objects in my plan file is created. How do I control what information displays in a materials list?


ANSWER

The Preferences dialog allows you to control the categories and columns that are included in a Materials List before it's created. If you've already created a Materials List however, you can control this information using the Materials List Specification dialog.

In addition to these options, you can specify what layers are displayed in a Materials List, as well as change the structural member reporting method used for framing members.


To set up Materials List Preferences

  1. Select Edit> Preferences  from the menu on a Windows PC or Chief Architect> Preferences  on a Mac.


  2. On the Materials List panel of the Preferences dialog, uncheck  the boxes beside any category that you do not wish to include in a Materials List when it is first created.

    Materials List panel of the Preferences dialog


  3. On the Report Style panel, uncheck the boxes beside the name of any Column that you do not wish to include in a Materials List when it is first created.

    Report Style panel of the Preferences dialog


  4. You can also control other properties here, such as the Grid, the Colors used, and the Font Size.


  5. Once you've made all of your desired changes, click OK to close the dialog.

The Materials List Specification dialog lets you control what is included in a Materials List after it's created.


To use the Materials List Specification dialog  

  1. Open  a Chief Architect plan in which you would like to access the Material List Specification dialog.

    In order to generate a Materials List, the plan should include at least one architectural object.


  2. Select Tools> Materials List> Calculate Materials for All Floors  from the menu to generate a Materials List for the entire plan.


  3. In the Materials List window, select Tools> Active View> Edit Active View to open the Materials List Specification dialog.

    • The Categories panel is similar to the Materials List panel of the Preferences dialog. Check the box beside each category that you would like to include in the current Materials List.

      Categories panel of the Materials List Specification dialog

    • The Columns panel is similar to the Report Style panel of the Preferences dialog. Check the box beside each column name that you wish to use. Click the Move Up and Move Down buttons to change the columns' order.

      Columns panel of the Materials List Specification dialog

    • On the Options panel, you can specify the Layer Set used, the Structural Member Reporting default, the Reporting Method, as well as what floor and what suppliers are displayed in the Materials List.

      In X12 and prior versions, the Restrict to Floor and Restrict to Supplier options are the only settings displayed here.

      Options panel of the Materials List Specification dialog



Layers that are associated with the plan file in which the Materials List was generated from can also be used to control what is displayed in the Materials List.


To control what is displayed in the Materials List using layers

  1. In X13, generate a Materials List, then navigate to Tools> Layer Settings> Display Options  .

    In X12 and prior versions, make sure a plan view is the active window, then navigate to Tools> Layer Settings> Display Options  .


  2. In X13, remove the checkmark from the Display column, or checkbox, to exclude all objects on that layer from being reported to the Materials List.

    In X12 and prior versions, remove the "M" symbol from the Materials List column instead.

    Unchecking the Fixtures, Interior layer



  3. Once all of your desired changes have been made, click OK.


  4. In X13, the Materials List will update in real time to reflect the changes that were made.

    In X12 and prior versions, generate a new Materials List to see the changes.

You can also control the way framing members are reported in the Materials List.


To change the structural member reporting method

With the Materials List window active, use the Lumber Reporting Method Control drop-down menu located near the top left corner to choose your desired reporting method for framing members.

Using the Lumber Reporting Method Control drop-down to change the reporting method

Starting in X13, you can also change the reporting method used for a Materials List by accessing the Options panel of the Materials List Specification dialog.

  • Linear Length calculates the framing materials of the different structural components of the plan in linear feet.

  • Cut List calculates the framing materials of the different structural components of the plan by counting the individual pieces present in the model.

  • Buy List calculates the framing materials of the different structural components of the plan by counting individual pieces and matching them to a list of board sizes that you specify.

  • Mixed Reporting calculates framing materials using a combination of linear lengths and piece counts and is recommended for saved Materials Lists in legacy plans.

For more information on modifying structuralmember reporting properties, please view the "Creating a Cut List of Framing Materials" resource in the Related Articles section below or access your program's help documentation.