Adding a Custom Backdrop Image to Camera Views


Reference Number: KB-00222
Last Modified: July 15, 2021

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors



QUESTION

I have created a number of custom backdrop images. I have copied the images from my digital camera to my desktop, and now I would like to make them usable in Chief Architect. How do I add them to the program?

Custom backdrop of hills


ANSWER

Backdrops are images that display behind the model in 3D views, and new backdrops can be created using a variety of graphic file formats. In this article, we will cover the following topics:


To import a custom image to be used as a backdrop

  1. Select File> Import> Import Backdrop  .

    Navigate to File> Import> Import Backdrop


  2. The Import Backdrop File dialog, which appears next, allows you to browse for an image on your computer. Once you have located the image you want to use, select it, and click the Open button.  


  3. In the Backdrop Specification dialog that displays, specify a Name, whether it's a Spherical Panoramic Backdrop or not, then click OK.

    Backdrop Specification dialog where a Name can be specified

    Note: The Spherical Backdrop Options should only be used if the selected backdrop was specially created to serve as a spherical panoramic backdrop. When enabled, the image will be projected onto a sphere that surrounds the model in camera views.  

    • The Horizontal Angle controls how many times the backdrop appears as you rotate in a full circle around the model. A value of 360° wraps the image around once; a value of 720°, twice; and a value of 180° makes only half the image wrap around the sphere.

    • The Vertical Angle determines how much of the backdrop stretches up and down. To have it stretch from the highest point in the sky to the lowest point below the ground, use a value of 180°. To have the backdrop stretch from just below a horizontal render to just above, use a smaller value, such as 100°.

    Some experimenting with the Angle values may be necessary to achieve the desired results. You may prefer to do this after adding the backdrop to a plan.

  4. The backdrop can now be found in the User Catalog section of the Library Browser  .


To add a folder of custom backdrop images to the library

  1. Select File> Import> Create Backdrop Library  to open the Select a Backdrop Folder dialog.


  2. Browse for and select the folder containing images you'd like to import as backdrops and then click the Select Folder button.


  3. An Information message will display once the import has completed. The folder containing the backdrop images will be located in the User Catalog.


To apply custom backdrop images to the camera defaults

  1. From the menu, navigate to Edit> Default Settings , expand the Camera Tools category, select a camera tool that you'd like a custom backdrop to be applied to, such as Full Camera, then click Edit.


  2. On the Backdrop panel of the Full Camera Defaults dialog that opens, click on the Select Backdrop button.

    Click the Select Backdrop button on the Backdrop panel

    • In the Select Library Object dialog that opens next, navigate into the User Catalog, find the backdrop image that you'd like to use, and select it.

    • Click OK to confirm the change.


  3. Click OK a second time, then click Done to confirm the changes and close out of the dialog boxes.


  4. Create a new, Full Camera  view to see the custom backdrop image displayed behind the model.

Certain rendering techniques, such as Vector View and Glass House, are not setup to display backdrops by default. To adjust this setting, navigate into Edit> Default Settings, expand 3D View Defaults, select Rendering Techniques, then click Edit. In the Rendering Technique Defaults dialog, select the rendering technique in which the specified backdrop is not displaying in, check the Use Backdrop box, then click OK.


To apply a custom backdrop image to a single camera view

  1. Select 3D> Create Perspective View or 3D> Create Orthographic View , select a camera tool of your choice, then create a camera view.


  2. Once the view has generated, navigate to Tools> Active View> Edit Active View .


  3. On the Backdrop panel of the Specification dialog that opens, click on the Select Backdrop button

    • In the Select Library Object dialog that opens, navigate into the User Catalog, find the backdrop image that you'd like to use, and select it.

    • Click OK to confirm the change.


  4. Click OK a second time to confirm the change and close out of the dialog.

    Note: If a camera view is not saved in the plan you're working in, and the view is subsequently closed, the backdrop will no longer appear when a new camera view is taken unless the backdrop was specified in the default settings.