Message: Cannot find or open the file to save your plan.


Reference Number: KB-00911
Last Modified: June 14, 2023

The information in this article applies to:

Chief Architect Premier or Chief Architect InteriorsHome Designer Professional or Home Designer Architectural or Home Designer Suite



DESCRIPTION

I sometimes encounter a message that says:

"Cannot find or open the file to save your plan."

OR

"This file cannot be saved to the specified location. Try a location with a shorter path name. If saving to a removable drive, make sure it is accessible."

OR

"Could not open the file to write. This may be because the drive you are attempting to write to has been ejected. If this is a temporary drive you can reconnect it and try again."


I am not saving to a removable drive, so why am I seeing this message?  


CAUSE

One of these messages will display whenever the program tries to save a file to a particular location but isn't able to.  

There are a number of specific reasons why this occurs:

  • The save location is a removable drive that cannot be accessed.
  • The save location is on a network and cannot be accessed.
  • The program is already in the process of saving the file in question.
  • Another program is accessing the file in question.
  • The operating system identifies the file as being accessed by another program.
  • The file's full path name is too long.


RESOLUTION

Since there are a number of possible reasons why these messages might display, there are also a number of different possible resolutions.


Removable Drives and Network/Cloud Locations

If you are working on a file that is saved somewhere other than your local hard drive, begin by confirming that you can actually browse to that location in Windows Explorer or macOS Finder. If you cannot, the program will not be able to either.

If you can access the network or removable location, bear in mind that the process of saving in Chief Architect will be slower to that location than if the file were located on your local machine.
We do not recommend that you work on files that are saved on a network or cloud location, as program slowness, file corruption, and data loss can occur. If you'd like to collaborate with colleagues using network/cloud services, please see the recommended procedure in the Related Articles section below. 

If you attempt to save a plan or layout file when Chief Architect is still in the process of performing the last save command, one of these messages may display. Click OK and wait a few moments while the program finishes saving.


Auto Archive, Auto Save, and Undo Files

Chief Architect automatically saves Archive files for your named files in the program's Data folder. More information can be found in the "Accessing Your Archive Files" linked in the Related Articles section.

By default, the Data folder is located in your Documents directory.

If you specify a non-default location for the Data folder that is either not the local hard drive or not writable per your Windows or macOS operating system, a message may display whenever the program saves an Archive file.

Similarly, if you specify a non-default location for your Documents directory that is either not located on the local hard drive or not allowed by your operating system, this message may display when the program saves an Archive file.

A similar situation can occur if you specify a non-default location for your Chief Architect Undo directory. If you choose a location that is not on the local hard drive, or not allowed by Windows or macOS, this Warning may display when the program writes an Undo file or when you try to use the Undo command.


Other Applications and File Locking

There are a variety of different programs that can temporarily lock files on your computer while they are running - for example, backup utilities and anti-virus or other security software. Consider scheduling file backups and security scans during the times when you are typically not working, or schedule them less frequently during those times. 

On occasion, your Windows or macOS operating system may identify a file as locked, or accessed by another program, when it is not. Usually, if you wait a few minutes the issue will resolve itself. If waiting does not resolve the issue, reboot your system, then attempt to open the file.


Path Name Length

Windows allows a maximum file path name length of 260 characters, while macOS allows a maximum file path name length of 255 characters.

It is very important to remember that a file name is not the same thing as its full path name.

For example:

  • A file name of Smith.plan has 10 characters.

  • If this file is saved in a user's Documents folder, its full path name on a Windows machine may be C:\Users\[YOUR USERNAME]\Documents\Smith.plan or /Users/[YOUR USERNAME]/Documents/Smith.plan which has 25+ characters.

Bear in mind that Chief Architect creates Archive and Auto Save copies of named plan and layout files on a regular basis, and that these files' path names are typically longer than those of the original files.

For example:

  • The full path name of the Smith.plan file might be, C:\Users\[YOUR USERNAME]\Documents\Chief Architect Premier X15 Data\Archives\Smith_b8f17c2e88a82622dc3c96618e1a4976e0d2f795Smith_2022_11_28.plan or /Users/[YOUR USERNAME]/Documents/Chief Architect Premier X15 Data/Archives/Smith_b8f17c2e88a82622dc3c96618e1a4976e0d2f795Smith_2022_11_28.plan which has 125+ characters.

When choosing a file naming convention and file management system, try to use short file names and limit the use of folders nested within other folders. Also, consider viewing the "Organizing Your Plan and Layout Files" resource in the Related Articles section below.