Creating a Custom Door Symbol


Reference Number: KB-01808
Last Modified: February 6, 2019

The information in this article applies to:

Chief Architect Premier



QUESTION

Is there a way that I can create a custom door symbol and add it to my library in Chief Architect?

Custom Door Symbol created in Chief Architect 


ANSWER

You can create custom door symbols in Chief Architect using many methods. In this article, we will cover how to accomplish this using solids to create a custom panel door and add it to our library for use in other plans.


To create the shape

  1. Navigate to File> New Plan to open a new plan file, select 3D> Create Orthographic View> Cross Section/Elevation from the menu, then click and drag to create an elevation view.

    Cross Section Elevation View being created in an empty plan


  2. In this new elevation, click CAD> Boxes> Rectangular Polyline and draw a polyline to the dimensions that you need.

    Rectangular Polyline drawn 80 inches tall and 30 inches wide

    In this example, we created a polyline 30" wide and 80" tall.


  3. Now, make a second polyline to serve as the first panel.

    In this example, our polyline is 18" wide and 18" tall.


  4. Select the top of the new polyline and click the Change Line/Arc  edit button.


  5. Repeat this for the bottom, then grab the triangle edit handle on the bottom's arc and curve the arc upward, as demonstrated below.

    18 by 18 rectangular polyline with top and bottom lines converted to parallel arcs


  6. Align this shape to the door.

    In this example, the shape is placed 8" down from the top and 6" in on either side. 
     

  7. With this shape selected, click the Copy and Paste in Place edit button, then using the shape's larger triangle handle, rotate the shape 180°.


  8. Finally, place the rotated shape up from the bottom of the door the same distance mentioned in Step 6 above.

    In this example, the shape is 8" up from the bottom.

    Door polyline with smaller polylines placed at top and bottom


  9. Next, go to CAD> Circles> Ellipse  and draw an ellipse.

    In this example, we drew an ellipse that is 18" wide and 12" tall, then centered it on the door.
    Note: You may find using the Point to Point Move edit tool helpful in aligning your ellipse to a specific point on another object. 

  10. Select the three polyline objects inside of the door and use the Copy/Paste  edit button to create copies of these objects beside the door for later use.

    Do this twice, as shown below.

    Three CAD shapes copied twice side by side

Now that you have the general layout of the door panels, you are ready to begin converting it all into a solid object.


To convert to a solid

  1. Select the door outline, which was the first shape created in Step 2 above, click on the Convert Polyline edit tool, choose the Polyline Solid option from the Convert Polyline dialog, then click OK.

    Convert Polyline dialog with Polyline Solid selected


  2. Specify a thickness in the Polyline Solid Specification dialog and click OK.

    In this example, we specified a thickness of 2".


  3. Select the three polyline objects contained inside of the door, and click the Convert Polyline edit tool to convert these into polyline solids as well.

    Polyline Solid Specification with Hole in Polyline Solid selected

    • Specify these as holes in the larger polyline solid by checking the Hole in Polyline Solid box in the Polyline Solid Specification dialog. 


  4. Now, select the next set of three polyline objects that we copied and, and using the Point to Point Move edit tool or the Move edit handle, align them with the newly created holes in your door.


  5. With the polyline objects still selected, click the Convert Polyline  edit tool, convert them to polyline solids, then specify their thickness.

    In this example, 1/4" is used as the thickness.



  6. Return to floor plan view, center the polyline solids created in Step 5 inside the door outline, and then toggle back to the Cross Section/Elevation view.

    Polyline solids moved to center of door object


Now, you are ready to finish off the door by adding trim to the panels.


To finish the panels

  1. Select the final set of the three polyline objects that were copied, click the Convert Polyline edit tool, select the 3D Molding Polyline option, then click OK.

     

  2. On the Moldings panel of the 3D Molding Polyline Specification dialog that opens, assign a different molding profile by clicking the Replace button.

    3D Molding Polyline Specification with CA-03 molding profile selected and a width of 1/4 inch and a height of 2 inches entered

    In this example, the CA-03 molding profile was used, with the width set to be 1/4" and the height 2".


  3. Return to floor plan view and draw a selection marquee around the new 3D molding polyline using the Select Objects tool.

    Selection marquee drawn around the 3D molding polylines


  4. Now, move the molding into place and line it up to the outer edge of the door. You may need to toggle between floor plan and the cross section/elevation view in order to line it up properly. 

    Door object with 3D molding polylines placed over polyline solids


Now that the door is built, the next step is to convert it to a symbol and add it to the library. First, however, you should assign some materials to the door. If all the pieces of the door are left with their default material, you will not be able to customize the materials fully as you might wish later on.


To convert to a door

  1. In the cross section/elevation view, navigate to 3D> Material Painter> Material Painter and select a material of your choosing.


  2. Apply a different material to the trim, panels, and door as shown in the example below.

    Door object with three different areas set to three different materials


  3. Close the cross section/elevation view and select 3D> Create Perspective View> Perspective Full Overview .


  4. Within the perspective full overview, select Tools> Symbol> Convert to Symbol  .


  5. In the Convert to Symbol dialog, choose Door from the Symbol Category drop-down.

    Convert To Symbol dialog with Door selected as the Symbol Category

    • Check Add To Library and Show Advanced Options, then click OK


  6. In the Symbol Specification dialog that appears next, select the 3D panel and specify the Symbol Name that you want displayed in the Library Browser, then click OK to finish adding the door to your library.

Your door is now ready for use in other plans.

You can use any combination of shapes to create a variety of objects and then convert them to the appropriate symbol category depending on your intended use of each object.