Converting Plan Files to DWG or DXF


Reference Number: KB-00013
Last Modified: June 15, 2018

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors


QUESTION

I have a Chief Architect plan file that I need to open in AutoCAD®. How do I convert it from a .plan to a .dwg or .dxf file type?


ANSWER

Converting a Chief Architect plan file into either a two- or three-dimensional AutoCAD® compatible .dwg or .dxf file can be done easily using the export functions.


Line drawings, such as Plan view, elevation views, and CAD Details can be exported as to-scale .dwg or .dxf files.

To export to a 2D DWG or DXF

  1. Select File> Export> Export Current View (DWG, DXF) from the menu.


  2. In the Export Drawing dialog:



    • From the Compatible Version drop-down list, select the version of AutoCAD that you want the exported DWG or DXF file to be compatible with.

    • Select the Layer Set that you would like to export.

    • Click the Export button.

    • For additional information about the options in the Export Drawing File dialog, click the Help button on the bottom of the dialog box


  3. A dialog will appear prompting for a save location:

    • Specify a file name.

    • Choose the location where you'd like to save this file to. Make sure to select an easy to find location, such as your Desktop or the project's folder.

    • Use the drop-down menu to change the Save as type to either .dwg or .dxf

    • Click Save to save the file


Any perspective or orthographic camera view can be exported as a 3D model, including AutoCAD compatible .dwg or .dxf files. 

To export a 3D DWG or DXF

  1. Enter a 3D view by selecting 3D> Create Perspective View> Perspective Full Overview 


  2. Select File> Export> Export 3D Model (DWG, DXF) 



    • From the Compatible Version drop-down list, select the version of AutoCAD that you want the exported 3D drawing to be compatible with.

    • Set the Scaling unit.

    • Click the Export button.


  3. Set the location and file name of the model in the Save 3D Drawing File dialog that appears, and then press Save to save the model.