Using Layer Sets


Reference Number: KB-00765
Last Modified: February 13, 2019

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors



QUESTION

What are layer sets and how can I use them to improve my productivity?  


ANSWER

In Chief Architect, nearly all objects in the program are placed on layers. At any time, you can open the Layer Display Options dialog and turn layers on or off - or change their appearance - to make it easier to work in your plan or to prepare views to be sent to layout or printed.

Working with layers is advantageous because they allow you to design a single file that includes everything needed for your working drawings, while avoiding the frustration of having to constantly change layer properties when switching between views.

Layer sets can be thought of as a stack of transparency sheets gathered together for a particular purpose that can be quickly applied to your drawing. Rather than turning on and off layers one by one, layer sets allow you to quickly switch between one collection of layer attributes and another.

If you're editing your electrical plan, for example, your job will be easier if unrelated objects such as roof planes and ceiling framing are not in the way. You could select Tools> Layer Settings> Display Options from the menu to open the Layer Display Options dialog and then browse the dozens of layers in the list, turning off each unneeded layer for the view you're in; or, you could simply click the Active Layer Set Control drop-down and choose the Electrical Layer Set from the list.

Chief Architect template plan files include a number of layer sets created for a variety of purposes, including:

  • Display settings for different types of views.
  • Display settings for specific drawing tasks.
  • Settings for the Reference Display and Aerial View.

Any changes made to a layer set in one view affects all other views that use the same layer set. If this is not desired, you can create or customize a layer set to suit your needs.

Layer sets are an extremely important consideration when sending views to layout. Please see the Related Articles section for more information on the layout / layer set relationship.



To manage layer sets

  1. Open the plan in which you would like to manage layer sets, or open a New Plan  , and then navigate to Tools> Layer Settings> Layer Set Management .

    Here, you can scroll through the list of the various Layer Sets that are setup in the plan that is open and make modifications.

    Layer Set Management dialog with the Working Layer Set selected

    • To customize layer properties for an existing layer set, select the name of the layer set to highlight it, and then click Define to open the Layer Display Options dialog.

      Layer settings such as line style, line color, line weight, text style, along with whether or not a layer is locked or displayed for the layer set can be specified here.

      Layer Display Options dialog where layer properties can be modified

    • Click the New button to open the New Layer Set dialog and create a new layer set. Layer sets must have unique names. If you try to give the new layer set a name that already belongs to a layer set in the current plan, the program will ask you to choose a new name.

      New Layer Set dialog where a name can be specified

      Once a name is specified and you click OK, the Layer Display Options dialog will open for the newly created layer set allowing you to specify your desired layer settings.

    • Click the Copy button to open the New Layer Set dialog and create a new layer set based on a copy of the currently selected layer set.

      Again, once a name is specified and you click OK, the Layer Display Options dialog will open for the newly created layer set allowing you to specify your desired layer settings.

    • Click the Rename button to rename a layer set and the Delete button to delete layer sets.

      The layer set specified as the Active Layer Set For Current View cannot be deleted.

      It's highly recommended that you don't delete any layer sets that are being referenced or used by a layout file.

    • Click the Import button to import layer settings from a .layers file or the Export button to export the layer settings in the current plan in a .layers file.

      More information on importing and exporting layer sets can be found further down in this article or by accessing the Help button at the bottom of the dialog.

    • The Active Layer Set for Current View option displays the layer set that is used in the view that was active when this dialog was opened.

      For example, if you're in a Cross Section/Elevation view and you access the Layer Set Management dialog, the Section View Layer Set may be the active layer set for the current view.


  2. When you're finished customizing layer sets, click OK to confirm the changes and close the dialog.


To adjust the default layer sets to be used for different views

The Layer Set Defaults dialog controls which layer set is used when a particular type of view is created. For example, when a Cross Section/Elevation view is created, the Section View Layer Set is used for that view; when a Framing Overview is created, the 3D Framing Layer Set is used.

  1. Navigate to Edit> Default Settings ,  click on Layer Sets, and then click Edit.


  2. In the Layer Set Defaults dialog, notice the layer sets that are setup for each particular type of view.




  3. Make any desired changes, then click OK.


To switch between layer sets using the Active Layer Set Control drop-down

The Active Layer Set Control drop-down toolbar option is a commonly used method to easily switch between layer sets, no matter what type of view you're in.

  1. Open a view that you want to switch the layer set for.


  2. On your toolbar, look for the Active Layer Set Control drop-down, click on it once, and select your desired layer set to use for the view.

    Selecting the Electrical Layer Set in the Active Layer Set Control drop-down



  3. When you select a layer set, it will instantly be applied to the current view.


To switch between layer sets using Saved Plan Views*

*Only available for saved floor plan views in Chief Architect X10 and newer product versions.

Saved plan views are linked to annotation and layer sets, and allow you to switch between them simultaneously with a single click. When a plan view is changed to a different plan view, the layer set may change if it's specified to do so within that plan views specification dialog.

  1. Open a view that you want to switch the layer set for.


  2. On your toolbar, look for the Saved Plan View Control drop-down, click on it once, and then select a different saved plan view from the list. You can also switch between saved plan views by accessing the Project Browser side window.

    Electrical Plan View selected in the Saved Plan View Control drop-down


    Notice that when you switch between saved plan views, the layer set will also change.

    Saved Plan View Control drop-downand the Active Layer Set Control drop-down


    Note: If changing the plan view does not also change the active layer set, the plan view may not be setup to change or it's not linked correctly to the view. Please refer to Saved Plan Views to learn more. 


To switch between layer sets using the Active Defaults

You can view and change the defaults that are currently active for the view you're in by clicking the Active Defaults toolbar button or by accessing the Active Defaults within the Default Settings. You can switch between layer sets here as well if you prefer.

  1. Open a view that you want to switch the layer set for.


  2. Select the Active Defaults toolbar button or navigate to Edit> Default Settings , click on Active Defaults, and then click Edit.


  3. In the Active Defaults dialog that opens, click on the Layer Set drop-down and select the desired layer set to use for the view.

    Selecting the active layer set in the Active Defaults dialog


  4. When you select a layer set and hit OK to confirm the change, the active view will switch to the layer set specified.


To switch between layer sets using the Active Layer Display Options

The Active Layer Display Options is a side window that is typically docked beside the Project Browser and Library Browser. This side window allows you to see and make layer-related changes on the fly for the view that's active. The layer set can also be changed here if it's displayed.

  1. Open a view that you want to switch the layer set for.


  2. If the Active Layer Display Options is not displayed, navigate to View> Active Layer Display Options to turn on the display of this side window.


  3. Click the Settings button at the bottom of this side window and enable the Layer Set Control option to be displayed if it's not already.

    Turning on the Layer Set Control for the Active Layer Display Options side window



  4. With the Layer Set Control now displayed, the layer set can be changed for the active view.

    Changing the layer set using the Layer Set Control in the Active Layer Display Options side window


To switch between layer sets using Annotation Sets

Annotation sets are a collection of saved defaults for many of the tools used to annotate a plan, such as text, arrows, callouts, markers, and dimensions. However, a layer set, along with the current CAD layer can also be linked to an annotation set. If you're working with plan views, it's recommended to switch between layer sets using the Saved Plan View Control drop-down as this can change the annotation and layer set in a single click. In views where the Saved Plan View Control drop-down is not available, such as section and CAD detail windows, you may want to change the text or dimension size, along with the layer set all in a single go. To do this though, you must setup your annotation sets to link to the desired layer sets. Please refer to Annotation Set Basics to learn more.


To export and import layer sets

Once you have created custom layer sets like in one of your plans, you can transfer them into other plan files by exporting and then importing them.

  1. In the plan file where you created or customized layer sets, select File> Export> Export Layer Sets from the menu or navigate to Tools> Layer Settings> Layer Set Management , and click on the Export button.

    All layers in the file will be exported to a .layers file no matter which method is chosen.


  2. In the Save Layer Set File dialog, type a short, descriptive Name and choose an easy-to-find location on your computer such as the Desktop or Documents, then click OK.


  3. Open a plan file in which you would like to use your custom layer sets, select File> Import> Import Layers Sets from the menu or navigate to Tools> Layer Settings> Layer Set Management , and click on the Import button.


  4. In the Import Layer Set File dialog, browse to the location where you saved your file in step 2 above, select it, and click the Open button.


  5. In the Import Layer Sets dialog which opens next, browse through the list of layer sets and select the layer set(s) that you would like to import into the current plan.

    Import Layer Sets dialog with two layer sets set to replace existing layer sets within the plan they are being imported into

    • Choose whether you want to Replace existing layer sets that have the same name or to Create a new copy.

      If you're importing layer sets that have the same name as existing layer sets already present in the file, and you choose the Create a new copy option, the new, imported layer sets will have a number appended onto the name.

    • Click OK to close the dialog and import the selected layer sets.


To modify all layer sets in a file

In most cases, you will want changes that you make to a given layer set to affect only that individual set. Occasionally, though, you may find it helpful to apply a particular change to all layer sets in a plan.

  1. Select Tools> Layer Settings> Display Options from the menu.


  2. Click the Layer Sets drop-down arrow and select a layer set from the list.


  3. Check the box beside Modify All Layer Sets.


  4. Make any changes that you want to any layer(s) that you would like reflected in all layer sets.


  5. Uncheck the box beside Modify All Layer Sets once your desired changes have been made.


  6. Click OK to close the dialog and apply your changes to all layer sets in the current plan or layout.


Return To Top